blob: e1706df9857f673bceab23385dbcc780ae9d18f6 [file] [log] [blame]
Pau Espin Pedrol0f9966e2021-11-16 17:57:50 +01001osmo-sgsn (1.8.0) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * Remove bogus DNS log category
5
6 [ Daniel Willmann ]
7 * manuals: Regenerate counters/VTY through docker
8
9 [ Vadim Yanitskiy ]
10 * main: resurrect removed 'ns' logging category as deprecated
11 * doc/manuals: update configuration.adoc to use new command syntax
12 * tests/Makefile.am: do not try removing non-existing files
13
14 [ Pau Espin Pedrol ]
15 * ranap: log ranap iu event type name instead of number
16 * gmm: log GMM msg type name instead of number
17 * gmm: Expect E_VLR_ANSWERED when in ST_IU_SECURITY_CMD
18 * gmm_fsm: Expect E_GMM_COMMON_PROC_INIT_REQ when in ST_GMM_COMMON_PROC_INIT
19 * mm_iu: Send event E_PMM_PS_CONN_ESTABLISH upon rx GMM SERVICE REQUEST
20 * mm_iu: Expect E_PMM_PS_ATTACH when in ST_PMM_IDLE
21 * gprs_gmm.c: State proper GMM prefix logging rx/tx of GMM messages
22 * mm_state_iu_fsm: T3314 expiry must lead to PMM IDLE, not PMM DETACHED
23 * Iu: Drop timer X3314
24 * gprs_ranap.c: Clean up code path releasing IU conn
25 * mm_state_{gb,iu}_fsm: Add missing license block, improve spec references
26 * mm_state_{gb,iu}_fsm: Improve naming for detach event
27 * Drop unused GBRPOXY enum field
28 * gtp: Delete ctx upon receive UpdateCtxResp with cause Non-existent
29 * Support forwarding RIM messages over GTPCv1 EUTRAN<->GERAN
30 * Use new stat item/ctr getter APIs
31
32 [ Keith ]
33 * vty: Fix optional display of pdp with mm-context
34 * VTY: Don't display 'PDP Address: invalid' for IPv4v6
35
36 [ Eric ]
37 * add support for multiple encryption algorithms and a5/4
38
39 [ Oliver Smith ]
40 * gtphub: remove llist_first, llist_last macros
41 * vty: add "page imsi"
42 * debian/control: remove dh-systemd build-depend
43 * Revert "Turn some compiler warnings into errors"
44
45 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 17:57:50 +0100
46
Pau Espin Pedrol80adb302021-02-23 20:29:33 +010047osmo-sgsn (1.7.0) unstable; urgency=medium
48
49 [ Daniel Willmann ]
50 * gprs_gmm: Check for RAT change and ensure this only happens for RAU/ATT
51 * gbproxy-usermanual: Explain BSSGP/BVC handling
52 * gbproxy: Whitespace fixes
53 * gbproxy: Add todo for BVC RESET logic
54 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
55 * Let libosmocore handle VTY parent node tracking
56 * osmo-gbproxy: Free msgb in ns2 prim callback
57 * configure.ac: Require python3 for ext_tests
58 * osmo-gbproxy: Implement nsvc-state ctrl command
59 * gbproxy: Remove test testing NSVCI change
60 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
61 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
62 * gbproxy: Only send paging to each matching NSE once
63 * gbproxy: Separate function to move gbproxy_peer to different nse
64 * gbproxy: Add logging macros for NSE and BVC
65 * gbproxy: Use LOG macros for NSE/BVC
66 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
67 * gbproxy: Add todos encountered while going through the code
68 * gbproxy: Add BVC log filters
69 * gbproxy: Add newline to log message
70 * gbproxy: Allow gbproxy_nse_free(NULL)
71 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
72 * mm_state_gb_fsm: Handle implicit detach from mm_standby
73 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
74 * osmo-gbproxy: Initialize all hash_maps
75 * gbproxy: Fix confusing log message in gbprox_relay2nse
76 * gbproxy: Add SGSN NRI configuration
77 * gbproxy: Add SGSN pooling support
78 * gbproxy: Add comments to sgsn functions
79 * gbproxy: Add config option to name an SGSN
80 * gbproxy: Add VTY command to override the node selection function
81 * Fix gbproxy_sgsn_by_tlli wraparound
82 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
83 * gbproxy: Increase TLLI cache timeout to 10s
84 * gbproxy: Implement IMSI cache
85 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
86 * gbproxy: Use C-style comments
87 * gbproxy: Move helper function to a more logical place
88 * gbproxy: Remove unused variable assignment
89 * gbproxy: Fix VTY cmd name
90 * gbproxy: Define and use help string for gbproxy
91 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
92 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
93 * gbproxy: Print the correct message type for dummy paging/paging reject
94 * gbproxy: Improve log messages in gbproxy_select_sgsn
95 * gbproxy: Fix radio status routing by TMSI
96 * manual/gbproxy: Update overview chapter
97 * Rename OsmoGbPROXY -> *Proxy
98 * manuals/gbproxy: Update configuration chapter
99 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
100 * manuals/gbproxy: MSC -> SGSN for pooling chapter
101 * manuals/gbproxy: Move pooling to separate chapter
102
103 [ Alexander Couzens ]
104 * gprs_gmm_fsm.c: Implement RAT change between 2g and 3g
105 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
106 * gprs_llc: _bssgp_tx_dl_ud: ensure the LLME is valid before using it
107 * gmm: on invalid RA id reject the MS with an implicit detach
108 * gtphub_test: fix compilation error on gcc 10.2.0
109 * gtphub: fix compilation with gcc 10.2.0
110 * Port gbproxy to NS2
111 * sgsn: check for NULL of gprs_subscr_get_or_create()
112 * sgsn: Use the new NS2 api
113 * gbproxy: use ns2 vty2
114 * configure.ac: define a c standard instead of using the compilers default
115 * follow libosmocore/gprs_ns2 API changes of GPRS enums
116 * gbproxy: follow gprs_ns2 API vty changes
117 * sgsn: migrate to the new gprs_ns2_vty configuration
118 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
119
120 [ Neels Hofmeyr ]
121 * manual: explain IuPS, add SCCP/M3UA section from common chapters
122 * fix nullpointer: in gsm48_rx_gmm_ra_upd_req()
123 * gsup: send RAT type on LU
124 * gbproxy_test.c: fix mobile identity test data
125 * use new osmo_mobile_identity API everywhere
126
127 [ Eric ]
128 * tests: dlopen does not imply availability of dlsym..
129 * configure.ac: fix libtool issue with clang and sanitizer
130
131 [ Harald Welte ]
132 * gtphub_test: Fix compilation with gcc-10
133 * Fix memory leak when SNDCP de-fragmentation is used
134 * Treat RAU as implicit RESUME if GMM is suspended
135 * *.spec.in: Use %config(noreplace) to retain current config file
136 * Send a BVC-RESET to all persistent Gb interfaces at start-up
137 * Use osmo_fd_setup() whenever applicable
138 * Use osmo_fd_*_{disable,enable}
139 * gbproxy: Properly implement paging to LAC/RAC
140 * gbproxy: Implement paging to entire BSS area
141 * gprs_gb_parse: Add function to determine TLLI from encoded BSSGP
142 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
143 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
144 * gb_proxy: More precise + readable log messages
145 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
146 * gbproxy: Move BSS-side BVC-RESET processing to its own function
147 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
148 * gbproxy: Cosmetics: use longer lines
149 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
150 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
151 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
152 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
153 * gbproxy: convert bss_nses from llist_head to hashtable
154 * gbproxy: convert nse->bvcs from llist_head to hashtable
155 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
156 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
157 * gbproxy: Delete gbproxy_test
158 * gb_proxy: Introduce more validation / constraint checks
159 * gbproxy: use gbprox_relay2peer() whenever possible
160 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
161 * gbproxy: Log FSM timeouts
162 * migrate to DLBSSGP as log sub-system for BSSGP
163 * gbproxy major rewrite for SGSN pool support
164 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
165 * gbproxy: Introduce new DOBJ log category; log object allocation/release
166 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
167 * gbproxy: Implement handling of BVC Flow Control
168 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
169 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
170 * gbproxy: Fix segfault when receiving PAGING for unknown destination
171 * gbproxy: Add FSM related VTY commands
172 * gbproxy: Implement scaling of BVC flow control in SGSN pool
173 * gbproxy: Improve VTY state introspection
174 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
175 * gbproxy: Add "show gbproxy cell ..." VTY command
176 * gbproxy: Fix build on Deiban 8
177 * gb_proxy: Don't use orphan log subsystem DPCU
178 * gbproxy: Avoid depending on any of the SGSN code
179 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
180 * manuals: generate vty reference xml at build time
181
182 [ Pau Espin Pedrol ]
183 * Use OSMO_FD_* instead of deprecated BSC_FD_*
184 * sgsn_libgtp: Improve ps-paging logging
185 * gprs_gmm_fsm.c: Add missing license header
186 * sgsn_libgtp: Avoid ps-paging MS on GMM Suspended state
187 * configure.ac: Fix trailing whitespace
188 * doc: Update VTY reference xml file
189 * Support setting rt-prio and cpu-affinity mask through VTY
190 * Change default SCTP conn NULL->127.0.0.1 to localhost->localhost
191 * contrib/jenkins: Enable parallel make in make distcheck
192 * Log error if pdp ctx is freed while holding an active timer
193 * Fix crash rx DeactPdpReq while waiting for DeactPdpAck after gtp side is freed
194 * sgsn_delete_pdp_ctx: Add documentation and assert assumptions
195 * process_ms_ctx_status: refactor to avoid code duplication
196 * process_ms_ctx_status: Fix crash deleting PDP Ctx if GTP side was already released
197 * gbproxy: generate coredump and exit upon SIGABRT received
198 * gtphub: generate coredump and exit upon SIGABRT received
199 * sgsn: generate coredump and exit upon SIGABRT received
200 * gmm: fix build without define PTMSI_ALLOC
201 * gmm: Introduce comment to ease addition of Network feature support IE later
202 * .gitignore: Ignore new autofoo tmp files
203 * sndcp: Fix struct bit fields on big endian
204 * Fix nsei+bvci not updated on rx UL SNDCP data
205
206 [ Oliver Smith ]
207 * contrib: import RPM spec
208 * contrib: integrate RPM spec
209 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
210 * contrib/jenkins: don't build osmo-gsm-manuals
211 * gbproxy: remove (moved to own repository)
212
213 [ Vadim Yanitskiy ]
214 * debian/control: change maintainer to the Osmocom team / mailing list
215 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
216 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
217
218 [ Keith ]
219 * Fix Radio Priority in MM Attach and PDP Context Activation
220 * VTY: Add gtp state-dir command
221
222 [ Philipp Maier ]
223 * gprs_sndcp: fix use after free
224 * sgsn_rim: Add routing for (GERAN) BSSGP RIM messages
225
226 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 20:29:33 +0100
227
Pau Espin Pedrol394aa532020-01-03 19:17:56 +0100228osmo-sgsn (1.6.0) unstable; urgency=medium
229
230 [ Pau Espin Pedrol ]
231 * gprs_gmm: Introduce macros to access msgb's associated IU UE ctx
232 * gprs_llc.h: Improve documentation of some structs
233 * gprs_gmm.c: Improve doc on nullable parameters
234 * gprs_gmm.c: Drop unneeded brackets
235 * Introduce define TLLI_UNASSIGNED
236 * gprs_sgsn.c: Warn upon llme free unexpected scenarios
237 * gprs_gmm: Clarify comment during TLLI assignment
238 * gprs_sgsn.c: Remove recently introduced assert
239 * gprs_gmm: Introduce assert to guard against unexpected condition
240 * gprs_gmm.c: Use correct function to set MM_IDLE state during cleanup
241 * gprs_sgsn.h: Flag MM_CTX_T_GERAN_Iu as not supported
242 * gprs_gmm.c: Flag mmctx_set_(p)mm_state() functions static
243 * sgsn: use sccp_simple_client API to setup ss7 id 0 instead of 1
244 * gprs_gmm.c: Fix typo in log message
245 * gprs_gmm.c: Call mmctx_set_(p)mm_state only on related ran_type
246 * Introduce and use log macros when no mm ctx available
247 * gprs_gmm: Avoid spaces in fsm events and enum strings
248 * tests: Verify that timers can be set over VTY
249 * Replace own timer infra with libosmocore osmo_tdef
250 * tests: Introduce vty-transcript-test tests
251 * gprs_gmm.c: Use osmo_rai_name() in log line
252 * examples: Add osmo-sgsn_custom-sccp.cfg
253 * vty: Introduce cs7-instance-iu
254 * gprs_gmm.c: Print value_string of reject cause
255 * gprs_gmm.c: Add spec document to function documentation
256 * gtp: make echo_interval unsigned
257 * gtp: cb_delete_context(): Clarify why pdp->lib is set to NULL
258 * Introduce log helper LOGGGSN and log category DGTP
259 * sgsn: gtp: Drop related pdp contexts on echo timeout against GGSN
260 * Move lots of Iu/ranap specific code into its own file
261 * Move llc->MM/SM Gb specific glue code to its own file
262 * Split enum gprs_pmm_state into Iu and Gb counterparts
263 * Merge common allocation steps for Gb and Iu ctx
264 * gprs_gmm.c: Replace inet_ntoa with inet_ntop
265 * sgsn_cdr.c: Fix ip addr string buffer size
266 * sgsn_vty: Fix mmctx rate_ctr output indentation
267 * sgsn_vty: Print correct Iu mmctx id in 'show mm-context'
268 * Introduce FSM mm_state_gb_fsm
269 * Introduce FSM mm_state_iu_fsm
270 * vty: Print MM state and RAN type in show mm-context
271 * src/gprs/Makefile.am: Move build of shared .c files to an internal lib
272 * Move out gbproxy to its own subdir
273 * Move out gtphub to its own subdir
274 * Move out sgsn to its own subdir
275 * gmm: Move code handling GMM Attach Complete to its own function
276 * gmm: Move code handling GMM Routing Area Update Complete to its own function
277 * gmm: Move code handling GMM PTMSI Realloc Complete to its own function
278 * enum gprs_gmm_state: Fix spec reference
279 * Implement GMM State using osmocom FSM
280 * Split out GPRS SM layer into its own file
281 * sgsn: Reject PdpActReq if no GTP pdp ctx exists
282 * Introduce TODO-RELEASE file
283 * sgsn_libgtp.c: Drop use of deprecated libgtp APIs gtp_retrans*()
284 * gmm: Fix assertion hit during RA UPD REQ before completting gmm attach
285 * Improve logging in gprs_llc.c code
286 * gprs_llc.c: Use enum instead of hardcoded value
287 * gprs_gmm.c: Send XID reset with received TLLI
288
289 [ Alexander Couzens ]
290 * gprs/gprs_gmm: implement T3314. Timeout to reset MM state READY->STANDBY
291 * gprs_gmm: only update gb/iu cell information when Iu/Gb present
292 * gprs_gmm: clarify comment of Iu follow-on request
293 * gprs_gmm: gsm48_rx_gmm_att_req(): refactor duplicated code
294 * sgsn_pdp_ctx_terminate: check llme before accessing
295 * gprs_ranap: send CommonId after receiving Security Mode Complete
296 * mm_gb_fsm: unassign the llme when entering MM_IDLE
297 * gprs_ranap: refactor REQUIRE_MM define
298 * sgsn: when receiving data PDU notify the Gb GMM fsm
299 * Avoid compiling unneeded files when building without Iu
300 * gprs_ranap: release Iu UE Context when exiting PMM Connected
301 * Iu: implement a user inactivity timer
302 * gprs_ranap: on Iu release, stop the attach fsm if running
303 * gprs_mm_state_gb_fsm: ensure T3350 is not running when entering IDLE
304 * gprs_ranap: add missing rc = 0
305 * gprs_sgsn: always allocate Gb/Iu mm fsm
306 * sgsn: MM Gb Fsm: fix event handling for implicit detach
307 * ranap: add non-spec X1001
308 * gprs_gmm: release Iu connection on RAU failures
309 * sgsn_mm_ctx_alloc(): check for unallocated fsms
310 * sgsn_libgtp: refactor ps paging into gprs_gb
311 * sgsn: Gb: implementing PS Paging when MS is MM_STANDBY
312
313 [ Vadim Yanitskiy ]
314 * gprs_mm_state_iu_fsm.c: fix: assign timer_cb to mm_state_iu_fsm
315
316 [ Max ]
317 * Use libosmocore constant for IMSI length in ACL entry
318
319 [ Harald Welte ]
320 * LLC: Don't use hard-coded N201-U / N201-I values in XID
321 * Initial OsmoGbPROXY user manual
322 * check for osmo_fsm_register() error return values
323 * check for osmo_ss7_init() error return value
324 * manual: Fix copy+paste error
325 * exit(2) on unsupported positional arguments on command line
326
327 [ Oliver Smith ]
328 * gitignore: fix paths to binaries
329 * doc: add OsmoGbProxy VTY reference
330 * regen_doc.sh: support gbproxy, run without docker
331 * osmoappdesc.py, tests: switch to python 3
332
333 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:17:56 +0100
334
Pau Espin Pedrold7ef94c2019-08-08 16:46:31 +0200335osmo-sgsn (1.5.0) unstable; urgency=medium
336
337 [ Max ]
338 * Improve 'show subscriber cache' vty command
339 * GMM: permit VLR_ANSWERED event in attach FSM
340 * Fix IMSI padding in imsi-acl
341
342 [ Harald Welte ]
343 * gbproxy_test: Fix test expectations of gprs_ns_rcvmsg()
344 * LLC XID: Fix string representation of N201_U
345 * LLC: Don't blindly assume all LLC frames have data payload
346 * LLC: Avoid NOTICE message on LLC NULL
347 * gprs_llc: Correctly refuse any ABM command (SABM, DISC) with DM
348 * LLC: Store the XID inside the LLC Entity, not LLC Mgmg Entity
349 * gb_proxy.h: Add missing comments; improve comments
350 * gb_proxy: cosmetic: Use 'bool' in data structures where applicable
351
352 [ efistokl ]
353 * gsm0408_rcv_gmm: send Iu-ReleaseCommand upon receiving Attach Complete.
354 * gprs_gmm: send Service Reject when no PDP ctxs are available.
355
356 [ Alexander Couzens ]
357 * gprs_gmm: reintroduce calling gsm48_gmm_authorize when not handling GMM Attach Requests
358 * gbproxy: parse dtap GSM48_MT_GSM_DEACT_PDP_REQ|ACK
359
360 [ Pau Espin Pedrol ]
361 * gprs_sndcp_comp_free: Replace ifelse with switch and better handling of error
362 * sgsn: vty: Improve log warning content with spec section
363 * Document max retransmit times for T3395
364 * sgsn: Fix echo timer not started upon first pdp ctx created
365 * sgsn_libgtp: Use new per-GSN libgtp API instead of deprecated API
366 * sgsn: Have authentication required on by default
367 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
368 * Require newer versions of dependencies
369
370 [ Keith ]
371 * Echo zero byte XID-Field of Type L3_PAR
372
373 [ Oliver Smith ]
374 * debian: create -doc subpackage with pdf manuals
375 * contrib/jenkins.sh: run "make maintainer-clean"
376 * osmo-gtphub.cfg: fix conflict with osmo-sgsn.cfg
377 * osmo-gbproxy.cfg: fix conflict with osmo-sgsn.cfg
378
379 [ Vadim Yanitskiy ]
380 * doc/manuals/vty: regenerate sgsn_vty_reference.xml
381 * osmo-sgsn: add VTY parameter to toggle authentication
382 * sgsn_mm_ctx_find_ggsn_ctx(): fix: always set gsm_cause
383
384 [ Eric Wild ]
385 * replace magic tmsi constant with define
386 * turn -Werror=null-dereference into a warning
387
388 [ Daniel Willmann ]
389 * manuals: Add script to regenerate vty/counter documentation
390 * manuals: Update vty/counter documentation
391 * Add/fix help string for version option
392 * osmo-sgsn: Fix outdated information in usermanual
393 * configuration.adoc: Small fixes
394 * configuration.adoc: Add a section about encryption
395
396 [ Ruben Undheim ]
397 * Spelling fixes
398
399 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 16:46:31 +0200
400
Harald Welte319a52b2019-01-23 18:32:41 +0100401osmo-sgsn (1.4.0) unstable; urgency=medium
402
403 [ Alexander Couzens ]
404 * gprs_subscriber: gsup_auth_error: reject MS in all cases
405 * gprs_gmm: make functions relating to GMM Attach Request public
406 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
407 * gprs_gmm: Cancel Location: use detach type IMSI
408 * vty: add cmd "reset sgsn state"
409 * tests: remove gmm unit tests
410 * gprs_gmm: introduce a GMM Attach Request FSM
411 * debian: add missing build dependencies
412 * sgsn: use gtp_clear_queues() when reset sgsn state
413 * vty: restart sgsn state: improve output message
414 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
415 * gprs_sgsn.h: fix wrong type of re-attempts
416 * GTP: refactor the echo timer
417 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
418 * gprs_gmm: Fix missing Security Command for 3G when attaching
419 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
420 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
421 * OsmoSGSN: add rate counter documentation
422
423 [ Daniel Willmann ]
424 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
425 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
426 * git-version-gen: Don't check for .git directory
427
428 [ Stefan Sperling ]
429 * add a test for OS#3178 (invalid unitdata message)
430 * finish gbproxy_parse_bssgp_unitdata test
431 * fix bogus assertion in encode_comp_field()
432 * fix bogus error check in gprs_sndcp_comp_create()
433 * use enums consistently instead of falling back to int
434 * update gbproxy test expected output
435 * consistently check the result of osmo_shift_v_fixed()
436 * remove pointless declaration of struct gsm_network
437 * make gsup ipa name configurable in osmo-sgsn.cfg
438
439 [ Pau Espin Pedrol ]
440 * jenkins.sh: Use --enable-werror only when iu support is disabled
441 * jenkins.sh: Remove non-existent configure options
442 * Drop all references of unused SMPP
443 * Drop all references of unused MGCP
444 * Drop unused common_vty.c
445 * sgsn_libgtp.c: Log pointer of deleted context
446 * Maintain per ggsn pdp ctx list
447 * osmo-sgsn: ping GGSN periodically and check for restart counter
448 * Disarm T3395 when dettaching mmctx from pdpctx
449 * examples: Enable by default echo req towards active GGSNs
450 * vty: Add cmd to disable echo loop explictly
451 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
452 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
453 * Forward GGSN originated DEACT PDP CTX REQ
454 * sgsn: Fix T3395 firing forever
455 * sgsn: subscriber: Avoid calling memcpy with NULL src
456 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
457 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
458 * sgsn: Fix crash using new libgtp cb_recovery2 API
459 * gbproxy: Replace '.' in counter names with ':'
460 * Drop gprs_msgb_copy with libosmocore replacement
461 * Drop gprs_msgb_resize_area with libosmocore replacement
462 * Use osmo_clock_gettime from libosmocore
463 * gbproxy: Add VTY parameter: link stored-msgs-max-length
464 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
465 * gbproxy: Replace '.' in counter names with ':'
466 * Add osmo-gtphub systemd service file
467 * debian: Fix typo in rules preventing build with IU support
468 * Install systemd services with autotools
469 * Install sample cfg file to /etc/osmocom
470 * Update wrong references to bsc in sgsn code
471 * Allocate sgsn_instance with talloc
472 * gbproxy: flag gbproxy_assign_imsi as static
473 * gbproxy: Fix abort during APN patch
474 * gbproxy: Remove unneeded parse_ctx param
475 * gbproxy: flush_stored_messages: Move comment to func description
476 * gbproxy: flush_stored_messages: Log and route using stored_msg info
477 * gbproxy: flush_stored_messages: Get rid of msg param
478 * Allow easily disabling GFDL references
479 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
480 * OsmoSGSN: configuration: Add missing pdp-periodic event
481 * OsmoSGSN: configuration: Document CDR CTRL interface
482 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
483
484 [ Harald Welte ]
485 * migrate to oap_client in libosmogsm
486 * remove libcommon
487 * gbproxy-legacy: Ensure well-formed config file
488 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
489 * initial checkin of manuals to public repo
490 * Add link to Asciidoc source code of manual
491 * OsmoSGSN: Fix formatting/cross reference in CDR section
492 * Update GSUP chapter regarding UMTS AKA and other recent changes
493 * GSUP: Add ladder diagrams for protocol transactions / procedures
494 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
495 * vty-ref: Update URI of docbook 5.0 schema
496
497 [ Neels Hofmeyr ]
498 * use __FILE__, not __BASE_FILE__
499 * vty: fix doc str for 'reset sgsn state'
500 * vty: add SCCP related vty commands
501 * fix build: remove unused variable
502 * Importing history from osmo-gsm-manuals.git
503 * add 'make check' target
504 * fix 'make clean': shell glob, ignore failure
505 * refactor Makefile build rules, don't use the FORCE
506 * OsmoSGSN: update VTY reference
507 * sgsn: update vty reference
508
509 [ Oliver Smith ]
510 * gtphub: Add --version cmdline option
511 * build manuals moved here from osmo-gsm-manuals.git
512 * Fix DISTCHECK_CONFIGURE_FLAGS override
513 * contrib/jenkins.sh: build and publish manuals
514 * contrib: fix makedistcheck with disabled systemd
515
516 [ Max ]
517 * Cleanup non-existent files from debian/copyright
518 * Use safer functions for IMSI ACL
519 * gbproxy: fix formatting in gbproxy-state command
520 * gbproxy: add number-of-peers ctrl command
521 * Revert "gbproxy: fix formatting in gbproxy-state command"
522 * Add OsmoSGSN control interface description
523 * Remove misleading comment
524 * Constify sgsn_acl_lookup() parameter
525 * Drop unused osmo-sgsn.pc
526 * Use explicit length check
527 * Use explicit parameter for sgsn_auth_init()
528
529 [ Jonathan Brielmaier ]
530 * fix various typos across all manuals
531
532 [ ikostov ]
533 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
534 * GSUP, OAP: fix AUTS length to 14, not 16
535
536 [ Philipp Maier ]
537 * osmo-sgsn: Update VTY command reference
538 * osmo-sgsn: improve auth-policy explaination
539 * osmo-sgsn: Explain TCP/IP header compression
540 * osmo-sgsn: fix arrow tips in flow diagrams
541
542 [ Holger Hans Peter Freyther ]
543 * sgsn: Fix numbering of QoS and add basic description for APN
544 * sgsn: Add charging characteristics to GSUP
545
546 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
547
Pau Espin Pedrol39c67e22018-05-03 19:01:44 +0200548osmo-sgsn (1.3.0) unstable; urgency=medium
549
550 [ Neels Hofmeyr ]
551 * drop osmo_sgsn.cfg from src/gprs dir
552 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
553 * vty: skip installing cmds now always installed by default
554 * add --enable-sanitize config option
555 * use default point-code as listed on Point_Codes wiki page
556 * gprs_gmm: segfault: gracefully handle failure to alloc context
557 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
558 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
559 * fix build: missing LIBGTP_CFLAGS in sgsn_test
560 * sgsn_test: guard against struct gprs_ra_id changing
561 * vty: absorb command explanations from osmo-gsm-manuals
562 * configure: add --enable-werror
563 * implement support for 3-digit MNC with leading zeros
564 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
565 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
566 * use osmo_init_logging2(), fix regression test memleaks
567 * auth+ciph: log is_r99 and auth types
568 * log two RA Update Request failure causes
569 * GERAN: allow GSM SRES on UMTS AKA challenge
570
571 [ Alexander Couzens ]
572 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
573 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
574 * debian: remove doublicated project name in example files
575 * .gitignore: remove non-existent /src/utils exludes
576 * configure.ac: remove pcap check
577 * configure.ac: remove unused libcdk check
578 * .service: remove OpenBSC from service desription
579 * mandatory depend on libc-ares and libgtp
580 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
581
582 [ Harald Welte ]
583 * Replace '.' in counter names with ':'
584 * Add talloc context introspection via VTY
585
586 [ Pau Espin Pedrol ]
587 * Replace '.' in counter names with ':'
588 * tests: Fix selection of python version
589 * sgsn_cdr: Split log formatting into a snprintf function
590 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
591 * tests: sgsn_test: Define wrap APIs with correct parameters
592 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
593 * gprs_gmm: Remove unused variable
594 * cosmetic: gprs_gmm: Remove trailing whitespace
595 * gprs_gmm: Convert warning message to pragma message
596 * configure.ac: Enable Wall in CFLAGS
597 * .gitignore: Add m4 files
598 * sgsn_libgtp.c: Fix typos and whitespace
599
600 [ Max ]
601 * Fix display of GTP addresses
602 * Show GTP version for PDP context in vty
603 * Remove unneeded .py scripts
604 * Replace '.' in counter names with ':'
605 * Remove dead code
606 * Enable sanitize for CI tests
607 * cosmetic: use macro for gtphub plane iteration
608 * Use connection id when allocating rate counters
609 * Migrate from OpenSSL to osmo_get_rand_id()
610 * Remove obsolete ./configure option
611 * Fix RAI construction
612 * gtphub: make rate_ctr unique
613 * Remove unused bsc_version.c
614 * Use gsm48_encode_ra() for RAI encoding
615 * gtphub: check for gsn_addr_from_sockaddr() errors
616 * gtphub: check for gsn_addr_from_sockaddr() error
617
618 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
619
Harald Welte467cfeb2017-10-28 19:07:48 +0200620osmo-sgsn (1.2.0) unstable; urgency=medium
621
622 [ Neels Hofmeyr ]
623 * jenkins: fix build: remove unused dependencies
624 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
625 * drop files unrelated to osmo-sgsn
626 * rewrite README
627 * configure.ac: set name to osmo-sgsn, fix ML addr
628 * move openbsc.pc to osmo-sgsn.pc
629 * move include/openbsc to include/osmocom/sgsn
630 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
631 * jenkins: use osmo-clean-workspace.sh before and after build
632
633 [ Alexander Couzens ]
634 * debian: fix paths of examples
635 * debian/rules: show testsuite.log when tests are failing
636
637 [ Max ]
638 * Remove rest_octets.h
639 * gbproxy: ensure peer allocation result
640 * jenkins: use osmo-ggsn for tests
641 * Cleanup configure checks
642 * Use extended logging for PDP contexts
643 * deb: fix copyright file issues
644 * Move P-TMSI alloc/update into separate function
645 * Check for correct P-TMSI allocation
646 * Use new FSF address in license header
647 * SGSN: uncomment BSSGP vty tests
648 * SGSN: print additional GTP-related info
649 * SGSN: check that GSN is created in proper mode
650 * Fix APN printing
651 * Fix build after recent rate_ctr patches
652 * gbproxy: don't link unnecessary
653 * Fix libosmo-sigtran dependency
654 * jenkins: check for IU properly
655 * Log GTP-U endpoints update
656 * Log address on GTP creation
657
658 [ Pau Espin Pedrol ]
659 * Remove unneeded dep libdbi
660
661 [ Philipp Maier ]
662 * log: fix default loglevels
663 * non-iu-build: guard vty libosmo-sigtran function calls.
664 * configure: fix libosmo-sigtran dependency
665
666 [ Harald Welte ]
667 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
668 * Debian: fix dh_strip rules for creating one -dbg per program
669
670 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
671
Alexander Couzens508c7632017-08-07 09:48:18 +0000672osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200673
Alexander Couzens508c7632017-08-07 09:48:18 +0000674 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200675
Alexander Couzens508c7632017-08-07 09:48:18 +0000676 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000