blob: 2edc6e66f88f359e6cf1ddfb9c807de9c88c34bf [file] [log] [blame]
Pau Espin Pedrol80adb302021-02-23 20:29:33 +01001osmo-sgsn (1.7.0) unstable; urgency=medium
2
3 [ Daniel Willmann ]
4 * gprs_gmm: Check for RAT change and ensure this only happens for RAU/ATT
5 * gbproxy-usermanual: Explain BSSGP/BVC handling
6 * gbproxy: Whitespace fixes
7 * gbproxy: Add todo for BVC RESET logic
8 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
9 * Let libosmocore handle VTY parent node tracking
10 * osmo-gbproxy: Free msgb in ns2 prim callback
11 * configure.ac: Require python3 for ext_tests
12 * osmo-gbproxy: Implement nsvc-state ctrl command
13 * gbproxy: Remove test testing NSVCI change
14 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
15 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
16 * gbproxy: Only send paging to each matching NSE once
17 * gbproxy: Separate function to move gbproxy_peer to different nse
18 * gbproxy: Add logging macros for NSE and BVC
19 * gbproxy: Use LOG macros for NSE/BVC
20 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
21 * gbproxy: Add todos encountered while going through the code
22 * gbproxy: Add BVC log filters
23 * gbproxy: Add newline to log message
24 * gbproxy: Allow gbproxy_nse_free(NULL)
25 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
26 * mm_state_gb_fsm: Handle implicit detach from mm_standby
27 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
28 * osmo-gbproxy: Initialize all hash_maps
29 * gbproxy: Fix confusing log message in gbprox_relay2nse
30 * gbproxy: Add SGSN NRI configuration
31 * gbproxy: Add SGSN pooling support
32 * gbproxy: Add comments to sgsn functions
33 * gbproxy: Add config option to name an SGSN
34 * gbproxy: Add VTY command to override the node selection function
35 * Fix gbproxy_sgsn_by_tlli wraparound
36 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
37 * gbproxy: Increase TLLI cache timeout to 10s
38 * gbproxy: Implement IMSI cache
39 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
40 * gbproxy: Use C-style comments
41 * gbproxy: Move helper function to a more logical place
42 * gbproxy: Remove unused variable assignment
43 * gbproxy: Fix VTY cmd name
44 * gbproxy: Define and use help string for gbproxy
45 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
46 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
47 * gbproxy: Print the correct message type for dummy paging/paging reject
48 * gbproxy: Improve log messages in gbproxy_select_sgsn
49 * gbproxy: Fix radio status routing by TMSI
50 * manual/gbproxy: Update overview chapter
51 * Rename OsmoGbPROXY -> *Proxy
52 * manuals/gbproxy: Update configuration chapter
53 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
54 * manuals/gbproxy: MSC -> SGSN for pooling chapter
55 * manuals/gbproxy: Move pooling to separate chapter
56
57 [ Alexander Couzens ]
58 * gprs_gmm_fsm.c: Implement RAT change between 2g and 3g
59 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
60 * gprs_llc: _bssgp_tx_dl_ud: ensure the LLME is valid before using it
61 * gmm: on invalid RA id reject the MS with an implicit detach
62 * gtphub_test: fix compilation error on gcc 10.2.0
63 * gtphub: fix compilation with gcc 10.2.0
64 * Port gbproxy to NS2
65 * sgsn: check for NULL of gprs_subscr_get_or_create()
66 * sgsn: Use the new NS2 api
67 * gbproxy: use ns2 vty2
68 * configure.ac: define a c standard instead of using the compilers default
69 * follow libosmocore/gprs_ns2 API changes of GPRS enums
70 * gbproxy: follow gprs_ns2 API vty changes
71 * sgsn: migrate to the new gprs_ns2_vty configuration
72 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
73
74 [ Neels Hofmeyr ]
75 * manual: explain IuPS, add SCCP/M3UA section from common chapters
76 * fix nullpointer: in gsm48_rx_gmm_ra_upd_req()
77 * gsup: send RAT type on LU
78 * gbproxy_test.c: fix mobile identity test data
79 * use new osmo_mobile_identity API everywhere
80
81 [ Eric ]
82 * tests: dlopen does not imply availability of dlsym..
83 * configure.ac: fix libtool issue with clang and sanitizer
84
85 [ Harald Welte ]
86 * gtphub_test: Fix compilation with gcc-10
87 * Fix memory leak when SNDCP de-fragmentation is used
88 * Treat RAU as implicit RESUME if GMM is suspended
89 * *.spec.in: Use %config(noreplace) to retain current config file
90 * Send a BVC-RESET to all persistent Gb interfaces at start-up
91 * Use osmo_fd_setup() whenever applicable
92 * Use osmo_fd_*_{disable,enable}
93 * gbproxy: Properly implement paging to LAC/RAC
94 * gbproxy: Implement paging to entire BSS area
95 * gprs_gb_parse: Add function to determine TLLI from encoded BSSGP
96 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
97 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
98 * gb_proxy: More precise + readable log messages
99 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
100 * gbproxy: Move BSS-side BVC-RESET processing to its own function
101 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
102 * gbproxy: Cosmetics: use longer lines
103 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
104 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
105 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
106 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
107 * gbproxy: convert bss_nses from llist_head to hashtable
108 * gbproxy: convert nse->bvcs from llist_head to hashtable
109 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
110 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
111 * gbproxy: Delete gbproxy_test
112 * gb_proxy: Introduce more validation / constraint checks
113 * gbproxy: use gbprox_relay2peer() whenever possible
114 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
115 * gbproxy: Log FSM timeouts
116 * migrate to DLBSSGP as log sub-system for BSSGP
117 * gbproxy major rewrite for SGSN pool support
118 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
119 * gbproxy: Introduce new DOBJ log category; log object allocation/release
120 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
121 * gbproxy: Implement handling of BVC Flow Control
122 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
123 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
124 * gbproxy: Fix segfault when receiving PAGING for unknown destination
125 * gbproxy: Add FSM related VTY commands
126 * gbproxy: Implement scaling of BVC flow control in SGSN pool
127 * gbproxy: Improve VTY state introspection
128 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
129 * gbproxy: Add "show gbproxy cell ..." VTY command
130 * gbproxy: Fix build on Deiban 8
131 * gb_proxy: Don't use orphan log subsystem DPCU
132 * gbproxy: Avoid depending on any of the SGSN code
133 * main: add --vty-ref-mode, use vty_dump_xml_ref_mode()
134 * manuals: generate vty reference xml at build time
135
136 [ Pau Espin Pedrol ]
137 * Use OSMO_FD_* instead of deprecated BSC_FD_*
138 * sgsn_libgtp: Improve ps-paging logging
139 * gprs_gmm_fsm.c: Add missing license header
140 * sgsn_libgtp: Avoid ps-paging MS on GMM Suspended state
141 * configure.ac: Fix trailing whitespace
142 * doc: Update VTY reference xml file
143 * Support setting rt-prio and cpu-affinity mask through VTY
144 * Change default SCTP conn NULL->127.0.0.1 to localhost->localhost
145 * contrib/jenkins: Enable parallel make in make distcheck
146 * Log error if pdp ctx is freed while holding an active timer
147 * Fix crash rx DeactPdpReq while waiting for DeactPdpAck after gtp side is freed
148 * sgsn_delete_pdp_ctx: Add documentation and assert assumptions
149 * process_ms_ctx_status: refactor to avoid code duplication
150 * process_ms_ctx_status: Fix crash deleting PDP Ctx if GTP side was already released
151 * gbproxy: generate coredump and exit upon SIGABRT received
152 * gtphub: generate coredump and exit upon SIGABRT received
153 * sgsn: generate coredump and exit upon SIGABRT received
154 * gmm: fix build without define PTMSI_ALLOC
155 * gmm: Introduce comment to ease addition of Network feature support IE later
156 * .gitignore: Ignore new autofoo tmp files
157 * sndcp: Fix struct bit fields on big endian
158 * Fix nsei+bvci not updated on rx UL SNDCP data
159
160 [ Oliver Smith ]
161 * contrib: import RPM spec
162 * contrib: integrate RPM spec
163 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
164 * contrib/jenkins: don't build osmo-gsm-manuals
165 * gbproxy: remove (moved to own repository)
166
167 [ Vadim Yanitskiy ]
168 * debian/control: change maintainer to the Osmocom team / mailing list
169 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
170 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
171
172 [ Keith ]
173 * Fix Radio Priority in MM Attach and PDP Context Activation
174 * VTY: Add gtp state-dir command
175
176 [ Philipp Maier ]
177 * gprs_sndcp: fix use after free
178 * sgsn_rim: Add routing for (GERAN) BSSGP RIM messages
179
180 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 20:29:33 +0100
181
Pau Espin Pedrol394aa532020-01-03 19:17:56 +0100182osmo-sgsn (1.6.0) unstable; urgency=medium
183
184 [ Pau Espin Pedrol ]
185 * gprs_gmm: Introduce macros to access msgb's associated IU UE ctx
186 * gprs_llc.h: Improve documentation of some structs
187 * gprs_gmm.c: Improve doc on nullable parameters
188 * gprs_gmm.c: Drop unneeded brackets
189 * Introduce define TLLI_UNASSIGNED
190 * gprs_sgsn.c: Warn upon llme free unexpected scenarios
191 * gprs_gmm: Clarify comment during TLLI assignment
192 * gprs_sgsn.c: Remove recently introduced assert
193 * gprs_gmm: Introduce assert to guard against unexpected condition
194 * gprs_gmm.c: Use correct function to set MM_IDLE state during cleanup
195 * gprs_sgsn.h: Flag MM_CTX_T_GERAN_Iu as not supported
196 * gprs_gmm.c: Flag mmctx_set_(p)mm_state() functions static
197 * sgsn: use sccp_simple_client API to setup ss7 id 0 instead of 1
198 * gprs_gmm.c: Fix typo in log message
199 * gprs_gmm.c: Call mmctx_set_(p)mm_state only on related ran_type
200 * Introduce and use log macros when no mm ctx available
201 * gprs_gmm: Avoid spaces in fsm events and enum strings
202 * tests: Verify that timers can be set over VTY
203 * Replace own timer infra with libosmocore osmo_tdef
204 * tests: Introduce vty-transcript-test tests
205 * gprs_gmm.c: Use osmo_rai_name() in log line
206 * examples: Add osmo-sgsn_custom-sccp.cfg
207 * vty: Introduce cs7-instance-iu
208 * gprs_gmm.c: Print value_string of reject cause
209 * gprs_gmm.c: Add spec document to function documentation
210 * gtp: make echo_interval unsigned
211 * gtp: cb_delete_context(): Clarify why pdp->lib is set to NULL
212 * Introduce log helper LOGGGSN and log category DGTP
213 * sgsn: gtp: Drop related pdp contexts on echo timeout against GGSN
214 * Move lots of Iu/ranap specific code into its own file
215 * Move llc->MM/SM Gb specific glue code to its own file
216 * Split enum gprs_pmm_state into Iu and Gb counterparts
217 * Merge common allocation steps for Gb and Iu ctx
218 * gprs_gmm.c: Replace inet_ntoa with inet_ntop
219 * sgsn_cdr.c: Fix ip addr string buffer size
220 * sgsn_vty: Fix mmctx rate_ctr output indentation
221 * sgsn_vty: Print correct Iu mmctx id in 'show mm-context'
222 * Introduce FSM mm_state_gb_fsm
223 * Introduce FSM mm_state_iu_fsm
224 * vty: Print MM state and RAN type in show mm-context
225 * src/gprs/Makefile.am: Move build of shared .c files to an internal lib
226 * Move out gbproxy to its own subdir
227 * Move out gtphub to its own subdir
228 * Move out sgsn to its own subdir
229 * gmm: Move code handling GMM Attach Complete to its own function
230 * gmm: Move code handling GMM Routing Area Update Complete to its own function
231 * gmm: Move code handling GMM PTMSI Realloc Complete to its own function
232 * enum gprs_gmm_state: Fix spec reference
233 * Implement GMM State using osmocom FSM
234 * Split out GPRS SM layer into its own file
235 * sgsn: Reject PdpActReq if no GTP pdp ctx exists
236 * Introduce TODO-RELEASE file
237 * sgsn_libgtp.c: Drop use of deprecated libgtp APIs gtp_retrans*()
238 * gmm: Fix assertion hit during RA UPD REQ before completting gmm attach
239 * Improve logging in gprs_llc.c code
240 * gprs_llc.c: Use enum instead of hardcoded value
241 * gprs_gmm.c: Send XID reset with received TLLI
242
243 [ Alexander Couzens ]
244 * gprs/gprs_gmm: implement T3314. Timeout to reset MM state READY->STANDBY
245 * gprs_gmm: only update gb/iu cell information when Iu/Gb present
246 * gprs_gmm: clarify comment of Iu follow-on request
247 * gprs_gmm: gsm48_rx_gmm_att_req(): refactor duplicated code
248 * sgsn_pdp_ctx_terminate: check llme before accessing
249 * gprs_ranap: send CommonId after receiving Security Mode Complete
250 * mm_gb_fsm: unassign the llme when entering MM_IDLE
251 * gprs_ranap: refactor REQUIRE_MM define
252 * sgsn: when receiving data PDU notify the Gb GMM fsm
253 * Avoid compiling unneeded files when building without Iu
254 * gprs_ranap: release Iu UE Context when exiting PMM Connected
255 * Iu: implement a user inactivity timer
256 * gprs_ranap: on Iu release, stop the attach fsm if running
257 * gprs_mm_state_gb_fsm: ensure T3350 is not running when entering IDLE
258 * gprs_ranap: add missing rc = 0
259 * gprs_sgsn: always allocate Gb/Iu mm fsm
260 * sgsn: MM Gb Fsm: fix event handling for implicit detach
261 * ranap: add non-spec X1001
262 * gprs_gmm: release Iu connection on RAU failures
263 * sgsn_mm_ctx_alloc(): check for unallocated fsms
264 * sgsn_libgtp: refactor ps paging into gprs_gb
265 * sgsn: Gb: implementing PS Paging when MS is MM_STANDBY
266
267 [ Vadim Yanitskiy ]
268 * gprs_mm_state_iu_fsm.c: fix: assign timer_cb to mm_state_iu_fsm
269
270 [ Max ]
271 * Use libosmocore constant for IMSI length in ACL entry
272
273 [ Harald Welte ]
274 * LLC: Don't use hard-coded N201-U / N201-I values in XID
275 * Initial OsmoGbPROXY user manual
276 * check for osmo_fsm_register() error return values
277 * check for osmo_ss7_init() error return value
278 * manual: Fix copy+paste error
279 * exit(2) on unsupported positional arguments on command line
280
281 [ Oliver Smith ]
282 * gitignore: fix paths to binaries
283 * doc: add OsmoGbProxy VTY reference
284 * regen_doc.sh: support gbproxy, run without docker
285 * osmoappdesc.py, tests: switch to python 3
286
287 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:17:56 +0100
288
Pau Espin Pedrold7ef94c2019-08-08 16:46:31 +0200289osmo-sgsn (1.5.0) unstable; urgency=medium
290
291 [ Max ]
292 * Improve 'show subscriber cache' vty command
293 * GMM: permit VLR_ANSWERED event in attach FSM
294 * Fix IMSI padding in imsi-acl
295
296 [ Harald Welte ]
297 * gbproxy_test: Fix test expectations of gprs_ns_rcvmsg()
298 * LLC XID: Fix string representation of N201_U
299 * LLC: Don't blindly assume all LLC frames have data payload
300 * LLC: Avoid NOTICE message on LLC NULL
301 * gprs_llc: Correctly refuse any ABM command (SABM, DISC) with DM
302 * LLC: Store the XID inside the LLC Entity, not LLC Mgmg Entity
303 * gb_proxy.h: Add missing comments; improve comments
304 * gb_proxy: cosmetic: Use 'bool' in data structures where applicable
305
306 [ efistokl ]
307 * gsm0408_rcv_gmm: send Iu-ReleaseCommand upon receiving Attach Complete.
308 * gprs_gmm: send Service Reject when no PDP ctxs are available.
309
310 [ Alexander Couzens ]
311 * gprs_gmm: reintroduce calling gsm48_gmm_authorize when not handling GMM Attach Requests
312 * gbproxy: parse dtap GSM48_MT_GSM_DEACT_PDP_REQ|ACK
313
314 [ Pau Espin Pedrol ]
315 * gprs_sndcp_comp_free: Replace ifelse with switch and better handling of error
316 * sgsn: vty: Improve log warning content with spec section
317 * Document max retransmit times for T3395
318 * sgsn: Fix echo timer not started upon first pdp ctx created
319 * sgsn_libgtp: Use new per-GSN libgtp API instead of deprecated API
320 * sgsn: Have authentication required on by default
321 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
322 * Require newer versions of dependencies
323
324 [ Keith ]
325 * Echo zero byte XID-Field of Type L3_PAR
326
327 [ Oliver Smith ]
328 * debian: create -doc subpackage with pdf manuals
329 * contrib/jenkins.sh: run "make maintainer-clean"
330 * osmo-gtphub.cfg: fix conflict with osmo-sgsn.cfg
331 * osmo-gbproxy.cfg: fix conflict with osmo-sgsn.cfg
332
333 [ Vadim Yanitskiy ]
334 * doc/manuals/vty: regenerate sgsn_vty_reference.xml
335 * osmo-sgsn: add VTY parameter to toggle authentication
336 * sgsn_mm_ctx_find_ggsn_ctx(): fix: always set gsm_cause
337
338 [ Eric Wild ]
339 * replace magic tmsi constant with define
340 * turn -Werror=null-dereference into a warning
341
342 [ Daniel Willmann ]
343 * manuals: Add script to regenerate vty/counter documentation
344 * manuals: Update vty/counter documentation
345 * Add/fix help string for version option
346 * osmo-sgsn: Fix outdated information in usermanual
347 * configuration.adoc: Small fixes
348 * configuration.adoc: Add a section about encryption
349
350 [ Ruben Undheim ]
351 * Spelling fixes
352
353 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 16:46:31 +0200
354
Harald Welte319a52b2019-01-23 18:32:41 +0100355osmo-sgsn (1.4.0) unstable; urgency=medium
356
357 [ Alexander Couzens ]
358 * gprs_subscriber: gsup_auth_error: reject MS in all cases
359 * gprs_gmm: make functions relating to GMM Attach Request public
360 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
361 * gprs_gmm: Cancel Location: use detach type IMSI
362 * vty: add cmd "reset sgsn state"
363 * tests: remove gmm unit tests
364 * gprs_gmm: introduce a GMM Attach Request FSM
365 * debian: add missing build dependencies
366 * sgsn: use gtp_clear_queues() when reset sgsn state
367 * vty: restart sgsn state: improve output message
368 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
369 * gprs_sgsn.h: fix wrong type of re-attempts
370 * GTP: refactor the echo timer
371 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
372 * gprs_gmm: Fix missing Security Command for 3G when attaching
373 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
374 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
375 * OsmoSGSN: add rate counter documentation
376
377 [ Daniel Willmann ]
378 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
379 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
380 * git-version-gen: Don't check for .git directory
381
382 [ Stefan Sperling ]
383 * add a test for OS#3178 (invalid unitdata message)
384 * finish gbproxy_parse_bssgp_unitdata test
385 * fix bogus assertion in encode_comp_field()
386 * fix bogus error check in gprs_sndcp_comp_create()
387 * use enums consistently instead of falling back to int
388 * update gbproxy test expected output
389 * consistently check the result of osmo_shift_v_fixed()
390 * remove pointless declaration of struct gsm_network
391 * make gsup ipa name configurable in osmo-sgsn.cfg
392
393 [ Pau Espin Pedrol ]
394 * jenkins.sh: Use --enable-werror only when iu support is disabled
395 * jenkins.sh: Remove non-existent configure options
396 * Drop all references of unused SMPP
397 * Drop all references of unused MGCP
398 * Drop unused common_vty.c
399 * sgsn_libgtp.c: Log pointer of deleted context
400 * Maintain per ggsn pdp ctx list
401 * osmo-sgsn: ping GGSN periodically and check for restart counter
402 * Disarm T3395 when dettaching mmctx from pdpctx
403 * examples: Enable by default echo req towards active GGSNs
404 * vty: Add cmd to disable echo loop explictly
405 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
406 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
407 * Forward GGSN originated DEACT PDP CTX REQ
408 * sgsn: Fix T3395 firing forever
409 * sgsn: subscriber: Avoid calling memcpy with NULL src
410 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
411 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
412 * sgsn: Fix crash using new libgtp cb_recovery2 API
413 * gbproxy: Replace '.' in counter names with ':'
414 * Drop gprs_msgb_copy with libosmocore replacement
415 * Drop gprs_msgb_resize_area with libosmocore replacement
416 * Use osmo_clock_gettime from libosmocore
417 * gbproxy: Add VTY parameter: link stored-msgs-max-length
418 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
419 * gbproxy: Replace '.' in counter names with ':'
420 * Add osmo-gtphub systemd service file
421 * debian: Fix typo in rules preventing build with IU support
422 * Install systemd services with autotools
423 * Install sample cfg file to /etc/osmocom
424 * Update wrong references to bsc in sgsn code
425 * Allocate sgsn_instance with talloc
426 * gbproxy: flag gbproxy_assign_imsi as static
427 * gbproxy: Fix abort during APN patch
428 * gbproxy: Remove unneeded parse_ctx param
429 * gbproxy: flush_stored_messages: Move comment to func description
430 * gbproxy: flush_stored_messages: Log and route using stored_msg info
431 * gbproxy: flush_stored_messages: Get rid of msg param
432 * Allow easily disabling GFDL references
433 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
434 * OsmoSGSN: configuration: Add missing pdp-periodic event
435 * OsmoSGSN: configuration: Document CDR CTRL interface
436 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
437
438 [ Harald Welte ]
439 * migrate to oap_client in libosmogsm
440 * remove libcommon
441 * gbproxy-legacy: Ensure well-formed config file
442 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
443 * initial checkin of manuals to public repo
444 * Add link to Asciidoc source code of manual
445 * OsmoSGSN: Fix formatting/cross reference in CDR section
446 * Update GSUP chapter regarding UMTS AKA and other recent changes
447 * GSUP: Add ladder diagrams for protocol transactions / procedures
448 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
449 * vty-ref: Update URI of docbook 5.0 schema
450
451 [ Neels Hofmeyr ]
452 * use __FILE__, not __BASE_FILE__
453 * vty: fix doc str for 'reset sgsn state'
454 * vty: add SCCP related vty commands
455 * fix build: remove unused variable
456 * Importing history from osmo-gsm-manuals.git
457 * add 'make check' target
458 * fix 'make clean': shell glob, ignore failure
459 * refactor Makefile build rules, don't use the FORCE
460 * OsmoSGSN: update VTY reference
461 * sgsn: update vty reference
462
463 [ Oliver Smith ]
464 * gtphub: Add --version cmdline option
465 * build manuals moved here from osmo-gsm-manuals.git
466 * Fix DISTCHECK_CONFIGURE_FLAGS override
467 * contrib/jenkins.sh: build and publish manuals
468 * contrib: fix makedistcheck with disabled systemd
469
470 [ Max ]
471 * Cleanup non-existent files from debian/copyright
472 * Use safer functions for IMSI ACL
473 * gbproxy: fix formatting in gbproxy-state command
474 * gbproxy: add number-of-peers ctrl command
475 * Revert "gbproxy: fix formatting in gbproxy-state command"
476 * Add OsmoSGSN control interface description
477 * Remove misleading comment
478 * Constify sgsn_acl_lookup() parameter
479 * Drop unused osmo-sgsn.pc
480 * Use explicit length check
481 * Use explicit parameter for sgsn_auth_init()
482
483 [ Jonathan Brielmaier ]
484 * fix various typos across all manuals
485
486 [ ikostov ]
487 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
488 * GSUP, OAP: fix AUTS length to 14, not 16
489
490 [ Philipp Maier ]
491 * osmo-sgsn: Update VTY command reference
492 * osmo-sgsn: improve auth-policy explaination
493 * osmo-sgsn: Explain TCP/IP header compression
494 * osmo-sgsn: fix arrow tips in flow diagrams
495
496 [ Holger Hans Peter Freyther ]
497 * sgsn: Fix numbering of QoS and add basic description for APN
498 * sgsn: Add charging characteristics to GSUP
499
500 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
501
Pau Espin Pedrol39c67e22018-05-03 19:01:44 +0200502osmo-sgsn (1.3.0) unstable; urgency=medium
503
504 [ Neels Hofmeyr ]
505 * drop osmo_sgsn.cfg from src/gprs dir
506 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
507 * vty: skip installing cmds now always installed by default
508 * add --enable-sanitize config option
509 * use default point-code as listed on Point_Codes wiki page
510 * gprs_gmm: segfault: gracefully handle failure to alloc context
511 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
512 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
513 * fix build: missing LIBGTP_CFLAGS in sgsn_test
514 * sgsn_test: guard against struct gprs_ra_id changing
515 * vty: absorb command explanations from osmo-gsm-manuals
516 * configure: add --enable-werror
517 * implement support for 3-digit MNC with leading zeros
518 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
519 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
520 * use osmo_init_logging2(), fix regression test memleaks
521 * auth+ciph: log is_r99 and auth types
522 * log two RA Update Request failure causes
523 * GERAN: allow GSM SRES on UMTS AKA challenge
524
525 [ Alexander Couzens ]
526 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
527 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
528 * debian: remove doublicated project name in example files
529 * .gitignore: remove non-existent /src/utils exludes
530 * configure.ac: remove pcap check
531 * configure.ac: remove unused libcdk check
532 * .service: remove OpenBSC from service desription
533 * mandatory depend on libc-ares and libgtp
534 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
535
536 [ Harald Welte ]
537 * Replace '.' in counter names with ':'
538 * Add talloc context introspection via VTY
539
540 [ Pau Espin Pedrol ]
541 * Replace '.' in counter names with ':'
542 * tests: Fix selection of python version
543 * sgsn_cdr: Split log formatting into a snprintf function
544 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
545 * tests: sgsn_test: Define wrap APIs with correct parameters
546 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
547 * gprs_gmm: Remove unused variable
548 * cosmetic: gprs_gmm: Remove trailing whitespace
549 * gprs_gmm: Convert warning message to pragma message
550 * configure.ac: Enable Wall in CFLAGS
551 * .gitignore: Add m4 files
552 * sgsn_libgtp.c: Fix typos and whitespace
553
554 [ Max ]
555 * Fix display of GTP addresses
556 * Show GTP version for PDP context in vty
557 * Remove unneeded .py scripts
558 * Replace '.' in counter names with ':'
559 * Remove dead code
560 * Enable sanitize for CI tests
561 * cosmetic: use macro for gtphub plane iteration
562 * Use connection id when allocating rate counters
563 * Migrate from OpenSSL to osmo_get_rand_id()
564 * Remove obsolete ./configure option
565 * Fix RAI construction
566 * gtphub: make rate_ctr unique
567 * Remove unused bsc_version.c
568 * Use gsm48_encode_ra() for RAI encoding
569 * gtphub: check for gsn_addr_from_sockaddr() errors
570 * gtphub: check for gsn_addr_from_sockaddr() error
571
572 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
573
Harald Welte467cfeb2017-10-28 19:07:48 +0200574osmo-sgsn (1.2.0) unstable; urgency=medium
575
576 [ Neels Hofmeyr ]
577 * jenkins: fix build: remove unused dependencies
578 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
579 * drop files unrelated to osmo-sgsn
580 * rewrite README
581 * configure.ac: set name to osmo-sgsn, fix ML addr
582 * move openbsc.pc to osmo-sgsn.pc
583 * move include/openbsc to include/osmocom/sgsn
584 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
585 * jenkins: use osmo-clean-workspace.sh before and after build
586
587 [ Alexander Couzens ]
588 * debian: fix paths of examples
589 * debian/rules: show testsuite.log when tests are failing
590
591 [ Max ]
592 * Remove rest_octets.h
593 * gbproxy: ensure peer allocation result
594 * jenkins: use osmo-ggsn for tests
595 * Cleanup configure checks
596 * Use extended logging for PDP contexts
597 * deb: fix copyright file issues
598 * Move P-TMSI alloc/update into separate function
599 * Check for correct P-TMSI allocation
600 * Use new FSF address in license header
601 * SGSN: uncomment BSSGP vty tests
602 * SGSN: print additional GTP-related info
603 * SGSN: check that GSN is created in proper mode
604 * Fix APN printing
605 * Fix build after recent rate_ctr patches
606 * gbproxy: don't link unnecessary
607 * Fix libosmo-sigtran dependency
608 * jenkins: check for IU properly
609 * Log GTP-U endpoints update
610 * Log address on GTP creation
611
612 [ Pau Espin Pedrol ]
613 * Remove unneeded dep libdbi
614
615 [ Philipp Maier ]
616 * log: fix default loglevels
617 * non-iu-build: guard vty libosmo-sigtran function calls.
618 * configure: fix libosmo-sigtran dependency
619
620 [ Harald Welte ]
621 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
622 * Debian: fix dh_strip rules for creating one -dbg per program
623
624 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
625
Alexander Couzens508c7632017-08-07 09:48:18 +0000626osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200627
Alexander Couzens508c7632017-08-07 09:48:18 +0000628 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200629
Alexander Couzens508c7632017-08-07 09:48:18 +0000630 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000