blob: 779d9449e47d8193468920e29990a4612a3fdca5 [file] [log] [blame]
Harald Welte08d88dd2019-04-03 09:09:49 +02001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Harald Welte1b0a68a2020-03-04 15:35:18 +00007USBDROPDIR := $(shell pkg-config --variable=usbdropdir libpcsclite)
8
Harald Welte08d88dd2019-04-03 09:09:49 +02009#export DH_VERBOSE=1
10export DEB_BUILD_MAINT_OPTIONS = hardening=+all
11
12
13%:
14 dh $@ --with=systemd --with autoreconf --fail-missing
15
16override_dh_auto_configure:
Harald Welte1b0a68a2020-03-04 15:35:18 +000017 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system \
Harald Welte1b0a68a2020-03-04 15:35:18 +000018 --enable-manuals
Harald Welte08d88dd2019-04-03 09:09:49 +020019
20#override_dh_clean:
21# dh_clean
22# $(RM) tests/package.m4
23# $(RM) tests/testsuite
24
25# Print test results in case of a failure
26#override_dh_auto_test:
27# dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Oliver Smithce58dac2024-03-19 18:40:50 +010028
29# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
30override_dh_compress:
31 dh_compress -X.pdf