fix debian build after introducing hack around usbdropdir

In Change-Id I87c68e8d14f8ddb6054178118ff1f96216483f5c we introduced
a hack to fix 'make distcheck' which in turn broke debian packaging.

Let's make sure the latter works while the formar also still does.

Change-Id: I16f7d0e8b7f63ed58dd4939c88e5276185bc3178
diff --git a/debian/rules b/debian/rules
index a36fe36..2714cc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,6 +4,8 @@
 DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
 VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
 
+USBDROPDIR := $(shell pkg-config --variable=usbdropdir libpcsclite)
+
 #export DH_VERBOSE=1
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
@@ -12,7 +14,9 @@
 	dh $@ --with=systemd --with autoreconf --fail-missing
 
 override_dh_auto_configure:
-	dh_auto_configure --  --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
+	dh_auto_configure --	--with-systemdsystemunitdir=/lib/systemd/system \
+				--with-usbdropdir=$(USBDROPDIR) \
+				--enable-manuals
 
 #override_dh_clean:
 #	dh_clean