blob: f59c49e12eb5f40016e44595c70b7693d924303f [file] [log] [blame]
Pau Espin Pedrol67d32a02020-01-03 17:04:15 +01001osmo-iuh (0.6.0) unstable; urgency=medium
2
3 [ Vadim Yanitskiy ]
4 * hnbgw_vty.c: fix: properly pass pointer to g_hnb_gw
5 * osmo-hnbgw: make sure osmo_ss7_init() executed successfully
6
7 [ Alexander Couzens ]
8 * iu_client: sccp_sap_up: set rc early
9 * iu_client: ensure UE is not NULL on CO primitives
10 * iu_client: sccp_sap_up: don't decode empty disconnect indications
11 * iu_client: introduce ranap_iu_free_ue() to free the UE connections
12 * iu_client: emit RANAP_IU_EVENT_LINK_INVALIDATED on SCCP disconnect indication
13 * iu_client: introduce a guard around global_iu_event_cb
14 * iu_client: allow to control the notifications
15 * iu_client: introduce ranap_iu_tx_release_free()
16 * iu_client: introduce UE field free_on_release
17 * iu_client: pass return value of osmo_sccp_user_sap_down() towards the caller
18 * iu_client: ranap_iu_tx_release() change default cause code to Success
19
20 [ Pau Espin Pedrol ]
21 * hnbgw: Add libosmoctrl's VTY CTRL command initialization
22 * debian/rules: Fix dbg pacakges
23 * debian: Split libosmo-sabp from libosmo-ranap package
24
25 [ Harald Welte ]
26 * asn1enum.pl: Make compatible with modern perl
27 * sabp: Initial import of SABP ASN.1 from 3GPP TS 25.419 V11.1.0 (2013-03)
28 * sabp: fixup SABP ASN.1 to avoid IOC (which are not supported by our toolchain)
29 * sabp: Add Procedure Codes and IEI constants to CommonDataTypes
30 * sabp: Generate C/H files for SABP; create libosmo-sabp
31 * Initial minimal OsmoHNBGW user manual
32 * exit(2) on unsupported positional arguments on command line
33
34 [ Oliver Smith ]
35 * gitignore: add gen_sabp.stamp
36 * debian, asn1tostruct.py: switch to python3
37
38 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 17:04:15 +0100
39
Pau Espin Pedrol505fa9e2019-08-07 21:23:57 +020040osmo-iuh (0.5.0) unstable; urgency=medium
41
42 [ Neels Hofmeyr ]
43 * ranap_msg_factory.h: fix enum def within function signature
44 * osmo-hnbgw: fix cmdline: do not force-disable colored logging
45 * osmo-hnbgw: set a proper talloc ctx for logging
46 * osmo-hnbgw: logging tweaks
47 * osmo-hnbgw: reply with RESET ACK when receiving a RESET
48
49 [ Oliver Smith ]
50 * tests: use -no-install libtool flag to avoid ./lt-* scripts
51 * contrib/jenkins.sh: run "make maintainer-clean"
52 * osmo-hnbgw.cfg: set local-ip to 0.0.0.0
53
54 [ Harald Welte ]
55 * iu_client: Implement transmission of ResetAcknowledge
56 * ranap_msg_factory: Fix criticality of PDUs
57
58 [ Thorsten Alteholz ]
59 * spelling stuff found by lintian
60
61 [ Daniel Willmann ]
62 * Add VTY reference manual
63 * jenkins: Enable manual publishing and building
64
65 [ Pau Espin Pedrol ]
66 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
67
68 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:23:57 +0200
69
Harald Welte92a88ee2019-01-20 21:46:06 +010070osmo-iuh (0.4.0) unstable; urgency=medium
71
72 [ Bernhard M. Wiedemann ]
73 * asn1tostruct: allow to override build date
74
75 [ Alexander Couzens ]
76 * hnbgw: remove close_cb() to fix a crash when releasing a hnbgw
77
78 [ Harald Welte ]
79 * debian/rules: Don't overwrite .tarball-version
80 * hnbgw_tx_hnb_register_rej(): Missing return statement
81
82 [ Neels Hofmeyr ]
83 * fix decoding of incoming X.213 NSAP addr
84 * hnbgw: vty: add SCCP related vty commands
85 * fix transport layer addr again, for nano3g
86
87 [ Pau Espin Pedrol ]
88 * debian: package osmo-hnbgw.service
89 * Install systemd services with autotools
90 * Install sample cfg file to /etc/osmocom
91
92 [ Stefan Sperling ]
93 * add a VTY command which shows a specific HNB
94
95 [ Oliver Smith ]
96 * Fix DISTCHECK_CONFIGURE_FLAGS override
97 * contrib: fix makedistcheck with disabled systemd
98
99 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:46:05 +0100
100
Pau Espin Pedrolba941e52018-05-03 18:29:14 +0200101osmo-iuh (0.3.0) unstable; urgency=medium
102
103 [ Neels Hofmeyr ]
104 * jenkins: use osmo-clean-workspace.sh before and after build
105 * vty: skip installing cmds now always installed by default
106 * src/Makefile.am: drop unused COMMON_LDADD
107 * add --enable-sanitize config option
108 * osmo-hnbgw: drop erratic log line on remote STP address
109 * api doc: clarify byte order in ranap_new_msg_rab_assign_*
110 * tests: sanitize: fix mem leaks, clean after tests
111 * ranap_msg_factory: sanitize: memcpy instead of unaligned int copy
112 * test_common: fix compiler warning: include ranap_common.h
113 * osmo-hnbgw: auto-config local and remote PCs if omitted
114 * cosmetic: osmo-hnbgw: log remote SCCP addresses on startup
115 * osmo-hnbgw: don't configure specific local IP address for STP connection
116 * iu client: store multiple LAC,RAC per RNC = fix paging for multiple RNC
117 * hnbgw: use proper VTY port number defined in libosmocore (4261)
118 * fix 3 compiler warnings in ranap_common.c
119 * hnbgw: use proper talloc ctx for vty telnet init
120 * hnbgw: hnb info: record MCC, MNC, show on 'show hnb'
121 * hnbap,rua,ranap decode: fix segfault on decode error
122 * vty: tweak / improve HNB and cnlink introspection
123 * osmo-hnbgw: vty: revamp output of context maps on 'show hnb'
124 * compiler warning: asn1tostruct.py: return 0 at end of *_free_*()
125 * segfault: context_map gc: use llist_for_each_entry_safe()
126 * rua: discard context maps on id-Disconnect
127 * rua_to_scu(): don't create a context map for UNITDATA
128 * cosmetic: context_map_tmr_cb(): fix comment
129 * osmo-hnbgw config: add 'rnc-id' config item
130 * osmo-hnbgw: startup: log the RNC-Id that is going to be used
131 * comments: hnbgw_rua.c: remove obsolete fixmes for asn1 free
132 * vty typo: 'show hnb': SCTP stream, not SCCP stream
133 * hnbgw_rua.c: log: fix integer format for cN_DomainIndicator
134 * hnbgw_rua: fix dereference of unset pointer
135 * hnbgw_cn: rx ranap: set rc in all cases
136 * hnbgw_hnbap: fix missing return in rx [un]successful outcome
137 * cosmetic: hnbgw: hnbap: log rx of unsuccessful outcome
138 * hnbap: log errors on decoding/encoding HNB-REGISTER msgs
139 * hnb-test: log accurate three-digit MNC with leading zeros
140 * configure: add --enable-werror
141 * cosmetic: use osmo_plmn_id instead of mcc,mnc
142
143 [ Harald Welte ]
144 * osmo-hnbgw: Avoid useless linking to libosmogsm and libsctp
145 * Link libosmo-ranap against libosmovty
146 * Add "-Wall" to the compile rules of the non-asn1c-generated source code
147 * hnbgw.c: Remove dead code creating libsctp linker dependency
148 * sccp_sap_up(): Fix never-hit "default" case in switch
149 * Fix various compiler warnings in hnb-gw code
150 * hnbgw_vty.c: cosmetic: Fix non-tab-indented code
151 * hnbgw_vty.c: Fix "-Werror=format-security" failure in vty_out()
152
153 [ Philipp Maier ]
154 * iu: iu_helpers: add functions to decode ip/port from rab-ass
155 * ranap_msg_factory: check IE encoder return codes
156 * ranap_msg_factory: remove unusued variable
157
158 [ Max ]
159 * Use proper package version
160 * Add control interface
161 * Expand ctrl interface
162 * Enable sanitize for CI tests
163
164 [ Pau Espin Pedrol ]
165 * iu_client.c: Remove unusued variable
166 * configure.ac: Enable -Wall flag
167 * contrib: jenkins.sh: Disable doxygen in libosmocore build
168 * debian/changelog: set prev releases to unstable
169
170 [ Stefan Sperling ]
171 * ensure unique CellIDs in HNB-GW
172
173 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:29:13 +0200
174
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200175osmo-iuh (0.2.0) unstable; urgency=low
Harald Weltecc1afdf2017-10-27 22:20:16 +0200176
177 * Upstream 0.2.0 release
178
179 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 22:19:00 +0000
180
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200181osmo-iuh (0.1.0) unstable; urgency=low
Alexander Couzense485cdd2017-08-06 21:52:02 +0000182
183 * Initial release.
184
185 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 04:13:19 +0000