blob: 1ec64374b35661c9751e19fa77d7c6355d78b330 [file] [log] [blame]
Pau Espin Pedrolba941e52018-05-03 18:29:14 +02001osmo-iuh (0.3.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * jenkins: use osmo-clean-workspace.sh before and after build
5 * vty: skip installing cmds now always installed by default
6 * src/Makefile.am: drop unused COMMON_LDADD
7 * add --enable-sanitize config option
8 * osmo-hnbgw: drop erratic log line on remote STP address
9 * api doc: clarify byte order in ranap_new_msg_rab_assign_*
10 * tests: sanitize: fix mem leaks, clean after tests
11 * ranap_msg_factory: sanitize: memcpy instead of unaligned int copy
12 * test_common: fix compiler warning: include ranap_common.h
13 * osmo-hnbgw: auto-config local and remote PCs if omitted
14 * cosmetic: osmo-hnbgw: log remote SCCP addresses on startup
15 * osmo-hnbgw: don't configure specific local IP address for STP connection
16 * iu client: store multiple LAC,RAC per RNC = fix paging for multiple RNC
17 * hnbgw: use proper VTY port number defined in libosmocore (4261)
18 * fix 3 compiler warnings in ranap_common.c
19 * hnbgw: use proper talloc ctx for vty telnet init
20 * hnbgw: hnb info: record MCC, MNC, show on 'show hnb'
21 * hnbap,rua,ranap decode: fix segfault on decode error
22 * vty: tweak / improve HNB and cnlink introspection
23 * osmo-hnbgw: vty: revamp output of context maps on 'show hnb'
24 * compiler warning: asn1tostruct.py: return 0 at end of *_free_*()
25 * segfault: context_map gc: use llist_for_each_entry_safe()
26 * rua: discard context maps on id-Disconnect
27 * rua_to_scu(): don't create a context map for UNITDATA
28 * cosmetic: context_map_tmr_cb(): fix comment
29 * osmo-hnbgw config: add 'rnc-id' config item
30 * osmo-hnbgw: startup: log the RNC-Id that is going to be used
31 * comments: hnbgw_rua.c: remove obsolete fixmes for asn1 free
32 * vty typo: 'show hnb': SCTP stream, not SCCP stream
33 * hnbgw_rua.c: log: fix integer format for cN_DomainIndicator
34 * hnbgw_rua: fix dereference of unset pointer
35 * hnbgw_cn: rx ranap: set rc in all cases
36 * hnbgw_hnbap: fix missing return in rx [un]successful outcome
37 * cosmetic: hnbgw: hnbap: log rx of unsuccessful outcome
38 * hnbap: log errors on decoding/encoding HNB-REGISTER msgs
39 * hnb-test: log accurate three-digit MNC with leading zeros
40 * configure: add --enable-werror
41 * cosmetic: use osmo_plmn_id instead of mcc,mnc
42
43 [ Harald Welte ]
44 * osmo-hnbgw: Avoid useless linking to libosmogsm and libsctp
45 * Link libosmo-ranap against libosmovty
46 * Add "-Wall" to the compile rules of the non-asn1c-generated source code
47 * hnbgw.c: Remove dead code creating libsctp linker dependency
48 * sccp_sap_up(): Fix never-hit "default" case in switch
49 * Fix various compiler warnings in hnb-gw code
50 * hnbgw_vty.c: cosmetic: Fix non-tab-indented code
51 * hnbgw_vty.c: Fix "-Werror=format-security" failure in vty_out()
52
53 [ Philipp Maier ]
54 * iu: iu_helpers: add functions to decode ip/port from rab-ass
55 * ranap_msg_factory: check IE encoder return codes
56 * ranap_msg_factory: remove unusued variable
57
58 [ Max ]
59 * Use proper package version
60 * Add control interface
61 * Expand ctrl interface
62 * Enable sanitize for CI tests
63
64 [ Pau Espin Pedrol ]
65 * iu_client.c: Remove unusued variable
66 * configure.ac: Enable -Wall flag
67 * contrib: jenkins.sh: Disable doxygen in libosmocore build
68 * debian/changelog: set prev releases to unstable
69
70 [ Stefan Sperling ]
71 * ensure unique CellIDs in HNB-GW
72
73 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:29:13 +0200
74
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +020075osmo-iuh (0.2.0) unstable; urgency=low
Harald Weltecc1afdf2017-10-27 22:20:16 +020076
77 * Upstream 0.2.0 release
78
79 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 22:19:00 +0000
80
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +020081osmo-iuh (0.1.0) unstable; urgency=low
Alexander Couzense485cdd2017-08-06 21:52:02 +000082
83 * Initial release.
84
85 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 04:13:19 +0000