blob: cdf7a94ee5e9f676f24b97a88470bac24dc5435e [file] [log] [blame]
Pau Espin Pedrol505fa9e2019-08-07 21:23:57 +02001osmo-iuh (0.5.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * ranap_msg_factory.h: fix enum def within function signature
5 * osmo-hnbgw: fix cmdline: do not force-disable colored logging
6 * osmo-hnbgw: set a proper talloc ctx for logging
7 * osmo-hnbgw: logging tweaks
8 * osmo-hnbgw: reply with RESET ACK when receiving a RESET
9
10 [ Oliver Smith ]
11 * tests: use -no-install libtool flag to avoid ./lt-* scripts
12 * contrib/jenkins.sh: run "make maintainer-clean"
13 * osmo-hnbgw.cfg: set local-ip to 0.0.0.0
14
15 [ Harald Welte ]
16 * iu_client: Implement transmission of ResetAcknowledge
17 * ranap_msg_factory: Fix criticality of PDUs
18
19 [ Thorsten Alteholz ]
20 * spelling stuff found by lintian
21
22 [ Daniel Willmann ]
23 * Add VTY reference manual
24 * jenkins: Enable manual publishing and building
25
26 [ Pau Espin Pedrol ]
27 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
28
29 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:23:57 +0200
30
Harald Welte92a88ee2019-01-20 21:46:06 +010031osmo-iuh (0.4.0) unstable; urgency=medium
32
33 [ Bernhard M. Wiedemann ]
34 * asn1tostruct: allow to override build date
35
36 [ Alexander Couzens ]
37 * hnbgw: remove close_cb() to fix a crash when releasing a hnbgw
38
39 [ Harald Welte ]
40 * debian/rules: Don't overwrite .tarball-version
41 * hnbgw_tx_hnb_register_rej(): Missing return statement
42
43 [ Neels Hofmeyr ]
44 * fix decoding of incoming X.213 NSAP addr
45 * hnbgw: vty: add SCCP related vty commands
46 * fix transport layer addr again, for nano3g
47
48 [ Pau Espin Pedrol ]
49 * debian: package osmo-hnbgw.service
50 * Install systemd services with autotools
51 * Install sample cfg file to /etc/osmocom
52
53 [ Stefan Sperling ]
54 * add a VTY command which shows a specific HNB
55
56 [ Oliver Smith ]
57 * Fix DISTCHECK_CONFIGURE_FLAGS override
58 * contrib: fix makedistcheck with disabled systemd
59
60 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:46:05 +0100
61
Pau Espin Pedrolba941e52018-05-03 18:29:14 +020062osmo-iuh (0.3.0) unstable; urgency=medium
63
64 [ Neels Hofmeyr ]
65 * jenkins: use osmo-clean-workspace.sh before and after build
66 * vty: skip installing cmds now always installed by default
67 * src/Makefile.am: drop unused COMMON_LDADD
68 * add --enable-sanitize config option
69 * osmo-hnbgw: drop erratic log line on remote STP address
70 * api doc: clarify byte order in ranap_new_msg_rab_assign_*
71 * tests: sanitize: fix mem leaks, clean after tests
72 * ranap_msg_factory: sanitize: memcpy instead of unaligned int copy
73 * test_common: fix compiler warning: include ranap_common.h
74 * osmo-hnbgw: auto-config local and remote PCs if omitted
75 * cosmetic: osmo-hnbgw: log remote SCCP addresses on startup
76 * osmo-hnbgw: don't configure specific local IP address for STP connection
77 * iu client: store multiple LAC,RAC per RNC = fix paging for multiple RNC
78 * hnbgw: use proper VTY port number defined in libosmocore (4261)
79 * fix 3 compiler warnings in ranap_common.c
80 * hnbgw: use proper talloc ctx for vty telnet init
81 * hnbgw: hnb info: record MCC, MNC, show on 'show hnb'
82 * hnbap,rua,ranap decode: fix segfault on decode error
83 * vty: tweak / improve HNB and cnlink introspection
84 * osmo-hnbgw: vty: revamp output of context maps on 'show hnb'
85 * compiler warning: asn1tostruct.py: return 0 at end of *_free_*()
86 * segfault: context_map gc: use llist_for_each_entry_safe()
87 * rua: discard context maps on id-Disconnect
88 * rua_to_scu(): don't create a context map for UNITDATA
89 * cosmetic: context_map_tmr_cb(): fix comment
90 * osmo-hnbgw config: add 'rnc-id' config item
91 * osmo-hnbgw: startup: log the RNC-Id that is going to be used
92 * comments: hnbgw_rua.c: remove obsolete fixmes for asn1 free
93 * vty typo: 'show hnb': SCTP stream, not SCCP stream
94 * hnbgw_rua.c: log: fix integer format for cN_DomainIndicator
95 * hnbgw_rua: fix dereference of unset pointer
96 * hnbgw_cn: rx ranap: set rc in all cases
97 * hnbgw_hnbap: fix missing return in rx [un]successful outcome
98 * cosmetic: hnbgw: hnbap: log rx of unsuccessful outcome
99 * hnbap: log errors on decoding/encoding HNB-REGISTER msgs
100 * hnb-test: log accurate three-digit MNC with leading zeros
101 * configure: add --enable-werror
102 * cosmetic: use osmo_plmn_id instead of mcc,mnc
103
104 [ Harald Welte ]
105 * osmo-hnbgw: Avoid useless linking to libosmogsm and libsctp
106 * Link libosmo-ranap against libosmovty
107 * Add "-Wall" to the compile rules of the non-asn1c-generated source code
108 * hnbgw.c: Remove dead code creating libsctp linker dependency
109 * sccp_sap_up(): Fix never-hit "default" case in switch
110 * Fix various compiler warnings in hnb-gw code
111 * hnbgw_vty.c: cosmetic: Fix non-tab-indented code
112 * hnbgw_vty.c: Fix "-Werror=format-security" failure in vty_out()
113
114 [ Philipp Maier ]
115 * iu: iu_helpers: add functions to decode ip/port from rab-ass
116 * ranap_msg_factory: check IE encoder return codes
117 * ranap_msg_factory: remove unusued variable
118
119 [ Max ]
120 * Use proper package version
121 * Add control interface
122 * Expand ctrl interface
123 * Enable sanitize for CI tests
124
125 [ Pau Espin Pedrol ]
126 * iu_client.c: Remove unusued variable
127 * configure.ac: Enable -Wall flag
128 * contrib: jenkins.sh: Disable doxygen in libosmocore build
129 * debian/changelog: set prev releases to unstable
130
131 [ Stefan Sperling ]
132 * ensure unique CellIDs in HNB-GW
133
134 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:29:13 +0200
135
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200136osmo-iuh (0.2.0) unstable; urgency=low
Harald Weltecc1afdf2017-10-27 22:20:16 +0200137
138 * Upstream 0.2.0 release
139
140 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 22:19:00 +0000
141
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200142osmo-iuh (0.1.0) unstable; urgency=low
Alexander Couzense485cdd2017-08-06 21:52:02 +0000143
144 * Initial release.
145
146 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 04:13:19 +0000