blob: ecb36d3a68dcc9e3b0fbce33b6ae87e44fe1954f [file] [log] [blame]
Harald Weltee0c6fe52019-01-20 19:29:59 +01001osmo-hlr (1.0.0) unstable; urgency=medium
2
3 [ Stefan Sperling ]
4 * move creation of insert subscriber data messages to a common function
5
6 [ Harald Welte ]
7 * Return proper GSUP error in case of too short IMSI
8 * disable blind subscriber insertion into every VLR/SGSN
9 * gsup_server: Add "priv" pointer and make it point to 'struct hlr'
10 * move osmo_gsup_addr_send() declaration from luop.h to gsup_router.h
11 * gsup_router: Use "#pragma once" and add missing #includes
12 * Add "show gsup-connections" VTY command
13 * import gsup_client.c as new libosmo-gsup-client
14 * gsup_client: rename gsup_client_* to osmo_gsup_client_*
15 * GSUP: Log GSUP route add/remove
16 * hlr: Export + Declare global g_hlr symbol
17 * USSD: Add Core USSD handling + VTY routing config to HLR
18 * USSD: Add basic dispatch + decode of GSUP-encapsulated SS/USSD
19 * hlr_ussd: Introduce LOGPSS() macro
20 * USSD: Send ReturnError component if USSD Code unknown / EUSE disconnected
21 * USSD: Further unification of log output; Use LOGPSS when possible
22 * osmo-hlr.cfg: Don't enable DEBUG logging by default
23 * USSD: Add new "DSS" logging category and use it appropriately
24 * USSD: fix null-pointer deref in "default-route" vty/config cmd
25 * Add osmo-euse-demo as minimalistic test of a External USSD (EUSE) handler
26 * USSD: Add support for internal USSD handlers
27 * debian: Add sub-package for libosmo-gsup-client
28 * pkg-config: Fix libosmo-gsup-client pkg-config file
29 * gitignore: Add .tarball-version
30 * debian: Make libosmo-gsup-client-dev depend on libosmo-gsup-client0
31 * USSD: Fix "ussd default-route"
32 * libosmo-gsup-client: License is GPLv2-or-later
33 * osmo-hlr.cfg: Ensure well-formed config file example
34 * test_nodes.vty: Since libosmocore 1.0.0, we only have one space
35
36 [ Martin Hauke ]
37 * sql/Makefile.am: Make docsdir completely configurable
38 * debian: Fix typo in package description
39
40 [ Pau Espin Pedrol ]
41 * debian: Avoid installing duplicate cfg file in /etc
42 * sql/Makefile: Install hlr_data.sql as example together with hlr.sql
43 * sql/Makefile: Install sql files under doc/.../sql subdir
44 * sql/Makefile: Create empty /var/lib/osmocom directory at install time
45 * Install systemd services with autotools
46 * Move doc/Makefile.am to doc/examples/Makefile.am
47 * Install sample cfg file to /etc/osmocom
48
49 [ Vadim Yanitskiy ]
50 * hlr.c: move deinitialization code from SIGINT handler
51 * hlr.c: free root talloc context on exit
52 * hlr.c: track the use of talloc NULL memory contexts
53 * src/db.c: fix: make sure the database is properly closed
54 * src/db.c: don't ignore the result of db_bootstrap()
55 * hlr_vty_subscr.c: fix subscriber creation command help
56 * Update .gitignore: add missing build products
57 * tests/Makefile.am: also remove temporary sqlite files
58 * hlr_ussd.h: add #pragma once include guard
59 * hlr_ussd.h: use proper libc headers
60 * Update .gitignore: ignore osmo-euse-demo
61 * hlr_ussd.h: drop meaningless forward declaration
62 * USSD/hlr_vty.c: print error if EUSE is not found
63 * hlr_ussd.c: fix: properly print a EUSE / IUSE name
64 * hlr_ussd.c: avoid using CR and NL in IUSE responses
65
66 [ Neels Hofmeyr ]
67 * fix build: adjust test_nodes.vty to logging change
68 * tweak example config
69 * make: always allow running python tests manually
70
71 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:29:58 +0100
72
Pau Espin Pedrol78f43012018-05-04 18:41:35 +020073osmo-hlr (0.2.1) unstable; urgency=medium
74
75 [ Neels Hofmeyr ]
76 * fix luop crash: use buffer for APN that remains valid
77 * add gsup_test to catch OS#3231
78 * add error handling to osmo_gsup_configure_wildcard_apn()
79
80 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 04 May 2018 18:41:35 +0200
81
Pau Espin Pedrolcb360f02018-05-03 16:27:14 +020082osmo-hlr (0.2.0) unstable; urgency=medium
83
84 [ Neels Hofmeyr ]
85 * vty: skip installing cmds now always installed by default
86 * hlr_db_tool: fix error log strerror invocation
87 * cosmetic: add comment on ignored return value
88 * db-tool: add command 'create'
89 * db-tool: cosmetic: tweak printf output
90 * db-tool: error-exit on too many arguments
91 * add --enable-sanitize config option
92 * db_test: don't verify SQLite issued error messages, they might change
93 * cosmetic: rx_send_auth_info(): decide error cause with switch()
94 * return GMM_CAUSE_IMSI_UNKNOWN if there is no auth data
95 * db_get_auth_data / db_get_auc: clarify return values
96 * osmo-hlr: log details for unknown IMSI / no auth data / db error
97 * db_test: also test db_get_auc() return values
98 * fix test_subscriber_errors.ctrl after libosmocore change
99 * fix debug log: put 'deriving 2G from 3G' in proper place
100 * ctrl test: fix: adjust expectations after stricter ctrl parsing
101 * fix build: db_test: missing LIBOSMOABIS_CFLAGS and _LIBS
102 * configure: add --enable-werror
103 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
104
105 [ Harald Welte ]
106 * hlr.c: Avoid overflow of lu_operation.subscr.imsi
107 * Fix expected test output after new 'logging print file 1' vty command
108 * osmo-hlr: Add talloc context introspection via VTY
109 * vty: Don't print error if removing auth data while none present
110 * Fix responses to PURGE MS
111
112 [ Alexander Couzens ]
113 * debian: include systemd service osmo-hlr.service
114 * doc: install example .cfg files to $(docdir)/examples/
115 * debian: install osmo-hlr.cfg to /etc/osmocom
116
117 [ Max ]
118 * Remove unused check
119 * Remove unused ipa.py
120 * Enable sanitize for CI tests
121
122 [ Pau Espin Pedrol ]
123 * luop.c: Transform FIXME from warning to pragma message
124 * contrib:jenkins.sh: Enable Werror
125 * use osmo_init_logging2
126 * Remove unused src/db_test.c
127
128 [ Alexander Huemer ]
129 * Add missing build products in .gitignore
130
131 [ Stefan Sperling ]
132 * more robust usage of osmo_timer API for osmo-hlr luop timer
133 * notify GSUP clients when HLR subscriber information changes
134 * rewrite subscriber_update_notify() without calls into luop
135 * don't forget to mark luop as a packet switched connection
136
137 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:27:13 +0200
138
Harald Welte0dcbd472017-10-28 20:37:34 +0200139osmo-hlr (0.1.0) unstable; urgency=medium
140
141 [ Neels Hofmeyr ]
142 * build with autoconf/automake, add jenkins.sh script
143 * fix build on FreeBSD: eliminate implicitly declared functions
144 * fix various compiler warnings
145 * fix DLGSUP logging cat after change in libosmocore
146 * build: recoin db_test as non-installable program
147 * build: actually make sqlite mandatory
148 * bump required libosmocore version to 0.9.5
149 * gsup: send subscriber MSISDN
150 * debug log: log computed vector kinds
151 * log: move a log from info to debug level
152 * hlr.sql: typo in comment
153 * auc.c: typo in comment
154 * main: add and use root talloc ctx
155 * main: add option parsing with db file and default options
156 * main: add VTY and '-c config-file' option
157 * sql: fix 3g_auc's column K data type
158 * cosmetic: sql: indicate VARCHAR size of key columns as 32
159 * sql: auc_3g: set sqn NOT NULL DEFAULT 0
160 * comment: sql: describe auc_2g and auc_3g columns
161 * Add test suite skeleton with empty test (auc_3g_test)
162 * tests: auc_3g_test: implement vector generation test
163 * auth: verify test sets from 3GPP TS 55.205
164 * sql: add unique constraints to IMSI and MSISDN
165 * UMTS AKA resync: fix argument ordering
166 * auc_3g_test: add AUTS resync test
167 * auc_gen_vectors(): ensure sane arguments, test
168 * auc_3g_test: allow to inc fake rand bytes upon rand request
169 * auc_3g_test: add AUTS test with N vectors, to show bug
170 * cosmetic: refactor auc_compute_vectors(), add debug log
171 * auc_compute_vectors(): fix AUTS resync for multiple vectors
172 * cosmetic: auc_3g_test: improve test debugging tools
173 * cosmetic: rename auc_3g_test.c to auc_test.c
174 * fix: properly handle error rc by osmo_gsup_conn_ccm_get()
175 * auc tests: adjust cosmetically to prepare for SQN changes
176 * auc tests: fix after SQN scheme changes from libosmocore
177 * fix debug log: adjust to new SQN increment scheme
178 * UMTS AKA: implement SQN increment according to SEQ and IND
179 * debug log: output ind slot, previous sqn, and sqn db update
180 * jenkins: add value_string termination check
181 * fix db_subscr_ps error handling
182 * add config example (mostly empty)
183 * install hlr.sql in prefix/doc/osmo-hlr/
184 * use OSMO_GSUP_PORT == 4222 instead of hardcoded 2222
185 * add basic CTRL interface tests
186 * add CTRL tests for enable-/disable-/status-ps
187 * cosmetic: prepend DB_STMT_ to enum stmt_idx entries
188 * cosmetic: rename db_subscr_get() to db_subscr_get_by_imsi()
189 * cosmetic: refactor db_bind_imsi() as db_bind_text()
190 * cosmetic: multi-line DB_STMT_AUC_BY_IMSI
191 * cosmetic: log IMSI='<imsi>', log "no such subscriber"
192 * cosmetic: log: "SQLite" with capital L
193 * cosmetic: db_hlr: SL3_TXT: clarify indenting
194 * ctrl_test_runner.py: use proper constant as test db path
195 * gitignore: tests/package.m4
196 * cosmetic: don't log about missing SQLite log cb
197 * add db_bind_int() and db_bind_int64()
198 * add db_subscr_create(), db_subscr_delete(), db_subscr_update_msisdn_by_imsi()
199 * add initial db_test: creating and deleting subscribers
200 * less noise: simplify db_remove_reset()
201 * db: use int64_t as subscriber id
202 * add db_subscr_get_by_msisdn() and db_subscr_get_by_id()
203 * refactor db_subscr_ps() to db_subscr_nam()
204 * refactor db_subscr_lu()
205 * refactor db_subscr_purge
206 * add db_subscr_update_aud_by_id(), complete db_subscr_delete_by_id()
207 * refactor db_get_auth_data return val
208 * code undup: use db_remove_reset() in db_auc.c
209 * fix db_update_sqn(): reset stmt in all error cases
210 * code undup: use db_bind_text() in db_get_auth_data()
211 * debian: 'make check' needs sqlite3, add to Build-Depends
212 * fix db_subscr_get_by_*(): clear output data; test in db_test.c
213 * implement subscriber vty interface, tests
214 * add test_nodes.vty
215 * replace ctrl_test_runner.py with transcript test_subscriber.ctrl
216 * add lu_op_free(), use in luop.c
217 * luop: fix mem leak upon error in lu_op_alloc_conn()
218 * fix mem leak in handle_cmd_ps(): free luop
219 * api doc: say that lu_op_tx_del_subscr_data() doesn't free
220 * add hlr_subsrc_nam to put GSUP client notification in proper API
221 * vty: fix output of empty IMSI
222 * db api: fix/add API docs
223 * cosmetic: tweak params of hlr_controlif_setup()
224 * ctrl: completely replace all CTRL commands
225 * test_subscriber.ctrl: test against octal/hex interpretation of id
226 * jenkins: use osmo-clean-workspace.sh before and after build
227 * tests/Makefile: use test db var instead of repeating the path
228 * db_test: fix *FLAGS
229 * automatically create db tables on osmo-hlr invocation
230 * cosmetic: sql/hlr.sql: move comments
231 * cosmetic: rename SL3_TXT macro, use osmo_strlcpy()
232 * fix default logging levels to NOTICE, not DEBUG
233 * add osmo-hlr-db-tool, program to migrate from osmo-nitb db
234
235 [ Max ]
236 * Add gerrit settings
237 * Add hardcoded APN
238 * Log error cause as a string
239 * Move GSUP msg init into separate function
240 * Use strings for GSUP message type
241 * Move lu_operation into separate file
242 * db: move duplicated code into helper functions
243 * Fix compiler's warning about printf security
244 * Add routines to update nam_ps
245 * Add global HLR struct
246 * Make subscr parameter to db_subscr_get() optional
247 * Add CTRL interface
248 * CTRL: add enable/disable packet service cmds
249 * Add .deb packaging
250 * deb: fix OBS build
251 * debian: remove obsolete dependency
252 * Attempt to fix .deb package
253 * deb: use python in shebang
254 * Another attempt at fixing .deb
255 * Use release helper from libosmocore
256 * Use value string check from osmo-ci
257
258 [ Daniel Willmann ]
259 * Add systemd service file
260 * hlr_data.sql: Insert ki and opc instead of op to example data
261 * tests/auc: Don't require python3
262
263 [ Pau Espin Pedrol ]
264 * VTY: Add hlr node and bind ip field
265 * debian: remove unneeded dependency libdbd-sqlite3
266
267 [ Harald Welte ]
268 * jenkins.sh: Proper error message if local environment isn't set up
269
270 [ Alexander Couzens ]
271 * debian/rules: show testsuite.log when tests are failing
272
273 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 20:37:33 +0200
274
Maxe9d37db2017-03-13 16:08:11 +0100275osmo-hlr (0.0.1) UNRELEASED; urgency=low
276
277 * Initial release (Closes: OS#1948)
278
279 -- Max Suraev <msuraev@sysmocom.de> Mon, 13 Mar 2017 16:26:41 +0200