blob: f59ca1e2dcafe086a33f0ddc6ae55afc5c00d07a [file] [log] [blame]
Eric Butler91ffa2b2012-08-14 18:07:48 -07001#!/usr/bin/make -f
2
Eric Butlerd11a5c12012-08-14 20:56:26 -07003DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Max5f3871e2016-12-21 14:18:34 +01007export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +01008#export DH_VERBOSE=1
Max5f3871e2016-12-21 14:18:34 +01009
Eric Butler91ffa2b2012-08-14 18:07:48 -070010
11%:
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +010012 dh $@ --with autoreconf --fail-missing
Eric Butlerd11a5c12012-08-14 20:56:26 -070013
Holger Hans Peter Freythercf5b08b2013-02-13 20:12:36 +010014override_dh_strip:
15 dh_strip --dbg-package=libosmo-abis-dbg
16
Max5f3871e2016-12-21 14:18:34 +010017override_dh_clean:
18 dh_clean
Harald Weltea60f5e12018-08-06 11:10:29 +020019 rm -f tests/package.m4 tests/testsuite .version
Alexander Couzens4200aa62017-10-11 07:05:46 +020020
21override_dh_auto_test:
22 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)