Integrate Debian packaging changes

debian/control:
    * restructure to make it easier to incorporate further changes
    * update package descriptions
    * update project URL

debian/rules:
    * use proper hardening syntax
    * restructure to make it easier to incorporate further changes
    * add cleanup override

debian/copyright: add file matching Debian format

Change-Id: I6af8ab7f5c75b4d161cebf492f3de5d9dbd00220
Related: OS#1694
diff --git a/debian/rules b/debian/rules
index d3f1534..cec3c9f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,9 @@
 DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
 VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 #export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+
 
 %:
 	dh $@ --with autoreconf --fail-missing
@@ -16,3 +17,7 @@
 override_dh_autoreconf:
 	echo $(VERSION) > .tarball-version
 	dh_autoreconf
+
+override_dh_clean:
+	dh_clean
+	rm -f tests/package.m4 tests/testsuite .version .tarball-version