blob: cec3c9fdfc7a7c3771e84820184fcec50b717330 [file] [log] [blame]
Eric Butler91ffa2b2012-08-14 18:07:48 -07001#!/usr/bin/make -f
2
Eric Butlerd11a5c12012-08-14 20:56:26 -07003DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Max5f3871e2016-12-21 14:18:34 +01007export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +01008#export DH_VERBOSE=1
Max5f3871e2016-12-21 14:18:34 +01009
Eric Butler91ffa2b2012-08-14 18:07:48 -070010
11%:
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +010012 dh $@ --with autoreconf --fail-missing
Eric Butlerd11a5c12012-08-14 20:56:26 -070013
Holger Hans Peter Freythercf5b08b2013-02-13 20:12:36 +010014override_dh_strip:
15 dh_strip --dbg-package=libosmo-abis-dbg
16
Eric Butlerd11a5c12012-08-14 20:56:26 -070017override_dh_autoreconf:
18 echo $(VERSION) > .tarball-version
19 dh_autoreconf
Max5f3871e2016-12-21 14:18:34 +010020
21override_dh_clean:
22 dh_clean
23 rm -f tests/package.m4 tests/testsuite .version .tarball-version