blob: 20bbfa0a28da70e91c7ddb425e0436d8bc3c92d6 [file] [log] [blame]
Pau Espin Pedrol71637152018-03-05 16:49:42 +01001osmo-trx (0.3.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * jenkins: use osmo-clean-workspace.sh before and after build
5
6 [ Harald Welte ]
7 * SocketsTest: Fix printing of non-nul-terminated string
8
9 [ Piotr Krysik ]
10 * UHDDevice.cpp: add USRP B205mini support
11
12 [ Max ]
13 * Mark release target as virtual
14 * Remove outdated references to OpenBTS
15 * Remove unused headers
16 * Update installation instructions
17 * Update legal disclaimer
18 * Update license notes
19 * tests: null-terminate buffer
20
21 [ Pau Espin Pedrol ]
22 * cosmetic: Remove trailing whitespace
23 * Logger: Stop using Log.Alarms.Max from config
24 * Logger: Stop using Log.File and Log.Level from config
25 * Drop use of ConfigurationTable gConfig
26 * Remove Configuration module and libsqlite dependency
27 * cosmetic: AUTHORS: fix trailing whitespace
28 * Set up GNU Autotest infrastructure
29 * tests: InterThread: adapt to have reproducible output and enable autotest
30 * tests: Timeval: adapt to have reproducible output and enable autotest
31 * tests: Log: adapt to have reproducible output and enable autotest
32 * Sockets.cpp: Fix initialization of UDD socket
33 * tests: Sockets: adapt to have reproducible output and enable autotest
34 * utils/convolvtest: Remove uneeded libosmocore dependency
35 * Move ARCH_LA to Makefile.common
36 * tests: Migrate convtest util to autotest infrastructure
37 * arm/convert.c: Fix compilation error
38 * arm/convert.c: Add missing convert_init implementation
39 * .gitignore: Add missing test related files
40 * Remove UDDSocket class
41 * tests: SocketTests: Pick OS-assigned instead of setting one manually
42 * tests: SocketsTest: Avoid hang forever if test fails
43 * tests: SocketsTest: Fail test on write fail
44 * tests: TimevalTest: refactor and avoid double comparison
45 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
46 * tests: convolve: Disable due to difference in output in different archs
47 * Remove unneeded libdl dependency
48 * Fix whitespace
49 * Add support to set Rx/TxAntenna
50 * UHDDevice: Initialize async_event_thrd in constructor
51 * Logger: Drop unused gLogEarly
52 * Logger: Remove unused logging macros
53 * Logger: get rid of alarm APIs
54 * Logger: Drop syslog support
55 * Logger: Drop support to log into file
56 * Logger: Remove unused includes
57 * Logger: Remove gLogToConsole flag
58 * configure.ac: Check for pkg-config
59
60 [ Alexander Huemer ]
61 * Unbreak `./configure --with-usrp1` build
62 * Fix USRP1 build with support for setting Rx/TxAntenna
63
64 [ Alexander Couzens ]
65 * jenkins.sh: fix the download url if the qemu image wasn't setup
66
67 -- Pau Espin Pedrol <pespin@sysmocom.de> Mon, 05 Mar 2018 16:49:42 +0100
68
Harald Welte78e1cd22017-10-28 17:52:32 +020069osmo-trx (0.2.0) unstable; urgency=medium
70
71 [ Alexander Chemeris ]
72 * EDGE: Add support for UmTRX.
73 * Common: Get rid of a compilation warning.
74 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
75 * transceiver: Properly handle MAXDLY.
76 * transceiver: Add an option to generate random Access Bursts.
77 * osmo-trx: Output Rx SPS as a part of configuration output.
78 * transceiver: Do not pass transceiver state struct to function where it's not used.
79 * makefile: Fix build from an external path.
80 * radioDevice: GSMRATE macro must have parentheses around its definition.
81 * uhd: Fix comment.
82 * radioInterface: Initialize power scale with a meaningful default.
83 * transceiver: Log channel number in DEBUG output of demoded bursts.
84 * transceiver: Add an option to emulate a RACH delay in random filler mode.
85 * UHD: Initial LimeSDR support.
86 * CommonLibs: Remove unused files.
87 * sigProcLib: Typo sybols -> symbols
88 * radioBuffer: Remove extra ; at the end of inline function definitions.
89 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
90 * sigProcLib: make energyDetect() simpler by returning actual energy.
91 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
92 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
93 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
94 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
95 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
96 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
97 * signalVector: Implement segment().
98 * vector: Introduce segmentMove() method to move data inside of a vector.
99 * vector: Introduce shrink() function to shrink vector size without loosing data.
100 * Move CorrType type from Transceiver to sigProcLib.
101 * sigProcLib: rename signalError type to SignalError.
102 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
103 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
104 * sigProcLib: Add operator<< to print CorrType to a string.
105 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
106 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
107 * sigProcLib: constify signalVector arguments for detectBurst() functions.
108 * sigProcLib: Constify demodulation functions burst argument.
109 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
110 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
111 * BitVector: Remove Generator class.
112 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
113
114 [ Tom Tsou ]
115 * EDGE: Fix USRP B210 device support
116 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
117 * EDGE: Fix demodulation slicer input
118 * common: Restrict UDP binding to localhost only
119 * common: Add mandatory length field to UDP receive calls
120 * uhd: Update default E3XX settings
121 * uhd: Set default Tx sampling to 4 sps
122 * uhd: Make device offset check a private method
123 * uhd: Set minimum UHD version requirement for E3XX
124 * sigproc: Expand RACH, TSC, and EDGE correlation windows
125 * transceiver: Do not report error on SETTSC when radio is on
126 * transceiver: Add Rx samples-per-symbol option
127 * radioInterface: Convert diversity argument to general type
128 * iface: Add inner ring-buffer implementation
129 * mcbts: Add multi-ARFCN channelizing filters
130 * mcbts: Add multi-ARFCN radio support
131 * sigproc: Adjust burst detection threshold criteria
132 * egprs: Enable 8-PSK length vectors on the Tx interface
133 * egprs: Enable 8-PSK burst detection when EDGE is enabled
134 * transceiver: Remove HANDOVER warnings
135 * mcbts: Allow out of order channel setup
136 * radioInterface: Fix multi-channel buffer index bug
137 * uhd: Add command line option for GPS reference
138 * transceiver: Fix mixed GSMK / 8-PSK transmission
139 * transceiver: Fix 4 SPS receive TOA value
140 * sigproc: Fix missing 8-PSK tail symbols
141 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
142 * sigproc: Match differential GMSK start/end bits to tail bits
143 * uhd: Add missing B200 sample timing for 4 SPS receive
144 * transceiver: Fix command build warning
145 * uhd: Set minimum supported version to 3.9.0
146 * uhd: Add X300 sample timing for 4 SPS
147 * Revert "uhd: Set minimum supported version to 3.9.0"
148 * uhd: Add support for UHD-3.11 logging control
149 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
150 * Resampler: Fix initialization return checking
151 * sigProcLib: Remove unreachable code and no-effect checks
152 * sigProcLib: Check return status on downsampling
153 * sigProcLib: Fix negative value check on unsigned value
154 * Resampler: Fix non-array delete for filter taps
155 * Transceiver: Remove unsigned negative compares
156 * Configuration: Fix const and signedness compile warnings
157 * config: Remove OpenBTS style sqlite configuration
158 * radioInterface: Remove UmTRX 'diversity' option
159 * build: Require and check for gcc C++11 support
160 * uhd: Use map container for for device parameter access
161 * sigProcLib: Remove unused functions from public interface
162 * uhd: Add non-UmTRX channel swap support
163 * uhd: Fix Tx-RX timing offset setting
164 * uhd: Fix USRP2/N200/N210 device detection
165 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
166 * sigProcLib: Fix complex/real vector flag in Laurent modulator
167 * sigProcLib: Remove heap based signal vector allocations
168 * common: Declare explicit Vector move constructor
169 * sigProcLib: Remove trigonometric tables
170 * sigProcLib: Use explicit NaN check in sinc table generation
171 * sigProcLib: Replace dynamically allocated resampling buffers
172 * sigProcLib: Specify standard namespace for isnan()
173 * uhd: Always specify samples-per-symbol for device lookup
174 * LimeSDR: set approximate tx offset value to make GSM work
175
176 [ Neels Hofmeyr ]
177 * add basic .gitignore
178 * configure.ac: check for boost/config.hpp header
179 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
180 * add contrib/jenkins.sh, for gerrit build bot
181
182 [ pierre.baudry ]
183 * transceiver: Fix mismatched allocations and deallocations
184
185 [ Holger Hans Peter Freyther ]
186 * debian: Require fftw3 header files for osmo-trx
187
188 [ Max ]
189 * Add gerrit settings
190 * Integrate Debian packaging changes
191 * Remove embedded sqlite3
192 * Fix building against sqlite3
193 * Add autoconf-archive to dependencies
194 * debian: remove obsolete dependency
195 * deb: remove unused dependency
196 * Remove redundant explicit dependency
197 * Use release helper from libosmocore
198
199 [ Ruben Undheim ]
200 * Do not embed sqlite3 when building
201
202 [ Philipp Maier ]
203 * buildenv: Turn off native architecture builds
204 * cosmetic: Make parameter lists uniform
205 * Add test program to verify convolution implementation
206 * ssedetect: Add runtime CPU detection
207 * cosmetic: remove code duplication
208 * buildenv: Make build CPU invariant
209 * buildenv: Split up SSE3 and SSE4.1 code
210 * cosmetic: Add info about SSE support
211
212 [ Vadim Yanitskiy ]
213 * buildenv: correct the ax_sse macro description
214 * buildenv: actually strip unused cpuid functionality
215 * buildenv: fix build on systems without SIMD support
216 * buildenv: cosmetic changes
217 * buildenv: check for __builtin_cpu_supports call support
218 * ssedetect: call __builtin_cpu_supports() only if supported
219
220 [ Pau Espin Pedrol ]
221 * cosmetic: transciever: Remove trailing whitespaces
222 * transceiver: Avoid sending clock indications when trx is not powered on
223 * Add -j option to bind to specific address
224
225 [ ignasj ]
226 * LimeSDR: Change device detection to work with USB and PCIe versions
227 * LimeSDR: change tx window type to TX_WINDOW_FIXED
228 * LimeSDR: Fix sample value range
229
230 [ Harald Welte ]
231 * Add '-t' command line option to enable SCHED_RR
232 * Import git-version-gen and update AC_INIT()
233
234 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
235
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100236osmo-trx (0.1.9) trusty; urgency=medium
237
238 * Ask Ivan, really
239
240 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
241
242osmo-trx (0.1.8) precise; urgency=low
243
244 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
245
246 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400