blob: dc20ec8dc4b8a4d686a76e7c6f21d1142731c8a5 [file] [log] [blame]
Harald Welted20b7fa2019-01-20 19:35:05 +01001osmo-trx (1.0.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * doc: examples: Add umtrx sample config
5 * UHDDevice: Fix setup failure with LimeSuite > 18.04.1
6 * examples: Set rt-prio 18 and print file basename
7 * lms: Several improvements and compilation/runtime fixes
8 * build: Add support for LimeSuite device backend
9 * LMSDevice: Set correct values for Max{Tx,Rx}Gain
10 * LMSDevice: Fix setup failure with LimeSuite > 18.04.1
11 * lms: Makefile.am: Reorder params to fix link issue
12 * lms: Check LPBFW to set is within supported range
13 * debian: Add package osmo-trx-lms
14 * contrib: Add systemd services for all backends
15 * debian: Add cfg file examples for osmo-trx-{lms,uhd}
16 * Add -V param to print version
17 * lms: Allow values diff than 34dB to be set by setRxGain()
18 * Use correct paths when installing example files
19 * debian: Enable build of osmo-trx-lms
20 * debian: Explicitly enable osmo-trx-uhd build
21 * configure.ac: Fix typo in with-lms help string
22 * vty: Fix typo in gpsdo clock reference type
23 * configure.ac: Add --enable-werror option
24 * Logger: Disable pthread cancel point inside Logger destructor
25 * cosmetic: Fix trailing whitespace
26 * radioInterface: forward errors from RadioDevice to Transceiver in recv path
27 * lms: Return error on device read timeout
28 * osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
29 * radioInterface: Fix variable storing integer return value
30 * configure.ac: Specify default language as C++
31 * UHHDDevice: Replace deprecated header uhd/utils/thread_priority.hpp
32 * SigProcLib: Use available copyTo Vector API instead of memcopy
33 * cosmetic: Fix trailing whitespace in several files
34 * radioInterfaceMulti:pullBuffer: Sanely convert float array to complex array
35 * Vector: Copy arrays in a sane way for non-trivially copyable types
36 * jenkins.sh: Add --enable-werror flag to osmo-trx configure step
37 * Install systemd services with autotools
38 * Install sample cfg file to /etc/osmocom
39 * cosmetic: Use proper whitespace in several for loops
40 * Use pthread_setname_np to name threads
41 * CommonLibs/Makefile.am: Specify libcommon_la_LIBADD
42 * Transciever: Log values causing Tx underrun
43 * examples: Use logging level 'set-all' instead of 'all'
44 * jenkins.sh: Enable build of osmo-trx-lms
45 * ChannelizerBase: Fix ASan alloc-dealloc-mismatch
46 * UHDDevice: setRxGain on chan 0 when using multi-arfcn
47 * lms: Use LimeSuite.h log level defines instead of hardcoded values
48 * lms: Apply LMS->OSMO log level conversion
49 * Introduce OsmoTRX manual
50 * Introduce chapter trx_if.adoc and add it to OsmoTRX and OsmoBTS
51 * trx: Add reference to project wiki page in overfiew section
52 * trx: Add Hardware architecture support section
53 * trx: Add Hardware device support section
54 * osmotrx: Split Device specific section from backend one
55 * osmotrx: Write initial documentation for several supported devices
56 * osmotrx: configuration: Add section to document multi-arfcn feature
57 * osmotrx: Create a common chapter for section documenting backends
58 * osmotrx: Introduce code architecture chapter
59 * lms: Fix start after stop of device
60 * lms: Destroy streams on device stop
61 * radioInterface: Fix memleak during close()
62 * PointerFIFO: Fix memleak of ListNode
63 * lms: Make sure LMS_Close is called when Device is torn down
64 * osmo-trx: Change some lines to use libosmocore logging instead of cout
65 * lms: Close device on LMS_Init failure
66 * SigProcLib: Improve Vector buffer allocation mess
67 * lms: Allow setting Tx/RxGain for chan!=0
68 * lms: Allow setting Tx/RxFreq for lchan!=0
69 * lms: Improve Set{Rx,Tx}{Gain,Freq} logging
70 * transceiver: log chan on CTRL command received
71 * Add TRXCTRL log category
72 * transceiver: Log TRXCTRL iface responses towards osmo-bts-trx
73 * lms: Move {under,over}run checks into separate method
74 * lms: Do {under,over}run checks even if LMS_RecvStream fails
75 * Timeval: passed() returns true if time is equal
76 * Timeval: Move implementation to use clock_gettime and timespec
77 * Timeval: Move to osmo_clock_gettime
78 * TimevalTest: Make test deterministic with fake time
79 * lms: Fix build against LimeSuite > 18.10
80 * configure.ac: check boost only if USRP1 support is enabled
81
82 [ Vadim Yanitskiy ]
83 * trx_vty.c: fix: use CONFIG_NODE as parent by default
84 * device/lms/LMSDevice.cpp: fix compilation warning
85 * sigProcLib: introduce both TS1 and TS2 RACH synch. sequences
86 * sigProcLib: add a CorrType for extended (11-bit) RACH
87
88 [ Harald Welte ]
89 * Initial work towards direct LimeSuite support in OsmoTRX
90 * update .gitignore to include osmo-trx-lms
91 * LMSDevice: Call LMS_Init() before setting sample rate
92 * LMSDevice: Print sample rate range + actual sample rate after setting it
93 * LMSDevice: Typo fix: s/Internal/External
94 * LMSDevice: Set low-pass filters to smallest possible option
95 * LMSDevice: Fix initial timestamp offset of 2500
96 * LMS_Device: Set ts_offset to 0.
97 * LMSDevice: Reduce Rx logging verbosity: Only log unexpected timestamps
98 * move set_antennas() from UHD to generic radioDevice base class
99 * lms: Fix support for rx_paths / tx_paths
100 * lms: Call set_antennas() during open() method
101 * radioDevice: Move tx_sps from derived into base class
102 * radioDevice: better encapsulation in base class
103 * lms: Fix coding style
104 * lms: Fail in case of unsupported configuration
105 * usrp1: Fail in case of unsupported configuration
106 * Fix config file saving of {tx,rx}-path VTY config strings
107 * logging: Introduce new "DDEV" category for device-specific code
108 * update git-version-gen to generate proper version numbers
109 * ensure well-formed example config files
110 * SocketsTest.testReaderIP(): Zero terminate received buffer
111 * trx_validate_config(): Fix validation of rx_sps
112 * vty-ref: Update URI of docbook 5.0 schema
113 * lms: User correct scale factor for transmit samples
114 * lms: Set Rx gain to midpoint, as comment suggests.
115 * usrp1: Remove uninitialized skipRx logic
116 * usrp1: Fix formatting of log message (missing space)
117 * cosmetic: Don't call the SDR "USRP" in error message
118
119 [ Zydrunas Tamosevicius ]
120 * lms: Use same timestamp offset like when using LimeSDR via UHD
121 * lms: Reduce log level of "send buffer of len ..."
122 * lms: fix LMS_StartStream() handling for multiple channels
123 * lms: Reduce Rx gain from 47 to 34 dB
124
125 [ Alexander Couzens ]
126 * debian: add patches for debian8
127
128 [ Oliver Smith ]
129 * Add long parameters (--help, --version, ...)
130 * build manuals moved here from osmo-gsm-manuals.git
131 * Fix DISTCHECK_CONFIGURE_FLAGS override
132 * contrib/jenkins.sh: build and publish manuals
133 * jenkins.sh: run "make distcheck"
134 * contrib: fix makedistcheck with disabled systemd
135 * osmo-trx.cpp: move comma_delimited_to_vector() to Utils.cpp
136 * LMSDevice: make use of dev-args in osmo-trx.cfg
137 * LMSDeviceTest: fix link errors on OBS
138
139 [ Neels Hofmeyr ]
140 * Importing history from osmo-gsm-manuals.git
141
142 [ d0gtail ]
143 * UHDDevice: log exception information on device open failure
144
145 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 19:35:04 +0100
146
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +0200147osmo-trx (0.4.0) unstable; urgency=medium
148
149 [ Neels Hofmeyr ]
150 * jenkins: use osmo-clean-workspace.sh before and after build
151
152 [ Harald Welte ]
153 * SocketsTest: Fix printing of non-nul-terminated string
154 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
155 * debian/control: Remove "Maintainer" from binary package section
156 * debian/rules: Make sure we always require libusrp
157 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
158 * debian/control: Add build dependency to libusrp-dev
159 * update .gitignore for new executable names
160 * osmo-trx: s/GSM Core Address/GSM BTS Address/
161
162 [ Piotr Krysik ]
163 * UHDDevice.cpp: add USRP B205mini support
164
165 [ Max ]
166 * Mark release target as virtual
167 * Remove outdated references to OpenBTS
168 * Remove unused headers
169 * Update installation instructions
170 * Update legal disclaimer
171 * Update license notes
172 * tests: null-terminate buffer
173
174 [ Pau Espin Pedrol ]
175 * cosmetic: Remove trailing whitespace
176 * Logger: Stop using Log.Alarms.Max from config
177 * Logger: Stop using Log.File and Log.Level from config
178 * Drop use of ConfigurationTable gConfig
179 * Remove Configuration module and libsqlite dependency
180 * cosmetic: AUTHORS: fix trailing whitespace
181 * Set up GNU Autotest infrastructure
182 * tests: InterThread: adapt to have reproducible output and enable autotest
183 * tests: Timeval: adapt to have reproducible output and enable autotest
184 * tests: Log: adapt to have reproducible output and enable autotest
185 * Sockets.cpp: Fix initialization of UDD socket
186 * tests: Sockets: adapt to have reproducible output and enable autotest
187 * utils/convolvtest: Remove uneeded libosmocore dependency
188 * Move ARCH_LA to Makefile.common
189 * tests: Migrate convtest util to autotest infrastructure
190 * arm/convert.c: Fix compilation error
191 * arm/convert.c: Add missing convert_init implementation
192 * .gitignore: Add missing test related files
193 * Remove UDDSocket class
194 * tests: SocketTests: Pick OS-assigned instead of setting one manually
195 * tests: SocketsTest: Avoid hang forever if test fails
196 * tests: SocketsTest: Fail test on write fail
197 * tests: TimevalTest: refactor and avoid double comparison
198 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
199 * tests: convolve: Disable due to difference in output in different archs
200 * Remove unneeded libdl dependency
201 * Fix whitespace
202 * Add support to set Rx/TxAntenna
203 * UHDDevice: Initialize async_event_thrd in constructor
204 * Logger: Drop unused gLogEarly
205 * Logger: Remove unused logging macros
206 * Logger: get rid of alarm APIs
207 * Logger: Drop syslog support
208 * Logger: Drop support to log into file
209 * Logger: Remove unused includes
210 * Logger: Remove gLogToConsole flag
211 * configure.ac: Check for pkg-config
212 * Depend on libosmocore
213 * osmo-trx: set up signals using libosmocore helpers
214 * osmo-trx: Set up talloc ctx
215 * debian: Depend on libtalloc and libosmocore
216 * Add initial support for logging, vty, ctrl
217 * Logger: Use libosmocore logging system
218 * osmo-trx.cpp: Move trx start and stop to helper functions
219 * Move enums required by VTY to a separate header
220 * vty: Implement VTY cfg parsing for current parameters
221 * doc: Add sample cfg file for LimeSDR
222 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
223 * osmo-trx: Re-introduce -l cmd line parameter
224 * Makefile.am: Avoid using subdir if arch is not required
225 * Build Transceiver52M/common as an .la lib
226 * use osmo_init_logging2()
227 * tests: Makefile.am: Fix typo in include path
228 * configure.ac: Add --enable-sanitize option
229 * Move arch specific fiels to arch subdir
230 * Move device specific files to device subdir
231 * Change configure define USRP1 to DEVICE_USRP1
232 * Move device specific code out of radioInterface
233 * Transceiver: Move device specific code to radioDevice class
234 * Build one osmo-trx binary for each device support enabled
235 * Logger: Print correct source file and line number
236 * Transceiver: log timing info of stale bursts
237 * build: Fix make distcheck
238 * build: More OBS build failure fixes
239 * jenkins.sh: Enable build of osmo-trx-usrp1
240 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
241 * debian: Fix OBS build
242 * build: Fix OBS build for ARM
243 * git-version-gen: Take into account tags not in master
244
245 [ Alexander Huemer ]
246 * Unbreak `./configure --with-usrp1` build
247 * Fix USRP1 build with support for setting Rx/TxAntenna
248
249 [ Alexander Couzens ]
250 * jenkins.sh: fix the download url if the qemu image wasn't setup
251 * jenkins.sh: cleanup always the workspace
252 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
253
254 [ Vadim Yanitskiy ]
255 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
256 * Transceiver.cpp: properly zero-terminate received commands
257 * Transceiver.cpp: use pointer arithmetics for CMD parsing
258 * Transceiver.cpp: fix incorrect format string for SETTSC
259 * Transceiver.cpp: prevent out-of-range array access
260
261 [ Martin Hauke ]
262 * configure.ac: Fix typo
263
264 [ Philipp Maier ]
265 * doc: add example config for usrp B200 series
266
267 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
268
Harald Welte78e1cd22017-10-28 17:52:32 +0200269osmo-trx (0.2.0) unstable; urgency=medium
270
271 [ Alexander Chemeris ]
272 * EDGE: Add support for UmTRX.
273 * Common: Get rid of a compilation warning.
274 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
275 * transceiver: Properly handle MAXDLY.
276 * transceiver: Add an option to generate random Access Bursts.
277 * osmo-trx: Output Rx SPS as a part of configuration output.
278 * transceiver: Do not pass transceiver state struct to function where it's not used.
279 * makefile: Fix build from an external path.
280 * radioDevice: GSMRATE macro must have parentheses around its definition.
281 * uhd: Fix comment.
282 * radioInterface: Initialize power scale with a meaningful default.
283 * transceiver: Log channel number in DEBUG output of demoded bursts.
284 * transceiver: Add an option to emulate a RACH delay in random filler mode.
285 * UHD: Initial LimeSDR support.
286 * CommonLibs: Remove unused files.
287 * sigProcLib: Typo sybols -> symbols
288 * radioBuffer: Remove extra ; at the end of inline function definitions.
289 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
290 * sigProcLib: make energyDetect() simpler by returning actual energy.
291 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
292 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
293 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
294 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
295 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
296 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
297 * signalVector: Implement segment().
298 * vector: Introduce segmentMove() method to move data inside of a vector.
299 * vector: Introduce shrink() function to shrink vector size without loosing data.
300 * Move CorrType type from Transceiver to sigProcLib.
301 * sigProcLib: rename signalError type to SignalError.
302 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
303 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
304 * sigProcLib: Add operator<< to print CorrType to a string.
305 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
306 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
307 * sigProcLib: constify signalVector arguments for detectBurst() functions.
308 * sigProcLib: Constify demodulation functions burst argument.
309 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
310 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
311 * BitVector: Remove Generator class.
312 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
313
314 [ Tom Tsou ]
315 * EDGE: Fix USRP B210 device support
316 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
317 * EDGE: Fix demodulation slicer input
318 * common: Restrict UDP binding to localhost only
319 * common: Add mandatory length field to UDP receive calls
320 * uhd: Update default E3XX settings
321 * uhd: Set default Tx sampling to 4 sps
322 * uhd: Make device offset check a private method
323 * uhd: Set minimum UHD version requirement for E3XX
324 * sigproc: Expand RACH, TSC, and EDGE correlation windows
325 * transceiver: Do not report error on SETTSC when radio is on
326 * transceiver: Add Rx samples-per-symbol option
327 * radioInterface: Convert diversity argument to general type
328 * iface: Add inner ring-buffer implementation
329 * mcbts: Add multi-ARFCN channelizing filters
330 * mcbts: Add multi-ARFCN radio support
331 * sigproc: Adjust burst detection threshold criteria
332 * egprs: Enable 8-PSK length vectors on the Tx interface
333 * egprs: Enable 8-PSK burst detection when EDGE is enabled
334 * transceiver: Remove HANDOVER warnings
335 * mcbts: Allow out of order channel setup
336 * radioInterface: Fix multi-channel buffer index bug
337 * uhd: Add command line option for GPS reference
338 * transceiver: Fix mixed GSMK / 8-PSK transmission
339 * transceiver: Fix 4 SPS receive TOA value
340 * sigproc: Fix missing 8-PSK tail symbols
341 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
342 * sigproc: Match differential GMSK start/end bits to tail bits
343 * uhd: Add missing B200 sample timing for 4 SPS receive
344 * transceiver: Fix command build warning
345 * uhd: Set minimum supported version to 3.9.0
346 * uhd: Add X300 sample timing for 4 SPS
347 * Revert "uhd: Set minimum supported version to 3.9.0"
348 * uhd: Add support for UHD-3.11 logging control
349 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
350 * Resampler: Fix initialization return checking
351 * sigProcLib: Remove unreachable code and no-effect checks
352 * sigProcLib: Check return status on downsampling
353 * sigProcLib: Fix negative value check on unsigned value
354 * Resampler: Fix non-array delete for filter taps
355 * Transceiver: Remove unsigned negative compares
356 * Configuration: Fix const and signedness compile warnings
357 * config: Remove OpenBTS style sqlite configuration
358 * radioInterface: Remove UmTRX 'diversity' option
359 * build: Require and check for gcc C++11 support
360 * uhd: Use map container for for device parameter access
361 * sigProcLib: Remove unused functions from public interface
362 * uhd: Add non-UmTRX channel swap support
363 * uhd: Fix Tx-RX timing offset setting
364 * uhd: Fix USRP2/N200/N210 device detection
365 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
366 * sigProcLib: Fix complex/real vector flag in Laurent modulator
367 * sigProcLib: Remove heap based signal vector allocations
368 * common: Declare explicit Vector move constructor
369 * sigProcLib: Remove trigonometric tables
370 * sigProcLib: Use explicit NaN check in sinc table generation
371 * sigProcLib: Replace dynamically allocated resampling buffers
372 * sigProcLib: Specify standard namespace for isnan()
373 * uhd: Always specify samples-per-symbol for device lookup
374 * LimeSDR: set approximate tx offset value to make GSM work
375
376 [ Neels Hofmeyr ]
377 * add basic .gitignore
378 * configure.ac: check for boost/config.hpp header
379 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
380 * add contrib/jenkins.sh, for gerrit build bot
381
382 [ pierre.baudry ]
383 * transceiver: Fix mismatched allocations and deallocations
384
385 [ Holger Hans Peter Freyther ]
386 * debian: Require fftw3 header files for osmo-trx
387
388 [ Max ]
389 * Add gerrit settings
390 * Integrate Debian packaging changes
391 * Remove embedded sqlite3
392 * Fix building against sqlite3
393 * Add autoconf-archive to dependencies
394 * debian: remove obsolete dependency
395 * deb: remove unused dependency
396 * Remove redundant explicit dependency
397 * Use release helper from libosmocore
398
399 [ Ruben Undheim ]
400 * Do not embed sqlite3 when building
401
402 [ Philipp Maier ]
403 * buildenv: Turn off native architecture builds
404 * cosmetic: Make parameter lists uniform
405 * Add test program to verify convolution implementation
406 * ssedetect: Add runtime CPU detection
407 * cosmetic: remove code duplication
408 * buildenv: Make build CPU invariant
409 * buildenv: Split up SSE3 and SSE4.1 code
410 * cosmetic: Add info about SSE support
411
412 [ Vadim Yanitskiy ]
413 * buildenv: correct the ax_sse macro description
414 * buildenv: actually strip unused cpuid functionality
415 * buildenv: fix build on systems without SIMD support
416 * buildenv: cosmetic changes
417 * buildenv: check for __builtin_cpu_supports call support
418 * ssedetect: call __builtin_cpu_supports() only if supported
419
420 [ Pau Espin Pedrol ]
421 * cosmetic: transciever: Remove trailing whitespaces
422 * transceiver: Avoid sending clock indications when trx is not powered on
423 * Add -j option to bind to specific address
424
425 [ ignasj ]
426 * LimeSDR: Change device detection to work with USB and PCIe versions
427 * LimeSDR: change tx window type to TX_WINDOW_FIXED
428 * LimeSDR: Fix sample value range
429
430 [ Harald Welte ]
431 * Add '-t' command line option to enable SCHED_RR
432 * Import git-version-gen and update AC_INIT()
433
434 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
435
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100436osmo-trx (0.1.9) trusty; urgency=medium
437
438 * Ask Ivan, really
439
440 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
441
442osmo-trx (0.1.8) precise; urgency=low
443
444 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
445
446 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400