blob: a9724d8bd6cd6cd65e21bc8a68d0e1257a032514 [file] [log] [blame]
Pau Espin Pedrold0ac9262018-05-03 16:23:30 +02001osmo-trx (0.4.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * jenkins: use osmo-clean-workspace.sh before and after build
5
6 [ Harald Welte ]
7 * SocketsTest: Fix printing of non-nul-terminated string
8 * Revert "debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb"
9 * debian/control: Remove "Maintainer" from binary package section
10 * debian/rules: Make sure we always require libusrp
11 * debian: Ensure USRP1 firmware is part of osmo-trx-usrp1
12 * debian/control: Add build dependency to libusrp-dev
13 * update .gitignore for new executable names
14 * osmo-trx: s/GSM Core Address/GSM BTS Address/
15
16 [ Piotr Krysik ]
17 * UHDDevice.cpp: add USRP B205mini support
18
19 [ Max ]
20 * Mark release target as virtual
21 * Remove outdated references to OpenBTS
22 * Remove unused headers
23 * Update installation instructions
24 * Update legal disclaimer
25 * Update license notes
26 * tests: null-terminate buffer
27
28 [ Pau Espin Pedrol ]
29 * cosmetic: Remove trailing whitespace
30 * Logger: Stop using Log.Alarms.Max from config
31 * Logger: Stop using Log.File and Log.Level from config
32 * Drop use of ConfigurationTable gConfig
33 * Remove Configuration module and libsqlite dependency
34 * cosmetic: AUTHORS: fix trailing whitespace
35 * Set up GNU Autotest infrastructure
36 * tests: InterThread: adapt to have reproducible output and enable autotest
37 * tests: Timeval: adapt to have reproducible output and enable autotest
38 * tests: Log: adapt to have reproducible output and enable autotest
39 * Sockets.cpp: Fix initialization of UDD socket
40 * tests: Sockets: adapt to have reproducible output and enable autotest
41 * utils/convolvtest: Remove uneeded libosmocore dependency
42 * Move ARCH_LA to Makefile.common
43 * tests: Migrate convtest util to autotest infrastructure
44 * arm/convert.c: Fix compilation error
45 * arm/convert.c: Add missing convert_init implementation
46 * .gitignore: Add missing test related files
47 * Remove UDDSocket class
48 * tests: SocketTests: Pick OS-assigned instead of setting one manually
49 * tests: SocketsTest: Avoid hang forever if test fails
50 * tests: SocketsTest: Fail test on write fail
51 * tests: TimevalTest: refactor and avoid double comparison
52 * contrib/jenkins.sh: Use qemu+proot+debootstrap to run tests with ARM instruction set
53 * tests: convolve: Disable due to difference in output in different archs
54 * Remove unneeded libdl dependency
55 * Fix whitespace
56 * Add support to set Rx/TxAntenna
57 * UHDDevice: Initialize async_event_thrd in constructor
58 * Logger: Drop unused gLogEarly
59 * Logger: Remove unused logging macros
60 * Logger: get rid of alarm APIs
61 * Logger: Drop syslog support
62 * Logger: Drop support to log into file
63 * Logger: Remove unused includes
64 * Logger: Remove gLogToConsole flag
65 * configure.ac: Check for pkg-config
66 * Depend on libosmocore
67 * osmo-trx: set up signals using libosmocore helpers
68 * osmo-trx: Set up talloc ctx
69 * debian: Depend on libtalloc and libosmocore
70 * Add initial support for logging, vty, ctrl
71 * Logger: Use libosmocore logging system
72 * osmo-trx.cpp: Move trx start and stop to helper functions
73 * Move enums required by VTY to a separate header
74 * vty: Implement VTY cfg parsing for current parameters
75 * doc: Add sample cfg file for LimeSDR
76 * osmo-trx: Use VTY cfg structures while still allowing cmd line options
77 * osmo-trx: Re-introduce -l cmd line parameter
78 * Makefile.am: Avoid using subdir if arch is not required
79 * Build Transceiver52M/common as an .la lib
80 * use osmo_init_logging2()
81 * tests: Makefile.am: Fix typo in include path
82 * configure.ac: Add --enable-sanitize option
83 * Move arch specific fiels to arch subdir
84 * Move device specific files to device subdir
85 * Change configure define USRP1 to DEVICE_USRP1
86 * Move device specific code out of radioInterface
87 * Transceiver: Move device specific code to radioDevice class
88 * Build one osmo-trx binary for each device support enabled
89 * Logger: Print correct source file and line number
90 * Transceiver: log timing info of stale bursts
91 * build: Fix make distcheck
92 * build: More OBS build failure fixes
93 * jenkins.sh: Enable build of osmo-trx-usrp1
94 * debian: Remove osmo-trx-usrp1 until we can build libusrp1.deb
95 * debian: Fix OBS build
96 * build: Fix OBS build for ARM
97 * git-version-gen: Take into account tags not in master
98
99 [ Alexander Huemer ]
100 * Unbreak `./configure --with-usrp1` build
101 * Fix USRP1 build with support for setting Rx/TxAntenna
102
103 [ Alexander Couzens ]
104 * jenkins.sh: fix the download url if the qemu image wasn't setup
105 * jenkins.sh: cleanup always the workspace
106 * jenkins.sh: change qemu-img default location to $HOME/qemu-img instead of /opt/qemu-img
107
108 [ Vadim Yanitskiy ]
109 * Transceiver.cpp: use a define for the MAX_PACKET_LENGTH
110 * Transceiver.cpp: properly zero-terminate received commands
111 * Transceiver.cpp: use pointer arithmetics for CMD parsing
112 * Transceiver.cpp: fix incorrect format string for SETTSC
113 * Transceiver.cpp: prevent out-of-range array access
114
115 [ Martin Hauke ]
116 * configure.ac: Fix typo
117
118 [ Philipp Maier ]
119 * doc: add example config for usrp B200 series
120
121 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:23:29 +0200
122
Harald Welte78e1cd22017-10-28 17:52:32 +0200123osmo-trx (0.2.0) unstable; urgency=medium
124
125 [ Alexander Chemeris ]
126 * EDGE: Add support for UmTRX.
127 * Common: Get rid of a compilation warning.
128 * Common: Make sure gLogEarly() log to the same facilities as the normal log.
129 * transceiver: Properly handle MAXDLY.
130 * transceiver: Add an option to generate random Access Bursts.
131 * osmo-trx: Output Rx SPS as a part of configuration output.
132 * transceiver: Do not pass transceiver state struct to function where it's not used.
133 * makefile: Fix build from an external path.
134 * radioDevice: GSMRATE macro must have parentheses around its definition.
135 * uhd: Fix comment.
136 * radioInterface: Initialize power scale with a meaningful default.
137 * transceiver: Log channel number in DEBUG output of demoded bursts.
138 * transceiver: Add an option to emulate a RACH delay in random filler mode.
139 * UHD: Initial LimeSDR support.
140 * CommonLibs: Remove unused files.
141 * sigProcLib: Typo sybols -> symbols
142 * radioBuffer: Remove extra ; at the end of inline function definitions.
143 * sigProcLib: Fix documentation, sync argument names in .cpp and .h files.
144 * sigProcLib: make energyDetect() simpler by returning actual energy.
145 * sigProcLib: Rename demodulateBurst() to demodGmskBurst() for clarity.
146 * sigProcLib: Slice SoftVector instead of signalVector for GMSK demod.
147 * Call vectorSlicer() right before packing bits for transmission to osmo-bts.
148 * CommonLibs: Print soft bits with less confidence to console when printing a soft vector.
149 * BitVector: Remove convolutional codec - we don't use it in osmo-trx.
150 * BitVector: Convert SoftVector from 0..1 to -1..+1 soft bits.
151 * signalVector: Implement segment().
152 * vector: Introduce segmentMove() method to move data inside of a vector.
153 * vector: Introduce shrink() function to shrink vector size without loosing data.
154 * Move CorrType type from Transceiver to sigProcLib.
155 * sigProcLib: rename signalError type to SignalError.
156 * Move Transceiver::detectBurst() to sigProcLib to make it reusable.
157 * Move BURST_THRESH from Transceiver.cpp to sigProcLib.h to make it reusable.
158 * sigProcLib: Add operator<< to print CorrType to a string.
159 * sigProcLib.h: Fix whitespaces. No non-whitespace changes.
160 * Move Transceiver::demodulate() to sigProcLib to make it reusable.
161 * sigProcLib: constify signalVector arguments for detectBurst() functions.
162 * sigProcLib: Constify demodulation functions burst argument.
163 * sigProcLib: Fix number of tail bits in random Normal Bursts and zero Stealing Bits.
164 * Configuration: Variables allocated with 'new' must be freed with 'delete'.
165 * BitVector: Remove Generator class.
166 * PRBS: a Pseudo-random binary sequence (PRBS) generator class.
167
168 [ Tom Tsou ]
169 * EDGE: Fix USRP B210 device support
170 * uhd: Correct timing alignment in 8-PSK and GMSK downlink bursts
171 * EDGE: Fix demodulation slicer input
172 * common: Restrict UDP binding to localhost only
173 * common: Add mandatory length field to UDP receive calls
174 * uhd: Update default E3XX settings
175 * uhd: Set default Tx sampling to 4 sps
176 * uhd: Make device offset check a private method
177 * uhd: Set minimum UHD version requirement for E3XX
178 * sigproc: Expand RACH, TSC, and EDGE correlation windows
179 * transceiver: Do not report error on SETTSC when radio is on
180 * transceiver: Add Rx samples-per-symbol option
181 * radioInterface: Convert diversity argument to general type
182 * iface: Add inner ring-buffer implementation
183 * mcbts: Add multi-ARFCN channelizing filters
184 * mcbts: Add multi-ARFCN radio support
185 * sigproc: Adjust burst detection threshold criteria
186 * egprs: Enable 8-PSK length vectors on the Tx interface
187 * egprs: Enable 8-PSK burst detection when EDGE is enabled
188 * transceiver: Remove HANDOVER warnings
189 * mcbts: Allow out of order channel setup
190 * radioInterface: Fix multi-channel buffer index bug
191 * uhd: Add command line option for GPS reference
192 * transceiver: Fix mixed GSMK / 8-PSK transmission
193 * transceiver: Fix 4 SPS receive TOA value
194 * sigproc: Fix missing 8-PSK tail symbols
195 * uhd: Update USRP2/N200/N210 for 4 SPS Rx
196 * sigproc: Match differential GMSK start/end bits to tail bits
197 * uhd: Add missing B200 sample timing for 4 SPS receive
198 * transceiver: Fix command build warning
199 * uhd: Set minimum supported version to 3.9.0
200 * uhd: Add X300 sample timing for 4 SPS
201 * Revert "uhd: Set minimum supported version to 3.9.0"
202 * uhd: Add support for UHD-3.11 logging control
203 * uhd: Increase MC-BTS FPGA clock rate to 51.2 MHz
204 * Resampler: Fix initialization return checking
205 * sigProcLib: Remove unreachable code and no-effect checks
206 * sigProcLib: Check return status on downsampling
207 * sigProcLib: Fix negative value check on unsigned value
208 * Resampler: Fix non-array delete for filter taps
209 * Transceiver: Remove unsigned negative compares
210 * Configuration: Fix const and signedness compile warnings
211 * config: Remove OpenBTS style sqlite configuration
212 * radioInterface: Remove UmTRX 'diversity' option
213 * build: Require and check for gcc C++11 support
214 * uhd: Use map container for for device parameter access
215 * sigProcLib: Remove unused functions from public interface
216 * uhd: Add non-UmTRX channel swap support
217 * uhd: Fix Tx-RX timing offset setting
218 * uhd: Fix USRP2/N200/N210 device detection
219 * transceiver: Fix POWEROFF crash on USRP2/N200/X300 devices
220 * sigProcLib: Fix complex/real vector flag in Laurent modulator
221 * sigProcLib: Remove heap based signal vector allocations
222 * common: Declare explicit Vector move constructor
223 * sigProcLib: Remove trigonometric tables
224 * sigProcLib: Use explicit NaN check in sinc table generation
225 * sigProcLib: Replace dynamically allocated resampling buffers
226 * sigProcLib: Specify standard namespace for isnan()
227 * uhd: Always specify samples-per-symbol for device lookup
228 * LimeSDR: set approximate tx offset value to make GSM work
229
230 [ Neels Hofmeyr ]
231 * add basic .gitignore
232 * configure.ac: check for boost/config.hpp header
233 * The INSTALL file is being overwritten by autoreconf, but it is committed as empty file. As a result, the INSTALL file always shows as modified. Instead, remove INSTALL from git and ignore it.
234 * add contrib/jenkins.sh, for gerrit build bot
235
236 [ pierre.baudry ]
237 * transceiver: Fix mismatched allocations and deallocations
238
239 [ Holger Hans Peter Freyther ]
240 * debian: Require fftw3 header files for osmo-trx
241
242 [ Max ]
243 * Add gerrit settings
244 * Integrate Debian packaging changes
245 * Remove embedded sqlite3
246 * Fix building against sqlite3
247 * Add autoconf-archive to dependencies
248 * debian: remove obsolete dependency
249 * deb: remove unused dependency
250 * Remove redundant explicit dependency
251 * Use release helper from libosmocore
252
253 [ Ruben Undheim ]
254 * Do not embed sqlite3 when building
255
256 [ Philipp Maier ]
257 * buildenv: Turn off native architecture builds
258 * cosmetic: Make parameter lists uniform
259 * Add test program to verify convolution implementation
260 * ssedetect: Add runtime CPU detection
261 * cosmetic: remove code duplication
262 * buildenv: Make build CPU invariant
263 * buildenv: Split up SSE3 and SSE4.1 code
264 * cosmetic: Add info about SSE support
265
266 [ Vadim Yanitskiy ]
267 * buildenv: correct the ax_sse macro description
268 * buildenv: actually strip unused cpuid functionality
269 * buildenv: fix build on systems without SIMD support
270 * buildenv: cosmetic changes
271 * buildenv: check for __builtin_cpu_supports call support
272 * ssedetect: call __builtin_cpu_supports() only if supported
273
274 [ Pau Espin Pedrol ]
275 * cosmetic: transciever: Remove trailing whitespaces
276 * transceiver: Avoid sending clock indications when trx is not powered on
277 * Add -j option to bind to specific address
278
279 [ ignasj ]
280 * LimeSDR: Change device detection to work with USB and PCIe versions
281 * LimeSDR: change tx window type to TX_WINDOW_FIXED
282 * LimeSDR: Fix sample value range
283
284 [ Harald Welte ]
285 * Add '-t' command line option to enable SCHED_RR
286 * Import git-version-gen and update AC_INIT()
287
288 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 17:52:32 +0200
289
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +0100290osmo-trx (0.1.9) trusty; urgency=medium
291
292 * Ask Ivan, really
293
294 -- Kirill Zakharenko <earwin@gmail.com> Thu, 16 Jul 2015 12:13:46 +0000
295
296osmo-trx (0.1.8) precise; urgency=low
297
298 * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP
299
300 -- Ivan Klyuchnikov <Ivan.Kluchnikov@fairwaves.ru> Sun, 9 Mar 2014 14:10:10 +0400