blob: 71363ae722baa4ee29364739aa703eceb06c40fe [file] [log] [blame]
Pau Espin Pedrol1beada22022-06-28 18:27:29 +02001osmo-sysmon (0.3.2) unstable; urgency=medium
2
3 [ Oliver Smith ]
4 * treewide: remove FSF address
5
6 [ Pau Espin Pedrol ]
7 * Drop unneeded ax_check_compile_flag.m4
8
9 [ Harald Welte ]
10 * update git URLs (git -> https; gitea)
11
12 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 18:27:29 +0200
13
Pau Espin Pedrolbd144552021-11-16 14:46:05 +010014osmo-sysmon (0.3.1) unstable; urgency=medium
15
16 [ Oliver Smith ]
17 * configure.ac: set -std=gnu11
18 * configure: don't turn some warnings into errors
19
20 [ Harald Welte ]
21 * add README.md on what this repository is about
22
23 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:46:05 +0100
24
Harald Weltefaea0292021-01-06 16:56:14 +010025osmo-sysmon (0.3.0) unstable; urgency=medium
26
27 [ Daniel Willmann ]
28 * simple_ctrl: Don't cause an error if GET response is empty
29 * Cleaner output if sections are empty
30 * Add oneshot mode that exits after one iteration
31
32 [ Harald Welte ]
33 * exit(2) on unsupported positional arguments on command line
34 * configure.ac: Make configure.ac and debian/control agree on versions
35
36 -- Harald Welte <laforge@osmocom.org> Wed, 06 Jan 2021 16:56:14 +0100
37
Harald Welte7648a0e2019-07-14 08:04:51 +080038osmo-sysmon (0.2.0) unstable; urgency=medium
39
40 [ Harald Welte ]
41 * Initial empty repository
42 * initial checkin
43 * simple_ctrl: Add timeout to blocking I/O
44 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
45 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
46 * osmo-ctrl-client: Implement "monitor" mode
47 * simple-ctrl-client: Add basic help/usage information
48 * simple_ctrl: Abstract out timeval_from_msec() function
49 * simple_ctrl: Non-blocking connect() with timeout
50 * initial implementation of 'osysmon' main program + CTRL client
51 * add osysmon_sysinfo for uptime/ram/load
52 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
53 * osysmon_main: Show hierarchical/tree structure during printing
54 * value_node: add combined find_or_add() and avoid duplicate names
55 * value_node: Add 'idx' member to handle lookup by ifindex.
56 * Add network link + address monitiring via osysmon_rtnl.c
57 * add osysmon_file.c for reading/monitoring files (like sysfs)
58 * migrate to autoconf
59 * add .gitignore file
60 * rename to osmo-sysmon
61 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
62 * add contrib/jenkins.sh for build verification
63
64 [ Daniel Willmann ]
65 * Remove unused function
66 * Fix compilation issue on my machine, remove unused include
67 * Remove unused last_value handling code
68 * Add zero termination char to received ctrl cmd message
69 * Disconnect properly on errors so we can reconnect
70 * git-version-gen: Don't check for .git directory
71
72 [ Martin Hauke ]
73 * Makefile.am: Fix typo
74
75 [ Max ]
76 * Add git-review config
77 * Update gitignore
78 * Report config file name on error
79 * Update default config
80 * Expand default config
81 * Add OpenVPN status helper example from corresponding ticket
82 * Move shared libs into common LDADD
83 * Drop unused parameter
84 * ctrl: separate config structure
85 * Update Makefile.am
86 * Add ping probe support
87 * jenkins.sh: remove obsolete comments
88 * Install signal handlers before processing config
89 * ctrl: log host/port on errors
90 * Introduce generic host config and related helpers
91 * Add OpenVPN probe
92 * OpenVPN: track interface disconnect
93 * Update config example
94
95 [ Stefan Sperling ]
96 * fix file descriptor leak in osysmon_file_read
97
98 [ Pau Espin Pedrol ]
99 * Add m4 missing files to fix build
100 * Move source code to src subdir
101 * Add cmdline option parsing support
102 * Integrate sleeping/printing loop into osmo main loop
103 * openvpn: Improve logging and status information
104 * openvpn: Set reconnect timeout to a much lower value
105 * openvpn: String returned from openvpn is not null-terminated
106 * openvpn: log status description
107 * openvpn: Fix garbage printed after remote port
108 * openvpn: Remove useless conditional block in parse_state
109 * openvn: Fix missing break in last commit
110 * Add vty option to print output of shell cmd on every poll step
111 * Makefile.am: Add missing bits to have make release working
112 * Add debian packaging content
113 * Bump version: 0.0.1.66-d4c3-dirty → 0.1.0
114 * debian: Add missing libmnl-dev dependency
115 * Depend on liboping 1.7.0 instead of 1.9.0
116
117 [ Oliver Smith ]
118 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
119 * contrib/jenkins.sh: run "make maintainer-clean"
120
121 -- Harald Welte <laforge@gnumonks.org> Sun, 14 Jul 2019 08:04:51 +0800
122
Pau Espin Pedrolb1720a32019-03-20 13:14:31 +0100123osmo-sysmon (0.1.0) unstable; urgency=medium
124
125 [ Harald Welte ]
126 * initial checkin
127 * simple_ctrl: Add timeout to blocking I/O
128 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
129 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
130 * osmo-ctrl-client: Implement "monitor" mode
131 * simple-ctrl-client: Add basic help/usage information
132 * simple_ctrl: Abstract out timeval_from_msec() function
133 * simple_ctrl: Non-blocking connect() with timeout
134 * initial implementation of 'osysmon' main program + CTRL client
135 * add osysmon_sysinfo for uptime/ram/load
136 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
137 * osysmon_main: Show hierarchical/tree structure during printing
138 * value_node: add combined find_or_add() and avoid duplicate names
139 * value_node: Add 'idx' member to handle lookup by ifindex.
140 * Add network link + address monitiring via osysmon_rtnl.c
141 * add osysmon_file.c for reading/monitoring files (like sysfs)
142 * migrate to autoconf
143 * add .gitignore file
144 * rename to osmo-sysmon
145 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
146 * add contrib/jenkins.sh for build verification
147
148 [ Daniel Willmann ]
149 * Remove unused function
150 * Fix compilation issue on my machine, remove unused include
151 * Remove unused last_value handling code
152 * Add zero termination char to received ctrl cmd message
153 * Disconnect properly on errors so we can reconnect
154 * git-version-gen: Don't check for .git directory
155
156 [ Martin Hauke ]
157 * Makefile.am: Fix typo
158
159 [ Max ]
160 * Add git-review config
161 * Update gitignore
162 * Report config file name on error
163 * Update default config
164 * Expand default config
165 * Add OpenVPN status helper example from corresponding ticket
166 * Move shared libs into common LDADD
167 * Drop unused parameter
168 * ctrl: separate config structure
169 * Update Makefile.am
170 * Add ping probe support
171 * jenkins.sh: remove obsolete comments
172 * Install signal handlers before processing config
173 * ctrl: log host/port on errors
174 * Introduce generic host config and related helpers
175 * Add OpenVPN probe
176 * OpenVPN: track interface disconnect
177 * Update config example
178
179 [ Stefan Sperling ]
180 * fix file descriptor leak in osysmon_file_read
181
182 [ Pau Espin Pedrol ]
183 * Add m4 missing files to fix build
184 * Move source code to src subdir
185 * Add cmdline option parsing support
186 * Integrate sleeping/printing loop into osmo main loop
187 * openvpn: Improve logging and status information
188 * openvpn: Set reconnect timeout to a much lower value
189 * openvpn: String returned from openvpn is not null-terminated
190 * openvpn: log status description
191 * openvpn: Fix garbage printed after remote port
192 * openvpn: Remove useless conditional block in parse_state
193 * openvn: Fix missing break in last commit
194 * Add vty option to print output of shell cmd on every poll step
195 * Makefile.am: Add missing bits to have make release working
196 * Add debian packaging content
197
198 [ Oliver Smith ]
199 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
200
201 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 20 Mar 2019 13:14:30 +0100
202
Pau Espin Pedrol814882b2019-03-19 18:10:55 +0100203osmo-sysmon (0.0.1) unstable; urgency=medium
204
205 * Initial release.
206
207 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 19 Mar 2019 18:32:14 +0100