blob: 2d78a68ad254824e7a2800795383523301fafa7e [file] [log] [blame]
Harald Welte7648a0e2019-07-14 08:04:51 +08001osmo-sysmon (0.2.0) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * Initial empty repository
5 * initial checkin
6 * simple_ctrl: Add timeout to blocking I/O
7 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
8 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
9 * osmo-ctrl-client: Implement "monitor" mode
10 * simple-ctrl-client: Add basic help/usage information
11 * simple_ctrl: Abstract out timeval_from_msec() function
12 * simple_ctrl: Non-blocking connect() with timeout
13 * initial implementation of 'osysmon' main program + CTRL client
14 * add osysmon_sysinfo for uptime/ram/load
15 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
16 * osysmon_main: Show hierarchical/tree structure during printing
17 * value_node: add combined find_or_add() and avoid duplicate names
18 * value_node: Add 'idx' member to handle lookup by ifindex.
19 * Add network link + address monitiring via osysmon_rtnl.c
20 * add osysmon_file.c for reading/monitoring files (like sysfs)
21 * migrate to autoconf
22 * add .gitignore file
23 * rename to osmo-sysmon
24 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
25 * add contrib/jenkins.sh for build verification
26
27 [ Daniel Willmann ]
28 * Remove unused function
29 * Fix compilation issue on my machine, remove unused include
30 * Remove unused last_value handling code
31 * Add zero termination char to received ctrl cmd message
32 * Disconnect properly on errors so we can reconnect
33 * git-version-gen: Don't check for .git directory
34
35 [ Martin Hauke ]
36 * Makefile.am: Fix typo
37
38 [ Max ]
39 * Add git-review config
40 * Update gitignore
41 * Report config file name on error
42 * Update default config
43 * Expand default config
44 * Add OpenVPN status helper example from corresponding ticket
45 * Move shared libs into common LDADD
46 * Drop unused parameter
47 * ctrl: separate config structure
48 * Update Makefile.am
49 * Add ping probe support
50 * jenkins.sh: remove obsolete comments
51 * Install signal handlers before processing config
52 * ctrl: log host/port on errors
53 * Introduce generic host config and related helpers
54 * Add OpenVPN probe
55 * OpenVPN: track interface disconnect
56 * Update config example
57
58 [ Stefan Sperling ]
59 * fix file descriptor leak in osysmon_file_read
60
61 [ Pau Espin Pedrol ]
62 * Add m4 missing files to fix build
63 * Move source code to src subdir
64 * Add cmdline option parsing support
65 * Integrate sleeping/printing loop into osmo main loop
66 * openvpn: Improve logging and status information
67 * openvpn: Set reconnect timeout to a much lower value
68 * openvpn: String returned from openvpn is not null-terminated
69 * openvpn: log status description
70 * openvpn: Fix garbage printed after remote port
71 * openvpn: Remove useless conditional block in parse_state
72 * openvn: Fix missing break in last commit
73 * Add vty option to print output of shell cmd on every poll step
74 * Makefile.am: Add missing bits to have make release working
75 * Add debian packaging content
76 * Bump version: 0.0.1.66-d4c3-dirty → 0.1.0
77 * debian: Add missing libmnl-dev dependency
78 * Depend on liboping 1.7.0 instead of 1.9.0
79
80 [ Oliver Smith ]
81 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
82 * contrib/jenkins.sh: run "make maintainer-clean"
83
84 -- Harald Welte <laforge@gnumonks.org> Sun, 14 Jul 2019 08:04:51 +0800
85
Pau Espin Pedrolb1720a32019-03-20 13:14:31 +010086osmo-sysmon (0.1.0) unstable; urgency=medium
87
88 [ Harald Welte ]
89 * initial checkin
90 * simple_ctrl: Add timeout to blocking I/O
91 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
92 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
93 * osmo-ctrl-client: Implement "monitor" mode
94 * simple-ctrl-client: Add basic help/usage information
95 * simple_ctrl: Abstract out timeval_from_msec() function
96 * simple_ctrl: Non-blocking connect() with timeout
97 * initial implementation of 'osysmon' main program + CTRL client
98 * add osysmon_sysinfo for uptime/ram/load
99 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
100 * osysmon_main: Show hierarchical/tree structure during printing
101 * value_node: add combined find_or_add() and avoid duplicate names
102 * value_node: Add 'idx' member to handle lookup by ifindex.
103 * Add network link + address monitiring via osysmon_rtnl.c
104 * add osysmon_file.c for reading/monitoring files (like sysfs)
105 * migrate to autoconf
106 * add .gitignore file
107 * rename to osmo-sysmon
108 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
109 * add contrib/jenkins.sh for build verification
110
111 [ Daniel Willmann ]
112 * Remove unused function
113 * Fix compilation issue on my machine, remove unused include
114 * Remove unused last_value handling code
115 * Add zero termination char to received ctrl cmd message
116 * Disconnect properly on errors so we can reconnect
117 * git-version-gen: Don't check for .git directory
118
119 [ Martin Hauke ]
120 * Makefile.am: Fix typo
121
122 [ Max ]
123 * Add git-review config
124 * Update gitignore
125 * Report config file name on error
126 * Update default config
127 * Expand default config
128 * Add OpenVPN status helper example from corresponding ticket
129 * Move shared libs into common LDADD
130 * Drop unused parameter
131 * ctrl: separate config structure
132 * Update Makefile.am
133 * Add ping probe support
134 * jenkins.sh: remove obsolete comments
135 * Install signal handlers before processing config
136 * ctrl: log host/port on errors
137 * Introduce generic host config and related helpers
138 * Add OpenVPN probe
139 * OpenVPN: track interface disconnect
140 * Update config example
141
142 [ Stefan Sperling ]
143 * fix file descriptor leak in osysmon_file_read
144
145 [ Pau Espin Pedrol ]
146 * Add m4 missing files to fix build
147 * Move source code to src subdir
148 * Add cmdline option parsing support
149 * Integrate sleeping/printing loop into osmo main loop
150 * openvpn: Improve logging and status information
151 * openvpn: Set reconnect timeout to a much lower value
152 * openvpn: String returned from openvpn is not null-terminated
153 * openvpn: log status description
154 * openvpn: Fix garbage printed after remote port
155 * openvpn: Remove useless conditional block in parse_state
156 * openvn: Fix missing break in last commit
157 * Add vty option to print output of shell cmd on every poll step
158 * Makefile.am: Add missing bits to have make release working
159 * Add debian packaging content
160
161 [ Oliver Smith ]
162 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
163
164 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 20 Mar 2019 13:14:30 +0100
165
Pau Espin Pedrol814882b2019-03-19 18:10:55 +0100166osmo-sysmon (0.0.1) unstable; urgency=medium
167
168 * Initial release.
169
170 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 19 Mar 2019 18:32:14 +0100