blob: 2024e8801d59971482a14d83e67eef1871729336 [file] [log] [blame]
Harald Weltefaea0292021-01-06 16:56:14 +01001osmo-sysmon (0.3.0) unstable; urgency=medium
2
3 [ Daniel Willmann ]
4 * simple_ctrl: Don't cause an error if GET response is empty
5 * Cleaner output if sections are empty
6 * Add oneshot mode that exits after one iteration
7
8 [ Harald Welte ]
9 * exit(2) on unsupported positional arguments on command line
10 * configure.ac: Make configure.ac and debian/control agree on versions
11
12 -- Harald Welte <laforge@osmocom.org> Wed, 06 Jan 2021 16:56:14 +0100
13
Harald Welte7648a0e2019-07-14 08:04:51 +080014osmo-sysmon (0.2.0) unstable; urgency=medium
15
16 [ Harald Welte ]
17 * Initial empty repository
18 * initial checkin
19 * simple_ctrl: Add timeout to blocking I/O
20 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
21 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
22 * osmo-ctrl-client: Implement "monitor" mode
23 * simple-ctrl-client: Add basic help/usage information
24 * simple_ctrl: Abstract out timeval_from_msec() function
25 * simple_ctrl: Non-blocking connect() with timeout
26 * initial implementation of 'osysmon' main program + CTRL client
27 * add osysmon_sysinfo for uptime/ram/load
28 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
29 * osysmon_main: Show hierarchical/tree structure during printing
30 * value_node: add combined find_or_add() and avoid duplicate names
31 * value_node: Add 'idx' member to handle lookup by ifindex.
32 * Add network link + address monitiring via osysmon_rtnl.c
33 * add osysmon_file.c for reading/monitoring files (like sysfs)
34 * migrate to autoconf
35 * add .gitignore file
36 * rename to osmo-sysmon
37 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
38 * add contrib/jenkins.sh for build verification
39
40 [ Daniel Willmann ]
41 * Remove unused function
42 * Fix compilation issue on my machine, remove unused include
43 * Remove unused last_value handling code
44 * Add zero termination char to received ctrl cmd message
45 * Disconnect properly on errors so we can reconnect
46 * git-version-gen: Don't check for .git directory
47
48 [ Martin Hauke ]
49 * Makefile.am: Fix typo
50
51 [ Max ]
52 * Add git-review config
53 * Update gitignore
54 * Report config file name on error
55 * Update default config
56 * Expand default config
57 * Add OpenVPN status helper example from corresponding ticket
58 * Move shared libs into common LDADD
59 * Drop unused parameter
60 * ctrl: separate config structure
61 * Update Makefile.am
62 * Add ping probe support
63 * jenkins.sh: remove obsolete comments
64 * Install signal handlers before processing config
65 * ctrl: log host/port on errors
66 * Introduce generic host config and related helpers
67 * Add OpenVPN probe
68 * OpenVPN: track interface disconnect
69 * Update config example
70
71 [ Stefan Sperling ]
72 * fix file descriptor leak in osysmon_file_read
73
74 [ Pau Espin Pedrol ]
75 * Add m4 missing files to fix build
76 * Move source code to src subdir
77 * Add cmdline option parsing support
78 * Integrate sleeping/printing loop into osmo main loop
79 * openvpn: Improve logging and status information
80 * openvpn: Set reconnect timeout to a much lower value
81 * openvpn: String returned from openvpn is not null-terminated
82 * openvpn: log status description
83 * openvpn: Fix garbage printed after remote port
84 * openvpn: Remove useless conditional block in parse_state
85 * openvn: Fix missing break in last commit
86 * Add vty option to print output of shell cmd on every poll step
87 * Makefile.am: Add missing bits to have make release working
88 * Add debian packaging content
89 * Bump version: 0.0.1.66-d4c3-dirty 0.1.0
90 * debian: Add missing libmnl-dev dependency
91 * Depend on liboping 1.7.0 instead of 1.9.0
92
93 [ Oliver Smith ]
94 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
95 * contrib/jenkins.sh: run "make maintainer-clean"
96
97 -- Harald Welte <laforge@gnumonks.org> Sun, 14 Jul 2019 08:04:51 +0800
98
Pau Espin Pedrolb1720a32019-03-20 13:14:31 +010099osmo-sysmon (0.1.0) unstable; urgency=medium
100
101 [ Harald Welte ]
102 * initial checkin
103 * simple_ctrl: Add timeout to blocking I/O
104 * simple_ctrl.c: Support an indefinite timeout (using tout_msec=0)
105 * simple_ctrl.c: API for setting timeout + raw CTRL msgb read
106 * osmo-ctrl-client: Implement "monitor" mode
107 * simple-ctrl-client: Add basic help/usage information
108 * simple_ctrl: Abstract out timeval_from_msec() function
109 * simple_ctrl: Non-blocking connect() with timeout
110 * initial implementation of 'osysmon' main program + CTRL client
111 * add osysmon_sysinfo for uptime/ram/load
112 * osysmon_ctrl: Use variable name, not ctrl-client name as val->name
113 * osysmon_main: Show hierarchical/tree structure during printing
114 * value_node: add combined find_or_add() and avoid duplicate names
115 * value_node: Add 'idx' member to handle lookup by ifindex.
116 * Add network link + address monitiring via osysmon_rtnl.c
117 * add osysmon_file.c for reading/monitoring files (like sysfs)
118 * migrate to autoconf
119 * add .gitignore file
120 * rename to osmo-sysmon
121 * simple_ctrl: Check for NULL return of simple_ctrl_xceive
122 * add contrib/jenkins.sh for build verification
123
124 [ Daniel Willmann ]
125 * Remove unused function
126 * Fix compilation issue on my machine, remove unused include
127 * Remove unused last_value handling code
128 * Add zero termination char to received ctrl cmd message
129 * Disconnect properly on errors so we can reconnect
130 * git-version-gen: Don't check for .git directory
131
132 [ Martin Hauke ]
133 * Makefile.am: Fix typo
134
135 [ Max ]
136 * Add git-review config
137 * Update gitignore
138 * Report config file name on error
139 * Update default config
140 * Expand default config
141 * Add OpenVPN status helper example from corresponding ticket
142 * Move shared libs into common LDADD
143 * Drop unused parameter
144 * ctrl: separate config structure
145 * Update Makefile.am
146 * Add ping probe support
147 * jenkins.sh: remove obsolete comments
148 * Install signal handlers before processing config
149 * ctrl: log host/port on errors
150 * Introduce generic host config and related helpers
151 * Add OpenVPN probe
152 * OpenVPN: track interface disconnect
153 * Update config example
154
155 [ Stefan Sperling ]
156 * fix file descriptor leak in osysmon_file_read
157
158 [ Pau Espin Pedrol ]
159 * Add m4 missing files to fix build
160 * Move source code to src subdir
161 * Add cmdline option parsing support
162 * Integrate sleeping/printing loop into osmo main loop
163 * openvpn: Improve logging and status information
164 * openvpn: Set reconnect timeout to a much lower value
165 * openvpn: String returned from openvpn is not null-terminated
166 * openvpn: log status description
167 * openvpn: Fix garbage printed after remote port
168 * openvpn: Remove useless conditional block in parse_state
169 * openvn: Fix missing break in last commit
170 * Add vty option to print output of shell cmd on every poll step
171 * Makefile.am: Add missing bits to have make release working
172 * Add debian packaging content
173
174 [ Oliver Smith ]
175 * osmo-sysmon -h: s/OsmoHLR/osmo-sysmon/
176
177 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 20 Mar 2019 13:14:30 +0100
178
Pau Espin Pedrol814882b2019-03-19 18:10:55 +0100179osmo-sysmon (0.0.1) unstable; urgency=medium
180
181 * Initial release.
182
183 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 19 Mar 2019 18:32:14 +0100