blob: 2e4284a8393f292d8e229e5cc7969c1827308548 [file] [log] [blame]
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7#export DH_VERBOSE=1
Harald Weltee64917a2017-10-29 11:43:14 +01008export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02009
10
11%:
12 dh $@ --with=systemd --with autoreconf --fail-missing
13
14override_dh_strip:
15 dh_strip --dbg-package=osmo-pcu-dbg
16
Harald Welte9dab1ba2017-10-29 11:39:26 +010017override_dh_clean:
18 dh_clean
19 $(RM) tests/package.m4
20 $(RM) test/testsuite
21
22# Print test results in case of a failure
23override_dh_auto_test:
24 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Pau Espin Pedrol516697e2018-09-10 13:28:25 +020025
26override_dh_auto_configure:
Oliver Smitha558ad42019-05-22 13:51:58 +020027 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
28
29# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
30override_dh_compress:
31 dh_compress -X.pdf