Debian: print test results in case of failure + clean-up autotest

Change-Id: Id912a106d42bbd9d2ad89b67d16d52cb2344eb6d
diff --git a/debian/rules b/debian/rules
index 7623f74..cad7dfc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,3 +17,12 @@
 override_dh_autoreconf:
 	echo $(VERSION) > .tarball-version
 	dh_autoreconf
+
+override_dh_clean:
+	dh_clean
+	$(RM) tests/package.m4
+	$(RM) test/testsuite
+
+# Print test results in case of a failure
+override_dh_auto_test:
+	dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)