blob: 712dd756ef0bf0207a55a59858fd23f2c18989fa [file] [log] [blame]
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7#export DH_VERBOSE=1
Harald Weltee64917a2017-10-29 11:43:14 +01008export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02009
10
11%:
12 dh $@ --with=systemd --with autoreconf --fail-missing
13
14override_dh_strip:
15 dh_strip --dbg-package=osmo-pcu-dbg
16
Harald Welte9dab1ba2017-10-29 11:39:26 +010017override_dh_clean:
18 dh_clean
19 $(RM) tests/package.m4
20 $(RM) test/testsuite
21
22# Print test results in case of a failure
23override_dh_auto_test:
24 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Pau Espin Pedrol516697e2018-09-10 13:28:25 +020025
26override_dh_auto_configure:
27 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system