blob: 63ee1c377d0cdbd137501037a6d7860074b91110 [file] [log] [blame]
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7#export DH_VERBOSE=1
Harald Weltee64917a2017-10-29 11:43:14 +01008export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02009
10
11%:
12 dh $@ --with=systemd --with autoreconf --fail-missing
13
14override_dh_strip:
15 dh_strip --dbg-package=osmo-pcu-dbg
16
17override_dh_autoreconf:
18 echo $(VERSION) > .tarball-version
19 dh_autoreconf
Harald Welte9dab1ba2017-10-29 11:39:26 +010020
21override_dh_clean:
22 dh_clean
23 $(RM) tests/package.m4
24 $(RM) test/testsuite
25
26# Print test results in case of a failure
27override_dh_auto_test:
28 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)