blob: 9eff6cd96f613772279cad2fd30cb0907f07359c [file] [log] [blame]
Holger Hans Peter Freyther821f4fa2011-06-01 15:00:01 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4#
5# This file was originally written by Joey Hess and Craig Small.
6# As a special exception, when this file is copied by dh-make into a
7# dh-make output file, you may use that output file without restriction.
8# This special exception was added by Craig Small in version 0.37 of dh-make.
9#
10# Modified to make a template file for a multi-binary package with separated
11# build-arch and build-indep targets by Bill Allombert 2001
12
13# Uncomment this to turn on verbose mode.
14#export DH_VERBOSE=1
15
16# This has to be exported to make some magic below work.
17export DH_OPTIONS
18
Holger Hans Peter Freytherd7999f02012-11-06 23:40:17 +010019# Maybe we require some moreadvanced testing in the future
20PCAP_CFLAGS="-I/usr/include"
21PCAP_LIBS="-lpcap"
Holger Hans Peter Freyther821f4fa2011-06-01 15:00:01 +020022
23%:
24 dh --with autoreconf $@
Holger Hans Peter Freytherd7999f02012-11-06 23:40:17 +010025
26override_dh_auto_configure:
27 dh_auto_configure -- \
28 --with-pcap-config=/bin/false \
29 PCAP_CFLAGS=$(PCAP_CFLAGS) \
30 PCAP_LIBS=$(PCAP_LIBS)
Holger Hans Peter Freytherb08783d2012-11-07 10:11:54 +010031
32override_dh_auto_install:
33 dh_auto_install $@
34 install -d -m 0755 $(CURDIR)/debian/osmo-pcap-client/etc/osmo-pcap/
35 install -m 0644 $(CURDIR)/contrib/osmo-pcap-client.cfg $(CURDIR)/debian/osmo-pcap-client/etc/osmo-pcap
36
37 install -d -m 0755 $(CURDIR)/debian/osmo-pcap-server/etc/osmo-pcap/
38 install -m 0644 $(CURDIR)/contrib/osmo-pcap-server.cfg $(CURDIR)/debian/osmo-pcap-server/etc/osmo-pcap