blob: 26f7525b1b2ee3232707ed2bc61aa6308b1844c3 [file] [log] [blame]
Harald Welte92a88ee2019-01-20 21:46:06 +01001osmo-iuh (0.4.0) unstable; urgency=medium
2
3 [ Bernhard M. Wiedemann ]
4 * asn1tostruct: allow to override build date
5
6 [ Alexander Couzens ]
7 * hnbgw: remove close_cb() to fix a crash when releasing a hnbgw
8
9 [ Harald Welte ]
10 * debian/rules: Don't overwrite .tarball-version
11 * hnbgw_tx_hnb_register_rej(): Missing return statement
12
13 [ Neels Hofmeyr ]
14 * fix decoding of incoming X.213 NSAP addr
15 * hnbgw: vty: add SCCP related vty commands
16 * fix transport layer addr again, for nano3g
17
18 [ Pau Espin Pedrol ]
19 * debian: package osmo-hnbgw.service
20 * Install systemd services with autotools
21 * Install sample cfg file to /etc/osmocom
22
23 [ Stefan Sperling ]
24 * add a VTY command which shows a specific HNB
25
26 [ Oliver Smith ]
27 * Fix DISTCHECK_CONFIGURE_FLAGS override
28 * contrib: fix makedistcheck with disabled systemd
29
30 -- Harald Welte <laforge@gnumonks.org> Sun, 20 Jan 2019 21:46:05 +0100
31
Pau Espin Pedrolba941e52018-05-03 18:29:14 +020032osmo-iuh (0.3.0) unstable; urgency=medium
33
34 [ Neels Hofmeyr ]
35 * jenkins: use osmo-clean-workspace.sh before and after build
36 * vty: skip installing cmds now always installed by default
37 * src/Makefile.am: drop unused COMMON_LDADD
38 * add --enable-sanitize config option
39 * osmo-hnbgw: drop erratic log line on remote STP address
40 * api doc: clarify byte order in ranap_new_msg_rab_assign_*
41 * tests: sanitize: fix mem leaks, clean after tests
42 * ranap_msg_factory: sanitize: memcpy instead of unaligned int copy
43 * test_common: fix compiler warning: include ranap_common.h
44 * osmo-hnbgw: auto-config local and remote PCs if omitted
45 * cosmetic: osmo-hnbgw: log remote SCCP addresses on startup
46 * osmo-hnbgw: don't configure specific local IP address for STP connection
47 * iu client: store multiple LAC,RAC per RNC = fix paging for multiple RNC
48 * hnbgw: use proper VTY port number defined in libosmocore (4261)
49 * fix 3 compiler warnings in ranap_common.c
50 * hnbgw: use proper talloc ctx for vty telnet init
51 * hnbgw: hnb info: record MCC, MNC, show on 'show hnb'
52 * hnbap,rua,ranap decode: fix segfault on decode error
53 * vty: tweak / improve HNB and cnlink introspection
54 * osmo-hnbgw: vty: revamp output of context maps on 'show hnb'
55 * compiler warning: asn1tostruct.py: return 0 at end of *_free_*()
56 * segfault: context_map gc: use llist_for_each_entry_safe()
57 * rua: discard context maps on id-Disconnect
58 * rua_to_scu(): don't create a context map for UNITDATA
59 * cosmetic: context_map_tmr_cb(): fix comment
60 * osmo-hnbgw config: add 'rnc-id' config item
61 * osmo-hnbgw: startup: log the RNC-Id that is going to be used
62 * comments: hnbgw_rua.c: remove obsolete fixmes for asn1 free
63 * vty typo: 'show hnb': SCTP stream, not SCCP stream
64 * hnbgw_rua.c: log: fix integer format for cN_DomainIndicator
65 * hnbgw_rua: fix dereference of unset pointer
66 * hnbgw_cn: rx ranap: set rc in all cases
67 * hnbgw_hnbap: fix missing return in rx [un]successful outcome
68 * cosmetic: hnbgw: hnbap: log rx of unsuccessful outcome
69 * hnbap: log errors on decoding/encoding HNB-REGISTER msgs
70 * hnb-test: log accurate three-digit MNC with leading zeros
71 * configure: add --enable-werror
72 * cosmetic: use osmo_plmn_id instead of mcc,mnc
73
74 [ Harald Welte ]
75 * osmo-hnbgw: Avoid useless linking to libosmogsm and libsctp
76 * Link libosmo-ranap against libosmovty
77 * Add "-Wall" to the compile rules of the non-asn1c-generated source code
78 * hnbgw.c: Remove dead code creating libsctp linker dependency
79 * sccp_sap_up(): Fix never-hit "default" case in switch
80 * Fix various compiler warnings in hnb-gw code
81 * hnbgw_vty.c: cosmetic: Fix non-tab-indented code
82 * hnbgw_vty.c: Fix "-Werror=format-security" failure in vty_out()
83
84 [ Philipp Maier ]
85 * iu: iu_helpers: add functions to decode ip/port from rab-ass
86 * ranap_msg_factory: check IE encoder return codes
87 * ranap_msg_factory: remove unusued variable
88
89 [ Max ]
90 * Use proper package version
91 * Add control interface
92 * Expand ctrl interface
93 * Enable sanitize for CI tests
94
95 [ Pau Espin Pedrol ]
96 * iu_client.c: Remove unusued variable
97 * configure.ac: Enable -Wall flag
98 * contrib: jenkins.sh: Disable doxygen in libosmocore build
99 * debian/changelog: set prev releases to unstable
100
101 [ Stefan Sperling ]
102 * ensure unique CellIDs in HNB-GW
103
104 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:29:13 +0200
105
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200106osmo-iuh (0.2.0) unstable; urgency=low
Harald Weltecc1afdf2017-10-27 22:20:16 +0200107
108 * Upstream 0.2.0 release
109
110 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 22:19:00 +0000
111
Pau Espin Pedrol2b88cc42018-05-03 18:28:10 +0200112osmo-iuh (0.1.0) unstable; urgency=low
Alexander Couzense485cdd2017-08-06 21:52:02 +0000113
114 * Initial release.
115
116 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 04:13:19 +0000