blob: c11700c6f05a17223147377896e292530717db8b [file] [log] [blame]
Harald Weltee9168092010-08-24 15:23:33 +02001#!/usr/bin/make -f
Harald Weltee9168092010-08-24 15:23:33 +02002
3# Uncomment this to turn on verbose mode.
4#export DH_VERBOSE=1
5
Harald Welte367baa32017-08-13 09:41:33 +02006DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
7DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
8VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
9
Harald Weltee9168092010-08-24 15:23:33 +020010# This has to be exported to make some magic below work.
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010011#export DH_OPTIONS
Max77168602016-12-21 17:57:40 +010012export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Harald Weltee9168092010-08-24 15:23:33 +020013
Harald Weltee9168092010-08-24 15:23:33 +020014%:
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010015 dh $@ --with autoreconf
Holger Hans Peter Freytherf97f58d2014-09-23 16:52:19 +020016
17override_dh_strip:
Harald Welte6c10aa02017-10-28 18:56:16 +020018 dh_strip -posmo-ggsn --dbg-package=osmo-ggsn-dbg
Pau Espin Pedrole71e0f22020-01-02 20:39:39 +010019 dh_strip -plibgtp6 --dbg-package=libgtp-dbg
Pau Espin Pedrol381b7232018-09-10 12:19:45 +020020
21override_dh_auto_configure:
Oliver Smith77100802021-02-19 17:34:05 +010022 dh_auto_configure -- \
23 --enable-gtp-linux \
24 --with-systemdsystemunitdir=/lib/systemd/system \
25 --enable-manuals
Oliver Smith154f93d2019-05-21 15:26:06 +020026
27# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
28override_dh_compress:
29 dh_compress -X.pdf