blob: 423827e37c5bef591351e4918adb8a214be1f79c [file] [log] [blame]
Pau Espin Pedrol20f90672023-09-12 17:02:12 +02001osmo-gbproxy (1:0.4.1) unstable; urgency=medium
2
3 [ Vadim Yanitskiy ]
4 * tests: do not depend on $(BUILT_SOURCES), but on osmo-gbproxy
5
6 [ Oliver Smith ]
7 * debian: set compat level to 10
8 * systemd: depend on networking-online.target
9 * gbprox_rx_ptp_from_bss: fix dangling pointer
10
11 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 12 Sep 2023 17:02:12 +0200
12
Pau Espin Pedrolddbe35d2023-02-07 17:37:14 +010013osmo-gbproxy (1:0.4.0) unstable; urgency=medium
14
15 [ Vadim Yanitskiy ]
16 * configure.ac: do not require unused dlsym/dlopen
17
18 [ Max ]
19 * Set working directory in systemd service file
20 * Drop forward declaration of gbprox_relay2peer()
21 * ctrl: take both address and port from vty config
22
23 [ Alexander Couzens ]
24 * implement LL DISCARD with second BVCI
25
26 [ Daniel Willmann ]
27 * gbproxy_vty: Add commands to list Cell/BVC of an NSE
28 * Improve log levels
29 * Fix obsolete documentation of function
30
31 [ Harald Welte ]
32 * manual: Use combined/merged gb-ns2 chapter
33
34 [ arehbein ]
35 * osmo-gbproxy: Transition to use of 'telnet_init_default'
36
37 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 17:37:13 +0100
38
Pau Espin Pedrol6e1b3002022-06-29 11:54:09 +020039osmo-gbproxy (1:0.3.0) unstable; urgency=medium
40
41 [ Daniel Willmann ]
42 * gbproxy: Fix error return value
43 * gbproxy: Also try to route STATUS messages with truncated PDU in error
44 * gbproxy: Fix crash when FLUSH_LL_ACK does not contain a BVCI IE
45 * gbproxy_peer: Free all related BVCs if the cell is freed
46 * gbproxy: Only route to an SGSN if the BVC is not blocked
47 * gbproxy_peer: Use designated initializers for bvc_ctr_description
48 * gbproxy_peer: Add rate counters when forwarding packets fail
49 * gbproxy: Ensure PtP-BVCs are reset when we reset the SGSN SIG-BVC
50
51 [ Pau Espin Pedrol ]
52 * Drop unneeded ax_check_compile_flag.m4
53
54 [ Alexander Couzens ]
55 * docs: usermanual: reorder gb/ns2 chapter to keep all ns2 part together
56 * docs: usermanual: add new chapter gb-ns2-maintenance
57
58 [ Harald Welte ]
59 * update git URLs (git -> https; gitea)
60
61 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 11:54:09 +0200
62
Pau Espin Pedrold23ebf52021-11-16 18:03:02 +010063osmo-gbproxy (1:0.2.0) unstable; urgency=medium
64
65 [ Pau Espin Pedrol ]
66 * Support setting rt-prio and cpu-affinity mask through VTY
67 * Avoid sending tx_status upon rx of RIM messages
68 * Use new stat item/ctr getter APIs
69
70 [ Daniel Willmann ]
71 * gbproxy_main: Fix naming bsc_hack/nsip_proxy -> (osmo-)gbproxy
72 * manual: Update manuals, include sgsn pooling and NS variants
73 * manuals: Regenerate counters/VTY through docker
74 * Remove some outdated TODO/comments
75 * gb_proxy.h: Use pragma once instead of ifndef
76 * Update the max_sdu_len from NS
77 * Handle GPRS_NS2_AFF_CAUSE_FAILURE
78 * Remove osmo-sgsn relics
79 * gbproxy: Don't free NSE/BVC0 if SGSN NSE goes down
80 * gbproxy_main: Add ctrl vty commands
81 * gb_proxy: Ensure cell info is up to date when receiving PTP-BVC reset
82 * gbproxy_main: Process options after all initialization is done
83 * examples/manuals: Improve/update ns-related documentation
84 * Don't route messages to an SGSN if it is down
85 * manual: Update counters, add proper chapter for counters
86 * gbproxy_vty: Remove redundant command "show gbproxy links"
87 * manual: Add section describing show gbproxy command usage
88 * manual: Add chapter describing osmo counters in general
89 * gbproxy: Add usage flag to the imsi_cache
90 * gbproxy: Forward MS_REGISTR_ENQ/_RESP correctly
91 * gbproxy_peer: Set rate_ctr name for gbproxy_peer stats
92 * gbproxy_peer: Free a cell as soon as no BSS BVC uses it
93 * gbproxy_ctrl: Fix crash in nsvc-state ctrl command
94 * gbproxy_ctrl: Ignore SIG-BVCI in ctrl commands
95 * gbproxy: Remove SGSN-side BVC after sending BVC-BLOCK
96 * gbproxy: Avoid sending STATUS on unexpected BLOCK_ACK
97 * gbproxy: Fix stats when no BVC could be found
98 * gbproxy: Use designated initializers for global_ctr_description
99 * gbproxy: Improve log message when no bvc is found (include bvci)
100 * gbproxy: Route BSSGP STATUS with PDU_IN_ERROR containing a TLLI
101 * gpproxy: Route BSSGP STATUS with PDU_IN_ERROR containing a TMSI
102 * gbproxy: Add comment, improve log message in gbproxy_tlli_from_status_pdu
103 * gbproxy: Improve STATUS handling from SGSN
104 * gbproxy: Route DL STATUS with BVCI on SIG-BVC
105 * gbproxy: Add comment, remove unused param in gbproxy_tlli_from_status_pdu
106 * gbproxy: Route STATUS in PtP-BVC by TLLI/TMSI as well
107 * gbproxy: Move BSSGP decoding into its own function and use it
108 * gbproxy: Increase correct counter when BSSGP decode from SGSN fails
109 * gbproxy: Only use one struct tlv_parsed for gbproxy_decode_bssgp
110 * gbproxy: Remove duplicate struct gprs_ra_id handling
111
112 [ Harald Welte ]
113 * vty: Print CellId along with RA-ID
114
115 [ Oliver Smith ]
116 * doc: include gb-ns2.adoc, not gb-variants.adoc
117 * gitignore: add gbproxy_vty_reference.xml
118 * examples/osmo-gbproxy.cfg: fix osmo-sgsn conflict
119 * debian/control: remove dh-systemd build-depend
120 * Revert "Turn some compiler warnings into errors"
121
122 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 18:03:02 +0100
123
Pau Espin Pedrolf89d4f82021-02-24 16:54:13 +0100124osmo-gbproxy (1:0.1.0) unstable; urgency=medium
125
126 [ Philipp Maier ]
127 * gb_proxy_ctrl: use mcc-mnc-lac-rac notation instead mcc,mnc,lac,rac
128 * gb_proxy: simplify raid data storage
129 * gb_proxy_peer: Remove unused function gbproxy_cell_by_bvci_or_new
130 * gb_proxy_peer: Require ra_id and cid in gbproxy_cell_alloc
131 * gb_proxy: extend TLV parser
132 * gb_proxy: add support for relaying BSSGP RIM messages
133 * gb_proxy: fix wrong usage of bssgp_rim_ri_name()
134
135 [ Daniel Willmann ]
136 * gb_proxy_peer: Add Function to get gbproxy cell by cell id
137 * gbproxy_vty: Fix NRI VTY help MSC->SGSN
138 * gbproxy_vty: Fix NRI overlap behaviour to match osmo-bsc
139 * Various comment/whitespace changes
140 * Remove trailing whitespace
141 * gbproxy: Use bssgp2_nsi_tx_ptp in gbprox_relay2nse
142 * Remove unused log categories
143 * Move vty node into gbproxy_vty.c
144 * Add SDU length for an NSE (== BSSGP PDU size)
145 * gbproxy: Use bssgp2_enc_status when sending STATUS
146
147 [ Pau Espin Pedrol ]
148 * Drop c-ares references
149 * debian/copyright: Drop osmo-sgsn.git leftover files from list
150 * gitignore: Ignore autofoo files *~
151
152 [ Oliver Smith ]
153 * d/changelog: set epoch=1
154
155 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 24 Feb 2021 16:54:13 +0100
156
Oliver Smitha8fa5672021-02-15 12:07:24 +0100157osmo-gbproxy (1:0.0.1) unstable; urgency=medium
Oliver Smith33855062021-02-05 11:42:48 +0100158
159 [ Harald Welte ]
160 * Further clean-up in osmo-sgsn -> osmo-gbproxy migration
161 * Update README to cover osmo-gbproxy and not osmo-sgsn
162
163 [ Oliver Smith ]
164 * contrib/jenkins.sh: adjust to osmo-gbproxy split
165 * debian: fix installing pdfs for -doc package
166 * contrib/osmo-gbproxy.spec.in: fix config paths
167
168 -- Oliver Smith <osmith@sysmocom.de> Fri, 05 Feb 2021 11:42:48 +0100
169
Oliver Smitha8fa5672021-02-15 12:07:24 +0100170osmo-gbproxy (1:0.0.0) unstable; urgency=medium
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100171
Oliver Smith29532c22021-01-29 11:13:00 +0100172 [ Neels Hofmeyr ]
173 * manual: explain IuPS, add SCCP/M3UA section from common chapters
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100174
Oliver Smith29532c22021-01-29 11:13:00 +0100175 [ Eric ]
176 * tests: dlopen does not imply availability of dlsym..
177 * configure.ac: fix libtool issue with clang and sanitizer
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100178
179 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100180 * gtphub_test: Fix compilation with gcc-10
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100181
182 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100183 * contrib: import RPM spec
184 * contrib: integrate RPM spec
185 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100186
Oliver Smith29532c22021-01-29 11:13:00 +0100187 [ Neels Hofmeyr ]
188 * gbproxy_test.c: fix mobile identity test data
189 * use new osmo_mobile_identity API everywhere
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200190
191 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100192 * *.spec.in: Use %config(noreplace) to retain current config file
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200193
194 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100195 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
196
197 [ Vadim Yanitskiy ]
198 * debian/control: change maintainer to the Osmocom team / mailing list
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200199
200 [ Pau Espin Pedrol ]
Oliver Smith29532c22021-01-29 11:13:00 +0100201 * configure.ac: Fix trailing whitespace
202 * doc: Update VTY reference xml file
203 * Support setting rt-prio and cpu-affinity mask through VTY
204
205 [ Daniel Willmann ]
206 * gbproxy-usermanual: Explain BSSGP/BVC handling
207
208 [ Alexander Couzens ]
209 * gtphub_test: fix compilation error on gcc 10.2.0
210
211 [ Pau Espin Pedrol ]
212 * contrib/jenkins: Enable parallel make in make distcheck
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200213
214 [ Keith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100215 * VTY: Add gtp state-dir command
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200216
Oliver Smith29532c22021-01-29 11:13:00 +0100217 [ Alexander Couzens ]
218 * Port gbproxy to NS2
219
220 [ Daniel Willmann ]
221 * gbproxy: Whitespace fixes
222 * gbproxy: Add todo for BVC RESET logic
223 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
224 * Let libosmocore handle VTY parent node tracking
225 * osmo-gbproxy: Free msgb in ns2 prim callback
226 * configure.ac: Require python3 for ext_tests
227 * osmo-gbproxy: Implement nsvc-state ctrl command
228
229 [ Harald Welte ]
230 * gbproxy: Properly implement paging to LAC/RAC
231 * gbproxy: Implement paging to entire BSS area
232
233 [ Pau Espin Pedrol ]
234 * gbproxy: generate coredump and exit upon SIGABRT received
235
236 [ Harald Welte ]
237 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
238 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
239
240 [ Daniel Willmann ]
241 * gbproxy: Remove test testing NSVCI change
242 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
243 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
244 * gbproxy: Only send paging to each matching NSE once
245 * gbproxy: Separate function to move gbproxy_peer to different nse
246
247 [ Harald Welte ]
248 * gb_proxy: More precise + readable log messages
249
250 [ Daniel Willmann ]
251 * gbproxy: Add logging macros for NSE and BVC
252 * gbproxy: Use LOG macros for NSE/BVC
253 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
254 * gbproxy: Add todos encountered while going through the code
255
256 [ Harald Welte ]
257 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
258 * gbproxy: Move BSS-side BVC-RESET processing to its own function
259 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
260 * gbproxy: Cosmetics: use longer lines
261
262 [ Daniel Willmann ]
263 * gbproxy: Add BVC log filters
264 * gbproxy: Add newline to log message
265 * gbproxy: Allow gbproxy_nse_free(NULL)
266 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
267
268 [ Harald Welte ]
269 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
270 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
271 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
272 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
273 * gbproxy: convert bss_nses from llist_head to hashtable
274 * gbproxy: convert nse->bvcs from llist_head to hashtable
275 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
276 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
277 * gbproxy: Delete gbproxy_test
278 * gb_proxy: Introduce more validation / constraint checks
279 * gbproxy: use gbprox_relay2peer() whenever possible
280 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
281 * gbproxy: Log FSM timeouts
282 * migrate to DLBSSGP as log sub-system for BSSGP
283 * gbproxy major rewrite for SGSN pool support
284 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
285 * gbproxy: Introduce new DOBJ log category; log object allocation/release
286 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
287 * gbproxy: Implement handling of BVC Flow Control
288
289 [ Daniel Willmann ]
290 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
291
292 [ Harald Welte ]
293 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
294 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
295 * gbproxy: Fix segfault when receiving PAGING for unknown destination
296 * gbproxy: Add FSM related VTY commands
297 * gbproxy: Implement scaling of BVC flow control in SGSN pool
298 * gbproxy: Improve VTY state introspection
299 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
300
301 [ Daniel Willmann ]
302 * osmo-gbproxy: Initialize all hash_maps
303 * gbproxy: Fix confusing log message in gbprox_relay2nse
304
305 [ Harald Welte ]
306 * gbproxy: Add "show gbproxy cell ..." VTY command
307
308 [ Daniel Willmann ]
309 * gbproxy: Add SGSN NRI configuration
310 * gbproxy: Add SGSN pooling support
311 * gbproxy: Add comments to sgsn functions
312
313 [ Harald Welte ]
314 * gbproxy: Fix build on Deiban 8
315
316 [ Alexander Couzens ]
317 * sgsn: Use the new NS2 api
318 * gbproxy: use ns2 vty2
319
320 [ Daniel Willmann ]
321 * gbproxy: Add config option to name an SGSN
322 * gbproxy: Add VTY command to override the node selection function
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200323
324 [ Vadim Yanitskiy ]
Oliver Smith29532c22021-01-29 11:13:00 +0100325 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
326 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200327
328 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100329 * Fix gbproxy_sgsn_by_tlli wraparound
Harald Weltee250eaa2019-01-23 18:32:41 +0100330
331 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100332 * configure.ac: define a c standard instead of using the compilers default
Harald Weltee250eaa2019-01-23 18:32:41 +0100333
334 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100335 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
336 * gbproxy: Increase TLLI cache timeout to 10s
Harald Weltee250eaa2019-01-23 18:32:41 +0100337
338 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100339 * contrib/jenkins: don't build osmo-gsm-manuals
Harald Weltee250eaa2019-01-23 18:32:41 +0100340
Oliver Smith29532c22021-01-29 11:13:00 +0100341 [ Daniel Willmann ]
342 * gbproxy: Implement IMSI cache
343 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
344 * gbproxy: Use C-style comments
345 * gbproxy: Move helper function to a more logical place
346 * gbproxy: Remove unused variable assignment
347 * gbproxy: Fix VTY cmd name
348 * gbproxy: Define and use help string for gbproxy
349 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200350
351 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100352 * gb_proxy: Don't use orphan log subsystem DPCU
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200353
Oliver Smith29532c22021-01-29 11:13:00 +0100354 [ Daniel Willmann ]
355 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
356 * gbproxy: Print the correct message type for dummy paging/paging reject
357 * gbproxy: Improve log messages in gbproxy_select_sgsn
358 * gbproxy: Fix radio status routing by TMSI
Harald Welte5641e9d2017-10-28 19:07:48 +0200359
360 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100361 * follow libosmocore/gprs_ns2 API changes of GPRS enums
Harald Welte5641e9d2017-10-28 19:07:48 +0200362
363 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100364 * gbproxy: Avoid depending on any of the SGSN code
Harald Welte5641e9d2017-10-28 19:07:48 +0200365
Oliver Smith29532c22021-01-29 11:13:00 +0100366 [ Daniel Willmann ]
367 * manual/gbproxy: Update overview chapter
368 * Rename OsmoGbPROXY -> *Proxy
369 * manuals/gbproxy: Update configuration chapter
370 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
371 * manuals/gbproxy: MSC -> SGSN for pooling chapter
372 * manuals/gbproxy: Move pooling to separate chapter
Harald Welte5641e9d2017-10-28 19:07:48 +0200373
Oliver Smith29532c22021-01-29 11:13:00 +0100374 [ Alexander Couzens ]
375 * gbproxy: follow gprs_ns2 API vty changes
376 * sgsn: migrate to the new gprs_ns2_vty configuration
377 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200378
Oliver Smith29532c22021-01-29 11:13:00 +0100379 [ Oliver Smith ]
380 * === Split osmo-gbproxy from osmo-sgsn ===
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200381
Oliver Smith29532c22021-01-29 11:13:00 +0100382 -- Oliver Smith <osmith@sysmocom.de> Fri, 29 Jan 2021 12:57:28 +0100