blob: f4cea25d01d007699d9867ab4f66c831b92bc161 [file] [log] [blame]
Pau Espin Pedrolddbe35d2023-02-07 17:37:14 +01001osmo-gbproxy (1:0.4.0) unstable; urgency=medium
2
3 [ Vadim Yanitskiy ]
4 * configure.ac: do not require unused dlsym/dlopen
5
6 [ Max ]
7 * Set working directory in systemd service file
8 * Drop forward declaration of gbprox_relay2peer()
9 * ctrl: take both address and port from vty config
10
11 [ Alexander Couzens ]
12 * implement LL DISCARD with second BVCI
13
14 [ Daniel Willmann ]
15 * gbproxy_vty: Add commands to list Cell/BVC of an NSE
16 * Improve log levels
17 * Fix obsolete documentation of function
18
19 [ Harald Welte ]
20 * manual: Use combined/merged gb-ns2 chapter
21
22 [ arehbein ]
23 * osmo-gbproxy: Transition to use of 'telnet_init_default'
24
25 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 17:37:13 +0100
26
Pau Espin Pedrol6e1b3002022-06-29 11:54:09 +020027osmo-gbproxy (1:0.3.0) unstable; urgency=medium
28
29 [ Daniel Willmann ]
30 * gbproxy: Fix error return value
31 * gbproxy: Also try to route STATUS messages with truncated PDU in error
32 * gbproxy: Fix crash when FLUSH_LL_ACK does not contain a BVCI IE
33 * gbproxy_peer: Free all related BVCs if the cell is freed
34 * gbproxy: Only route to an SGSN if the BVC is not blocked
35 * gbproxy_peer: Use designated initializers for bvc_ctr_description
36 * gbproxy_peer: Add rate counters when forwarding packets fail
37 * gbproxy: Ensure PtP-BVCs are reset when we reset the SGSN SIG-BVC
38
39 [ Pau Espin Pedrol ]
40 * Drop unneeded ax_check_compile_flag.m4
41
42 [ Alexander Couzens ]
43 * docs: usermanual: reorder gb/ns2 chapter to keep all ns2 part together
44 * docs: usermanual: add new chapter gb-ns2-maintenance
45
46 [ Harald Welte ]
47 * update git URLs (git -> https; gitea)
48
49 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 29 Jun 2022 11:54:09 +0200
50
Pau Espin Pedrold23ebf52021-11-16 18:03:02 +010051osmo-gbproxy (1:0.2.0) unstable; urgency=medium
52
53 [ Pau Espin Pedrol ]
54 * Support setting rt-prio and cpu-affinity mask through VTY
55 * Avoid sending tx_status upon rx of RIM messages
56 * Use new stat item/ctr getter APIs
57
58 [ Daniel Willmann ]
59 * gbproxy_main: Fix naming bsc_hack/nsip_proxy -> (osmo-)gbproxy
60 * manual: Update manuals, include sgsn pooling and NS variants
61 * manuals: Regenerate counters/VTY through docker
62 * Remove some outdated TODO/comments
63 * gb_proxy.h: Use pragma once instead of ifndef
64 * Update the max_sdu_len from NS
65 * Handle GPRS_NS2_AFF_CAUSE_FAILURE
66 * Remove osmo-sgsn relics
67 * gbproxy: Don't free NSE/BVC0 if SGSN NSE goes down
68 * gbproxy_main: Add ctrl vty commands
69 * gb_proxy: Ensure cell info is up to date when receiving PTP-BVC reset
70 * gbproxy_main: Process options after all initialization is done
71 * examples/manuals: Improve/update ns-related documentation
72 * Don't route messages to an SGSN if it is down
73 * manual: Update counters, add proper chapter for counters
74 * gbproxy_vty: Remove redundant command "show gbproxy links"
75 * manual: Add section describing show gbproxy command usage
76 * manual: Add chapter describing osmo counters in general
77 * gbproxy: Add usage flag to the imsi_cache
78 * gbproxy: Forward MS_REGISTR_ENQ/_RESP correctly
79 * gbproxy_peer: Set rate_ctr name for gbproxy_peer stats
80 * gbproxy_peer: Free a cell as soon as no BSS BVC uses it
81 * gbproxy_ctrl: Fix crash in nsvc-state ctrl command
82 * gbproxy_ctrl: Ignore SIG-BVCI in ctrl commands
83 * gbproxy: Remove SGSN-side BVC after sending BVC-BLOCK
84 * gbproxy: Avoid sending STATUS on unexpected BLOCK_ACK
85 * gbproxy: Fix stats when no BVC could be found
86 * gbproxy: Use designated initializers for global_ctr_description
87 * gbproxy: Improve log message when no bvc is found (include bvci)
88 * gbproxy: Route BSSGP STATUS with PDU_IN_ERROR containing a TLLI
89 * gpproxy: Route BSSGP STATUS with PDU_IN_ERROR containing a TMSI
90 * gbproxy: Add comment, improve log message in gbproxy_tlli_from_status_pdu
91 * gbproxy: Improve STATUS handling from SGSN
92 * gbproxy: Route DL STATUS with BVCI on SIG-BVC
93 * gbproxy: Add comment, remove unused param in gbproxy_tlli_from_status_pdu
94 * gbproxy: Route STATUS in PtP-BVC by TLLI/TMSI as well
95 * gbproxy: Move BSSGP decoding into its own function and use it
96 * gbproxy: Increase correct counter when BSSGP decode from SGSN fails
97 * gbproxy: Only use one struct tlv_parsed for gbproxy_decode_bssgp
98 * gbproxy: Remove duplicate struct gprs_ra_id handling
99
100 [ Harald Welte ]
101 * vty: Print CellId along with RA-ID
102
103 [ Oliver Smith ]
104 * doc: include gb-ns2.adoc, not gb-variants.adoc
105 * gitignore: add gbproxy_vty_reference.xml
106 * examples/osmo-gbproxy.cfg: fix osmo-sgsn conflict
107 * debian/control: remove dh-systemd build-depend
108 * Revert "Turn some compiler warnings into errors"
109
110 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 18:03:02 +0100
111
Pau Espin Pedrolf89d4f82021-02-24 16:54:13 +0100112osmo-gbproxy (1:0.1.0) unstable; urgency=medium
113
114 [ Philipp Maier ]
115 * gb_proxy_ctrl: use mcc-mnc-lac-rac notation instead mcc,mnc,lac,rac
116 * gb_proxy: simplify raid data storage
117 * gb_proxy_peer: Remove unused function gbproxy_cell_by_bvci_or_new
118 * gb_proxy_peer: Require ra_id and cid in gbproxy_cell_alloc
119 * gb_proxy: extend TLV parser
120 * gb_proxy: add support for relaying BSSGP RIM messages
121 * gb_proxy: fix wrong usage of bssgp_rim_ri_name()
122
123 [ Daniel Willmann ]
124 * gb_proxy_peer: Add Function to get gbproxy cell by cell id
125 * gbproxy_vty: Fix NRI VTY help MSC->SGSN
126 * gbproxy_vty: Fix NRI overlap behaviour to match osmo-bsc
127 * Various comment/whitespace changes
128 * Remove trailing whitespace
129 * gbproxy: Use bssgp2_nsi_tx_ptp in gbprox_relay2nse
130 * Remove unused log categories
131 * Move vty node into gbproxy_vty.c
132 * Add SDU length for an NSE (== BSSGP PDU size)
133 * gbproxy: Use bssgp2_enc_status when sending STATUS
134
135 [ Pau Espin Pedrol ]
136 * Drop c-ares references
137 * debian/copyright: Drop osmo-sgsn.git leftover files from list
138 * gitignore: Ignore autofoo files *~
139
140 [ Oliver Smith ]
141 * d/changelog: set epoch=1
142
143 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 24 Feb 2021 16:54:13 +0100
144
Oliver Smitha8fa5672021-02-15 12:07:24 +0100145osmo-gbproxy (1:0.0.1) unstable; urgency=medium
Oliver Smith33855062021-02-05 11:42:48 +0100146
147 [ Harald Welte ]
148 * Further clean-up in osmo-sgsn -> osmo-gbproxy migration
149 * Update README to cover osmo-gbproxy and not osmo-sgsn
150
151 [ Oliver Smith ]
152 * contrib/jenkins.sh: adjust to osmo-gbproxy split
153 * debian: fix installing pdfs for -doc package
154 * contrib/osmo-gbproxy.spec.in: fix config paths
155
156 -- Oliver Smith <osmith@sysmocom.de> Fri, 05 Feb 2021 11:42:48 +0100
157
Oliver Smitha8fa5672021-02-15 12:07:24 +0100158osmo-gbproxy (1:0.0.0) unstable; urgency=medium
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100159
Oliver Smith29532c22021-01-29 11:13:00 +0100160 [ Neels Hofmeyr ]
161 * manual: explain IuPS, add SCCP/M3UA section from common chapters
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100162
Oliver Smith29532c22021-01-29 11:13:00 +0100163 [ Eric ]
164 * tests: dlopen does not imply availability of dlsym..
165 * configure.ac: fix libtool issue with clang and sanitizer
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100166
167 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100168 * gtphub_test: Fix compilation with gcc-10
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100169
170 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100171 * contrib: import RPM spec
172 * contrib: integrate RPM spec
173 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +0100174
Oliver Smith29532c22021-01-29 11:13:00 +0100175 [ Neels Hofmeyr ]
176 * gbproxy_test.c: fix mobile identity test data
177 * use new osmo_mobile_identity API everywhere
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200178
179 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100180 * *.spec.in: Use %config(noreplace) to retain current config file
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200181
182 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100183 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
184
185 [ Vadim Yanitskiy ]
186 * debian/control: change maintainer to the Osmocom team / mailing list
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200187
188 [ Pau Espin Pedrol ]
Oliver Smith29532c22021-01-29 11:13:00 +0100189 * configure.ac: Fix trailing whitespace
190 * doc: Update VTY reference xml file
191 * Support setting rt-prio and cpu-affinity mask through VTY
192
193 [ Daniel Willmann ]
194 * gbproxy-usermanual: Explain BSSGP/BVC handling
195
196 [ Alexander Couzens ]
197 * gtphub_test: fix compilation error on gcc 10.2.0
198
199 [ Pau Espin Pedrol ]
200 * contrib/jenkins: Enable parallel make in make distcheck
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200201
202 [ Keith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100203 * VTY: Add gtp state-dir command
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200204
Oliver Smith29532c22021-01-29 11:13:00 +0100205 [ Alexander Couzens ]
206 * Port gbproxy to NS2
207
208 [ Daniel Willmann ]
209 * gbproxy: Whitespace fixes
210 * gbproxy: Add todo for BVC RESET logic
211 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
212 * Let libosmocore handle VTY parent node tracking
213 * osmo-gbproxy: Free msgb in ns2 prim callback
214 * configure.ac: Require python3 for ext_tests
215 * osmo-gbproxy: Implement nsvc-state ctrl command
216
217 [ Harald Welte ]
218 * gbproxy: Properly implement paging to LAC/RAC
219 * gbproxy: Implement paging to entire BSS area
220
221 [ Pau Espin Pedrol ]
222 * gbproxy: generate coredump and exit upon SIGABRT received
223
224 [ Harald Welte ]
225 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
226 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
227
228 [ Daniel Willmann ]
229 * gbproxy: Remove test testing NSVCI change
230 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
231 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
232 * gbproxy: Only send paging to each matching NSE once
233 * gbproxy: Separate function to move gbproxy_peer to different nse
234
235 [ Harald Welte ]
236 * gb_proxy: More precise + readable log messages
237
238 [ Daniel Willmann ]
239 * gbproxy: Add logging macros for NSE and BVC
240 * gbproxy: Use LOG macros for NSE/BVC
241 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
242 * gbproxy: Add todos encountered while going through the code
243
244 [ Harald Welte ]
245 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
246 * gbproxy: Move BSS-side BVC-RESET processing to its own function
247 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
248 * gbproxy: Cosmetics: use longer lines
249
250 [ Daniel Willmann ]
251 * gbproxy: Add BVC log filters
252 * gbproxy: Add newline to log message
253 * gbproxy: Allow gbproxy_nse_free(NULL)
254 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
255
256 [ Harald Welte ]
257 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
258 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
259 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
260 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
261 * gbproxy: convert bss_nses from llist_head to hashtable
262 * gbproxy: convert nse->bvcs from llist_head to hashtable
263 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
264 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
265 * gbproxy: Delete gbproxy_test
266 * gb_proxy: Introduce more validation / constraint checks
267 * gbproxy: use gbprox_relay2peer() whenever possible
268 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
269 * gbproxy: Log FSM timeouts
270 * migrate to DLBSSGP as log sub-system for BSSGP
271 * gbproxy major rewrite for SGSN pool support
272 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
273 * gbproxy: Introduce new DOBJ log category; log object allocation/release
274 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
275 * gbproxy: Implement handling of BVC Flow Control
276
277 [ Daniel Willmann ]
278 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
279
280 [ Harald Welte ]
281 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
282 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
283 * gbproxy: Fix segfault when receiving PAGING for unknown destination
284 * gbproxy: Add FSM related VTY commands
285 * gbproxy: Implement scaling of BVC flow control in SGSN pool
286 * gbproxy: Improve VTY state introspection
287 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
288
289 [ Daniel Willmann ]
290 * osmo-gbproxy: Initialize all hash_maps
291 * gbproxy: Fix confusing log message in gbprox_relay2nse
292
293 [ Harald Welte ]
294 * gbproxy: Add "show gbproxy cell ..." VTY command
295
296 [ Daniel Willmann ]
297 * gbproxy: Add SGSN NRI configuration
298 * gbproxy: Add SGSN pooling support
299 * gbproxy: Add comments to sgsn functions
300
301 [ Harald Welte ]
302 * gbproxy: Fix build on Deiban 8
303
304 [ Alexander Couzens ]
305 * sgsn: Use the new NS2 api
306 * gbproxy: use ns2 vty2
307
308 [ Daniel Willmann ]
309 * gbproxy: Add config option to name an SGSN
310 * gbproxy: Add VTY command to override the node selection function
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200311
312 [ Vadim Yanitskiy ]
Oliver Smith29532c22021-01-29 11:13:00 +0100313 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
314 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200315
316 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100317 * Fix gbproxy_sgsn_by_tlli wraparound
Harald Weltee250eaa2019-01-23 18:32:41 +0100318
319 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100320 * configure.ac: define a c standard instead of using the compilers default
Harald Weltee250eaa2019-01-23 18:32:41 +0100321
322 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100323 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
324 * gbproxy: Increase TLLI cache timeout to 10s
Harald Weltee250eaa2019-01-23 18:32:41 +0100325
326 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100327 * contrib/jenkins: don't build osmo-gsm-manuals
Harald Weltee250eaa2019-01-23 18:32:41 +0100328
Oliver Smith29532c22021-01-29 11:13:00 +0100329 [ Daniel Willmann ]
330 * gbproxy: Implement IMSI cache
331 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
332 * gbproxy: Use C-style comments
333 * gbproxy: Move helper function to a more logical place
334 * gbproxy: Remove unused variable assignment
335 * gbproxy: Fix VTY cmd name
336 * gbproxy: Define and use help string for gbproxy
337 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200338
339 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100340 * gb_proxy: Don't use orphan log subsystem DPCU
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200341
Oliver Smith29532c22021-01-29 11:13:00 +0100342 [ Daniel Willmann ]
343 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
344 * gbproxy: Print the correct message type for dummy paging/paging reject
345 * gbproxy: Improve log messages in gbproxy_select_sgsn
346 * gbproxy: Fix radio status routing by TMSI
Harald Welte5641e9d2017-10-28 19:07:48 +0200347
348 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100349 * follow libosmocore/gprs_ns2 API changes of GPRS enums
Harald Welte5641e9d2017-10-28 19:07:48 +0200350
351 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100352 * gbproxy: Avoid depending on any of the SGSN code
Harald Welte5641e9d2017-10-28 19:07:48 +0200353
Oliver Smith29532c22021-01-29 11:13:00 +0100354 [ Daniel Willmann ]
355 * manual/gbproxy: Update overview chapter
356 * Rename OsmoGbPROXY -> *Proxy
357 * manuals/gbproxy: Update configuration chapter
358 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
359 * manuals/gbproxy: MSC -> SGSN for pooling chapter
360 * manuals/gbproxy: Move pooling to separate chapter
Harald Welte5641e9d2017-10-28 19:07:48 +0200361
Oliver Smith29532c22021-01-29 11:13:00 +0100362 [ Alexander Couzens ]
363 * gbproxy: follow gprs_ns2 API vty changes
364 * sgsn: migrate to the new gprs_ns2_vty configuration
365 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200366
Oliver Smith29532c22021-01-29 11:13:00 +0100367 [ Oliver Smith ]
368 * === Split osmo-gbproxy from osmo-sgsn ===
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200369
Oliver Smith29532c22021-01-29 11:13:00 +0100370 -- Oliver Smith <osmith@sysmocom.de> Fri, 29 Jan 2021 12:57:28 +0100