blob: a6646c10b198b4363deddfdfef93f0fbf3782220 [file] [log] [blame]
Harald Welte640d72a2010-08-24 15:33:04 +02001#!/usr/bin/make -f
Alexander Couzens77ac7af2017-08-07 07:57:20 +00002# You must remove unused comment lines for the released package.
3# See debhelper(7) (uncomment to enable)
4# This is an autogenerated template for debian/rules.
5#
6# Output every command that modifies files on the build system.
7#export DH_VERBOSE = 1
8#
9# Copy some variable definitions from pkg-info.mk and vendor.mk
10# under /usr/share/dpkg/ to here if they are useful.
11#
12# See FEATURE AREAS/ENVIRONMENT in dpkg-buildflags(1)
13# Apply all hardening options
14#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
15# Package maintainers to append CFLAGS
16#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
17# Package maintainers to append LDFLAGS
18#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
19#
20# With debhelper version 9 or newer, the dh command exports
21# all buildflags. So there is no need to include the
22# /usr/share/dpkg/buildflags.mk file here if compat is 9 or newer.
23#
24# These are rarely used code. (START)
25#
26# The following include for *.mk magically sets miscellaneous
27# variables while honoring existing values of pertinent
28# environment variables:
29#
30# Architecture-related variables such as DEB_TARGET_MULTIARCH:
31#include /usr/share/dpkg/architecture.mk
32# Vendor-related variables such as DEB_VENDOR:
33#include /usr/share/dpkg/vendor.mk
34# Package-related variables such as DEB_DISTRIBUTION
35#include /usr/share/dpkg/pkg-info.mk
36#
37# You may alternatively set them susing a simple script such as:
38# DEB_VENDOR ?= $(shell dpkg-vendor --query Vendor)
39#
40# These are rarely used code. (END)
41#
Harald Welte640d72a2010-08-24 15:33:04 +020042
Alexander Couzens77ac7af2017-08-07 07:57:20 +000043# main packaging script based on dh7 syntax
Harald Welte640d72a2010-08-24 15:33:04 +020044%:
Pau Espin Pedrold58ddb22018-09-10 13:00:44 +020045 dh $@ --with autoreconf
Eric Butlera73ca052012-08-14 17:40:58 -070046
Pau Espin Pedrold58ddb22018-09-10 13:00:44 +020047# debmake generated override targets
Oliver Smith3f1f8572019-05-21 15:21:43 +020048CONFIGURE_FLAGS += --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
Eric Butlera73ca052012-08-14 17:40:58 -070049override_dh_auto_configure:
Alexander Couzens77ac7af2017-08-07 07:57:20 +000050 dh_auto_configure -- $(CONFIGURE_FLAGS)
51#
52# Do not install libtool archive, python .pyc .pyo
53#override_dh_install:
54# dh_install --list-missing -X.la -X.pyc -X.pyo
Eric Butlera73ca052012-08-14 17:40:58 -070055
Alexander Couzens77ac7af2017-08-07 07:57:20 +000056# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
57override_dh_strip:
Harald Welte689ebad2017-10-28 13:33:47 +020058 dh_strip -posmo-bsc --dbg-package=osmo-bsc-dbg
Alexander Couzens4fe3ee72017-10-11 07:10:15 +020059
60# Print test results in case of a failure
61override_dh_auto_test:
62 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
Oliver Smith3f1f8572019-05-21 15:21:43 +020063
64# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
65override_dh_compress:
66 dh_compress -X.pdf