blob: 690b40f03a8a6dd59339db823560caaa9dc81251 [file] [log] [blame]
Fabio Bertonf6234c42015-10-26 13:12:01 -02001DESCRIPTION = "GSM Audio Library"
2SECTION = "libs"
3PRIORITY = "optional"
Fabio Bertonefa58492015-10-26 13:22:07 -02004LICENSE = "ISC"
Fabio Bertonf6234c42015-10-26 13:12:01 -02005LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fc1372895b173aaf543a122db37e04f5"
Holger Hans Peter Freytherb49f5122011-11-11 21:36:15 +08006
Fabio Bertonee5e6c42015-10-26 13:17:41 -02007SRC_URI = "\
8 http://www.quut.com/gsm/gsm-${PV}.tar.gz \
Fabio Bertonefa58492015-10-26 13:22:07 -02009 file://0001-Configure-Makefile.patch \
10 file://0002-Add-defines-to-c.patch \
11 file://0003-Use-gsm_config.-header-instead-of-config.h.patch \
12 file://0004-Add-includes.patch \
13 file://0005-Change-compiler-warnings.patch \
Fabio Bertonee5e6c42015-10-26 13:17:41 -020014"
Holger Hans Peter Freytherb49f5122011-11-11 21:36:15 +080015
Fabio Bertonefa58492015-10-26 13:22:07 -020016SRC_URI[md5sum] = "4cbb4e7b73842de3d12d30b0d74200d4"
17SRC_URI[sha256sum] = "5814a16a30b3c026871b3739812dc4a2a84299331182c987da1c212c93e9352c"
Holger Hans Peter Freytherb49f5122011-11-11 21:36:15 +080018
Fabio Bertonefa58492015-10-26 13:22:07 -020019S = "${WORKDIR}/gsm-1.0-pl14/"
Fabio Bertonf6234c42015-10-26 13:12:01 -020020
21CFLAGS += "-c -g -fPIC -Wall -D_GNU_SOURCE -D_REENTRANT -DNeedFunctionPrototypes=1 -DWAV49 -I./inc"
22
23PARALLEL_MAKE = ""
24
Fabio Bertonee5e6c42015-10-26 13:17:41 -020025do_compile(){
26 unset LD
Holger Hans Peter Freythere274f002016-02-18 09:16:12 +010027 oe_runmake CCFLAGS="${CFLAGS}" CC="${CC}"
Fabio Bertonf6234c42015-10-26 13:12:01 -020028}
29
Fabio Bertonee5e6c42015-10-26 13:17:41 -020030do_install(){
31 oe_libinstall -a -C lib libgsm ${D}${libdir}
32 oe_libinstall -so -C lib libgsm ${D}${libdir}
33 install -d ${D}${includedir}/gsm
34 install -m 0644 ${S}/inc/gsm.h ${D}${includedir}/gsm/
35 cd ${D}${includedir}
36 ln -s gsm/gsm.h gsm.h
Fabio Bertonf6234c42015-10-26 13:12:01 -020037}