blob: 38e7e1134ee9ec8119341b9588f175c0e7452546 [file] [log] [blame]
Fabio Bertonf6234c42015-10-26 13:12:01 -02001DESCRIPTION = "GSM Audio Library"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "libgsm"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fc1372895b173aaf543a122db37e04f5"
Holger Hans Peter Freytherb49f5122011-11-11 21:36:15 +08006
Fabio Bertonf6234c42015-10-26 13:12:01 -02007INC_PR = "r2"
8
9SRC_URI = "http://www.quut.com/gsm/gsm-${PV}.tar.gz \
10 file://01_makefile.patch \
11 file://02_cplusplus.patch \
12 file://03_config.patch \
13 file://04_includes.patch \
14 file://05_compiler_warnings.patch \
15 "
Holger Hans Peter Freytherb49f5122011-11-11 21:36:15 +080016
17S = "${WORKDIR}/gsm-1.0-pl13/"
18
19SRC_URI[md5sum] = "c1ba392ce61dc4aff1c29ea4e92f6df4"
20SRC_URI[sha256sum] = "52c518244d428c2e56c543b98c9135f4a76ff780c32455580b793f60a0a092ad"
Fabio Bertonf6234c42015-10-26 13:12:01 -020021
22CFLAGS += "-c -g -fPIC -Wall -D_GNU_SOURCE -D_REENTRANT -DNeedFunctionPrototypes=1 -DWAV49 -I./inc"
23
24PARALLEL_MAKE = ""
25
26do_compile() {
27 unset LD
28 oe_runmake CCFLAGS="${CFLAGS}"
29}
30
31do_install() {
32 oe_libinstall -a -C lib libgsm ${D}${libdir}
33 oe_libinstall -so -C lib libgsm ${D}${libdir}
34 install -d ${D}${includedir}/gsm
35 install -m 0644 ${S}/inc/gsm.h ${D}${includedir}/gsm/
36 cd ${D}${includedir}
37 ln -s gsm/gsm.h gsm.h
38}