blob: b353acbea245df1772cfbd231cd9ad07a1b7017d [file] [log] [blame]
Harald Welteccd25da2016-06-23 08:51:51 +02001require ${PN}.inc
2
3S = "${WORKDIR}/git"
Pau Espin Pedrol6c88ab82018-03-27 17:23:20 +02004SRCREV = "58fcc5344ea0e914c7f9be69c309998d243142bd"
Harald Welteccd25da2016-06-23 08:51:51 +02005SRC_URI = "git://git.osmocom.org/libosmo-sccp.git;protocol=git"
Pau Espin Pedrol0979bed2017-11-01 14:36:55 +01006PV = "0.8.1+gitr${SRCPV}"
7PR = "${INC_PR}.0"
Holger Hans Peter Freyther26452d22017-06-02 18:33:02 +08008
Holger Hans Peter Freytherd20285c2017-06-02 18:33:02 +08009# we require the tests to link to the static libosmo-sigtran library to
10# access symbols not starting with osmo_*
11EXTRA_OECONF_remove = "--disable-static"
12
Pau Espin Pedrold7e9e0e2017-09-27 12:17:43 +020013PACKAGES =+ "osmo-stp"
14SYSTEMD_PACKAGES = "osmo-stp"
15SYSTEMD_SERVICE_osmo-stp = "osmo-stp.service"
16
Pau Espin Pedrold7e9e0e2017-09-27 12:17:43 +020017do_install_append() {
18 install -d ${D}${systemd_system_unitdir}/
19 install -d ${D}${sysconfdir}/osmocom/
20
21 install -m 0644 ${S}/doc/examples/osmo-stp.cfg ${D}${sysconfdir}/osmocom/
22 install -m 0644 ${S}/contrib/systemd/osmo-stp.service ${D}${systemd_system_unitdir}/
23}
24
25FILES_osmo-stp = " \
26 ${bindir}/osmo-stp \
27 ${sysconfdir}/osmocom/osmo-stp.cfg \
28 "
Pau Espin Pedrol71ac7c02017-12-04 18:37:22 +010029CONFFILES_osmo-stp = "${sysconfdir}/osmocom/osmo-stp.cfg"