blob: a335993aa2d9f16b36e05c3c9642f35f120719c1 [file] [log] [blame]
Harald Welteccd25da2016-06-23 08:51:51 +02001require ${PN}.inc
2
3S = "${WORKDIR}/git"
Pau Espin Pedrold9789902017-09-25 17:22:56 +02004SRCREV = "54fa75b85c91bb4bb79960942f63968f6423f6a5"
Harald Welteccd25da2016-06-23 08:51:51 +02005SRC_URI = "git://git.osmocom.org/libosmo-sccp.git;protocol=git"
Harald Welte5baaf5e2017-08-17 00:53:51 +02006PV = "0.7.0+gitr${SRCPV}"
Pau Espin Pedrol71ac7c02017-12-04 18:37:22 +01007PR = "${INC_PR}.2"
Holger Hans Peter Freyther26452d22017-06-02 18:33:02 +08008
Holger Hans Peter Freytherd20285c2017-06-02 18:33:02 +08009# we require the tests to link to the static libosmo-sigtran library to
10# access symbols not starting with osmo_*
11EXTRA_OECONF_remove = "--disable-static"
12
Pau Espin Pedrold7e9e0e2017-09-27 12:17:43 +020013PACKAGES =+ "osmo-stp"
14SYSTEMD_PACKAGES = "osmo-stp"
15SYSTEMD_SERVICE_osmo-stp = "osmo-stp.service"
16
Harald Welteccd25da2016-06-23 08:51:51 +020017# because "${WORKDIR}/git" is not a git repo, it can't figure out the version
18do_configure_prepend() {
19 echo "${PV}" > ${S}/.tarball-version
20}
Pau Espin Pedrold7e9e0e2017-09-27 12:17:43 +020021
22do_install_append() {
23 install -d ${D}${systemd_system_unitdir}/
24 install -d ${D}${sysconfdir}/osmocom/
25
26 install -m 0644 ${S}/doc/examples/osmo-stp.cfg ${D}${sysconfdir}/osmocom/
27 install -m 0644 ${S}/contrib/systemd/osmo-stp.service ${D}${systemd_system_unitdir}/
28}
29
30FILES_osmo-stp = " \
31 ${bindir}/osmo-stp \
32 ${sysconfdir}/osmocom/osmo-stp.cfg \
33 "
Pau Espin Pedrol71ac7c02017-12-04 18:37:22 +010034CONFFILES_osmo-stp = "${sysconfdir}/osmocom/osmo-stp.cfg"