blob: 13d3cbdfcfa94d92881ffbf175b5021639256592 [file] [log] [blame]
Pau Espin Pedrol73eade52017-09-25 17:46:29 +02001DESCRIPTION = "Osmocom GGSN implementation"
2HOMEPAGE = "https://osmocom.org/projects/openggsn"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
Pau Espin Pedrol599bb012018-05-06 23:01:31 +02005PV = "1.2.1+gitr${SRCPV}"
Pau Espin Pedrol0979bed2017-11-01 14:36:55 +01006PR = "r0"
Pau Espin Pedrol73eade52017-09-25 17:46:29 +02007
Pau Espin Pedrol599bb012018-05-06 23:01:31 +02008SRCREV = "ac07625086948281295e54dd295228153ecd5ff0"
Pau Espin Pedrol73eade52017-09-25 17:46:29 +02009SRC_URI = "git://git.osmocom.org/osmo-ggsn \
10 file://osmo-ggsn.init \
11 file://libgtp-queue_depth_32.patch \
12 "
13S = "${WORKDIR}/git"
14
15DEPENDS = "libosmocore"
16
17PACKAGES =+ " libgtp libgtp-dev libgtp-staticdev osmo-sgsnemu"
18RDEPENDS_${PN} += "iptables kernel-module-ipt-masquerade kernel-module-tun"
19
20inherit autotools update-rc.d pkgconfig systemd
21
22do_install_append() {
23 install -d ${D}${sysconfdir}/init.d
24 install -d ${D}${systemd_system_unitdir}/
25 install -d ${D}/${sysconfdir}/osmocom/
26
27 install -m 0776 ${WORKDIR}/osmo-ggsn.init ${D}${sysconfdir}/init.d/osmo-ggsn
28 install -m 0644 ${S}/contrib/osmo-ggsn.service ${D}${systemd_system_unitdir}/
29 install -m 0644 ${S}/doc/examples/osmo-ggsn.cfg ${D}${sysconfdir}/osmocom/
30}
31
32SYSTEMD_SERVICE_osmo-ggsn = "osmo-ggsn.service"
33
34INITSCRIPT_PACKAGES = "osmo-ggsn"
35INITSCRIPT_NAME_osmo-ggsn = "osmo-ggsn"
36INITSCRIPT_PARAMS_osmo-ggsn = "defaults 29 29"
37
Pau Espin Pedrol71ac7c02017-12-04 18:37:22 +010038CONFFILES_osmo-ggsn = "${sysconfdir}/osmocom/osmo-ggsn.cfg"
39
Pau Espin Pedrol73eade52017-09-25 17:46:29 +020040FILES_libgtp = "${libdir}/*${SOLIBS}"
41FILES_libgtp-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
42FILES_libgtp-staticdev = "${libdir}/*.a"
43
44FILES_osmo-sgsnemu = "${bindir}/sgsnemu"