blob: 5a383b998dbf9d5901df6367a5919bb8a0618a05 [file] [log] [blame]
Pau Espin Pedrol73eade52017-09-25 17:46:29 +02001DESCRIPTION = "Osmocom GGSN implementation"
2HOMEPAGE = "https://osmocom.org/projects/openggsn"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
5PV = "1.0.0+gitr${SRCPV}"
6PR = "r0"
7
8SRCREV = "b5624c3d4838cd774c3a6df4208b709890174a25"
9SRC_URI = "git://git.osmocom.org/osmo-ggsn \
10 file://osmo-ggsn.init \
11 file://libgtp-queue_depth_32.patch \
12 "
13S = "${WORKDIR}/git"
14
15DEPENDS = "libosmocore"
16
17PACKAGES =+ " libgtp libgtp-dev libgtp-staticdev osmo-sgsnemu"
18RDEPENDS_${PN} += "iptables kernel-module-ipt-masquerade kernel-module-tun"
19
20inherit autotools update-rc.d pkgconfig systemd
21
22do_install_append() {
23 install -d ${D}${sysconfdir}/init.d
24 install -d ${D}${systemd_system_unitdir}/
25 install -d ${D}/${sysconfdir}/osmocom/
26
27 install -m 0776 ${WORKDIR}/osmo-ggsn.init ${D}${sysconfdir}/init.d/osmo-ggsn
28 install -m 0644 ${S}/contrib/osmo-ggsn.service ${D}${systemd_system_unitdir}/
29 install -m 0644 ${S}/doc/examples/osmo-ggsn.cfg ${D}${sysconfdir}/osmocom/
30}
31
32SYSTEMD_SERVICE_osmo-ggsn = "osmo-ggsn.service"
33
34INITSCRIPT_PACKAGES = "osmo-ggsn"
35INITSCRIPT_NAME_osmo-ggsn = "osmo-ggsn"
36INITSCRIPT_PARAMS_osmo-ggsn = "defaults 29 29"
37
38FILES_libgtp = "${libdir}/*${SOLIBS}"
39FILES_libgtp-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
40FILES_libgtp-staticdev = "${libdir}/*.a"
41
42FILES_osmo-sgsnemu = "${bindir}/sgsnemu"