blob: bddca019e592b2a29732bb38d08ed7b3e4f0d191 [file] [log] [blame]
Pau Espin Pedrole394d9d2023-09-12 13:39:05 +02001libosmo-abis (1.5.0) unstable; urgency=medium
2
3 [ Philipp Maier ]
4 * e1_input: add define constant for full subslot (whole E1 timeslot)
5 * trau_sync: allow multiple secondary sync patterns
6 * trau_sync: add synchronization pattern for Ericsson RBS MCS9
7 * trau_pcu_ericsson: change loglevel for CPS decoding
8 * e1_input: add timeslot type NONE
9 * e1_input: cleanup TS resources when timeslot type is changed
10 * trau_pcu_ericsson_test: replace 64K CS1/CS2 testvectors
11 * trau_pcu_ericsson: cosmetic: set hdr_good flag explictly to false
12 * trau_pcu_ericsson: fix log line
13 * trau_pcu_ericsson_test: fix comment, CS2 blocks are not CRC protected
14 * trau_pcu_ericsson: add testvectors for MCS1-MCS8
15 * trau_pcu_ericsson: add comment about uplink blocks
16 * e1d: fix log output
17 * e1d: clean up error logging in handle_ts_sign_read
18 * e1d: maintain error log consistency in handle_ts_hdlc_read
19 * e1d: fix sourcecode formatting
20 * e1d: cosmetic: remove double whitespace
21 * e1d: close fd when osmo_fd_setup fails
22 * trau_pcu_ericsson: set uplink frame error bit correctly
23 * e1d: do not set fd number to 0 after close
24 * e1_input: add new driver callback function: line_create
25 * e1d: initialize file descriptor numbers to -1 on startup
26 * e1d: fix logic to detect if a timeslot is in use
27 * e1d: get rid of strange file descriptor registered check
28 * trau_pcu_ericsson: do not set unused D bits to 1
29 * e1d: reconnect to osmo-e1d after connection loss
30
31 [ Andreas Eversberg ]
32 * Add more L1 signals to common part
33 * Add function to set Sa bits to common part
34 * Add L1 signals to misdn driver
35 * Add setting of Sa bits to misdn driver
36 * Use correct bit order of RAW channels at misdn driver
37 * misdn driver: replace printf and fprintf by logging functions
38 * Rework mi_e1_line_update() and some of its sub routines
39 * Send raw data with e1d as it arrives from application
40 * e1d: Remove useless call of handle_ts_trau_write()
41 * e1d: Add support for HDLC type channels
42 * dahdi: Disable OSMO_FD_WRITE if HDLC/RAW write queue is empty
43 * dahdi: Add missing msg->l2h
44 * dahdi: Add msgb_free() to prevent memeory leaks
45
46 [ Oliver Smith ]
47 * Cosmetic: osmo_ortp.h: fix typos
48 * osmo_ortp.h: add RTP_PT_CSDATA
49 * Run struct_endianness.py
50 * debian: set compat level to 10
51
52 [ arehbein ]
53 * Transition to use of 'telnet_init_default'
54
55 [ Pau Espin Pedrol ]
56 * ipa: Call osmo_fd_unregister() before closing and changing bfd->fd
57
58 [ Mychaela N. Falconia ]
59 * osmo_rtp2trau() for FR & EFR: correctly handle the no-data case
60 * osmo_rtp2trau() for FR & EFR: set SP=0 in DL if the frame is a SID
61 * osmo_rtp2trau() for FR & EFR UL: set C13 & C14 correctly
62
63 [ Vadim Yanitskiy ]
64 * .gitignore: add new trau_{pcu_ericsson,sync} tests
65 * cosmetic: struct e1inp_ts: fix coding style
66 * cosmetic: e1inp_ipa_bts_rsl_close_n(): cache ipa_client_conn
67 * fix use-after-free in ipaccess_bts_keepalive_fsm_alloc()
68 * osmo_ortp: register a PayloadType for RTP_PT_CSDATA
69
70 [ Harald Welte ]
71 * trau_sync: Add sync pattern for FA protocol of 3GPP TS 43.045
72
73 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 12 Sep 2023 13:39:04 +0200
74
Pau Espin Pedrol656f1352023-02-07 13:15:21 +010075libosmo-abis (1.4.0) unstable; urgency=medium
76
77 [ Pau Espin Pedrol ]
78 * configure.ac: Set libosmo-e1d dependency version
79 * cosmetic: Remove unneeded empty line
80 * ipa: Allow users closing lower layer tcp/ipa connections
81 * e1inp_line_ipa_rsl_ts(): Return null instead of reading out of bounds
82 * ipaccess_close(): No need to lookup already available struct e1i_ts
83 * ipaccess: Call line->ops->sign_link_down() only if set
84
85 [ Vadim Yanitskiy ]
86 * libosmo{abis,trau}: add -no-undefined to *_la_LDFLAGS
87
88 [ Jan Engelhardt ]
89 * pkgconf: require libosmocore
90
91 [ Harald Welte ]
92 * input/unixsocket: Remove write delay timer
93 * Support building with -Werror=strict-prototypes / -Werror=old-style-definition
94 * trau_sync: Add the V.110 sync pattern
95 * trau_sync: Fix typo tray_sync_pat_id -> trau_sync_pat_id
96
97 [ Oliver Smith ]
98 * e1_input: enable tcp keepalive by default
99 * ipaccess: require tcp keepalive related defines
100 * ipaccess: update_fd_settings: use LOGL_ERROR
101
102 [ Daniel Willmann ]
103 * ipaccess: Clean up keepalive FSM properly
104 * ipa: Add ipa_client_conn_open2 with connect timeout argument
105 * ipaccess: Add connect timeout in e1inp_line
106 * ipa: Guard against calling ipa_client_conn_open* multiple times
107
108 [ Philipp Maier ]
109 * trau_sync: add Ericsson RBS GPRS TRAU synchronization pattern (16kbps)
110 * trau_sync: support more than 40 bytes sync pattern.
111 * trau_sync: add Ericsson RBS GPRS TRAU synchronization pattern (64kbps)
112 * GPRS Trau frame encoder/decoder for Ericsson RBS
113 * trau_pcu_ericsson: fix broken length check
114 * trau_pcu_ericsson: also support ER_UL_CHMOD_NB_UNKN in 16k mode.
115
116 [ Eric ]
117 * lapd_pcap: fix illegal VLA within struct
118
119 [ Andreas Eversberg ]
120 * Fix support for HDLC/RAW type channels at mISDN.c
121 * Add missing functions to send HDLC/RAW data
122 * Remove mISDN header from received channel data
123 * Initialize devinfo at misdn.c
124 * Send raw data with mISDN as it arrives from application
125
126 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 07 Feb 2023 13:15:21 +0100
127
Pau Espin Pedrol59a0c912022-06-28 17:59:38 +0200128libosmo-abis (1.3.0) unstable; urgency=medium
129
130 [ Harald Welte ]
131 * lapd: don't add parenthesis around datalink name
132 * input/ipaccess: Don't start zero-ms timer on every write
133 * update git URLs (git -> https; gitea)
134 * update git URLs (git -> https; gitea)
135 * osmo_pcap_lapd_write: Fix write of uninitialized byte(s)
136
137 [ Oliver Smith ]
138 * treewide: remove FSF address
139
140 [ Philipp Maier ]
141 * ipaccess.c: register RSL/OML related osmo_fds for monitoring
142
143 [ Michael Iedema ]
144 * stats: add RSL line number to TCP stats name
145 * stats: add BTS index to IPA RSL TCP stats name
146 * stats: add site_id scope to ipa-rsl tcp stat names
147
148 [ Vadim Yanitskiy ]
149 * input/e1d: fix a memleak in handle_ts_raw_read()
150 * input/e1d: use msgb_hexdump_l2() in handle_ts_raw_read()
151
152 [ Pau Espin Pedrol ]
153 * input/ipaccess: Remove unneeded osmo_fd_write_enable()
154 * input/ipaccess: Avoid extra poll() call when e1i_ts tx queue becomes empty
155
156 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 28 Jun 2022 17:59:38 +0200
157
Pau Espin Pedrola6eda5a2021-11-16 14:18:45 +0100158libosmo-abis (1.2.0) unstable; urgency=medium
159
160 [ Keith ]
161 * Configure E1 pcap file per line
162 * Log TRAU FSM at INFO not NOTICE
163 * Fix up vty 'show' commands for E1 line/timeslots
164
165 [ Harald Welte ]
166 * ipa: Introduce support for user-specific DSCP and priority
167 * e1_input: Allow (vty) configuration of IP DSCP and socket priority
168 * trau: Introduce osmo_rtp_socket_set_priority()
169
170 [ Philipp Maier ]
171 * ipaccess: do not block ipaccess_line_update on failure
172
173 [ Pau Espin Pedrol ]
174 * Use new stat item/ctr getter APIs
175 * osmo_ortp: Fix seqno reset to 0 upon ssrc_changed
176 * e1_input: Fix line not removed from e1inp_line_list when freed
177 * e1_input: Document e1inp_line_create()
178 * ipaccess: Allow reconfiguring the ipa line during line_update()
179 * ipaccess: e1inp_ipa_bts_rsl_connect: Fix memleak recreating ipa_client_conn
180 * e1inp_input: Fix e1inp_line_clone removing original line from global list when freed
181
182 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:18:45 +0100
183
Harald Welte4aea11b2021-02-24 09:32:29 +0100184libosmo-abis (1.1.1) unstable; urgency=medium
185
186 * attempt to fix RPM spec file after recent soversion bump
187
188 -- Harald Welte <laforge@osmocom.org> Wed, 24 Feb 2021 09:32:29 +0100
189
Pau Espin Pedrolde169192021-02-23 16:21:49 +0100190libosmo-abis (1.1.0) unstable; urgency=medium
191
192 [ Harald Welte ]
193 * trau_frame: New API
194 * trau_frame: Introduce support for Downlink Time Alignment
195 * osmo_trau_frame_encode(): Check for sufficiently sized output buffer
196 * Add new TRAU frame sync code
197 * TRAU frame RTP conversion
198 * Add 'trau2rtp' demo program illustrating the use of new TRAU code
199 * Add missing build dependency to libosmocodec-dev
200 * trau_frame: Fix computation of odd parity while encoding HR frames
201 * trau_sync: Check return value of osmo_fsm_register()
202 * trau_frame: Add missing break statement in osmo_trau_frame_encode()
203 * Fix RPM spec file (.so.6 -> .so.9)
204 * debian: Build libosmo-abis with osmo-e1d support
205 * Revert "debian: Build libosmo-abis with osmo-e1d support"
206 * Use OSMO_FD_* instead of deprecated BSC_FD_*
207 * Use osmo_fd_setup() wherever applicable
208 * e1_input: Support I.460 timeslot type
209 * osmo_ortp: Don't print ERROR message for every missing RTP frame
210 * migrate to osmo_fd_{read,write}_{enable,disable}()
211
212 [ Philipp Maier ]
213 * trau_sync: prevent false positive synchronization on startup
214 * trau_sync: make sync pattern configurable
215 * vty: add attributes to VTY commands indicating when they apply
216
217 [ Vadim Yanitskiy ]
218 * debian/control: change maintainer to the Osmocom team / mailing list
219 * vty: use install_lib_element() and install_lib_element_ve()
220 * cosmetic: fix spelling in logging messages: existAnt -> existEnt
221 * ipaccess: fix verbosive logging in __handle_ts1_write()
222
223 [ Pau Espin Pedrol ]
224 * tests: Disable stderr log color in trau_sync_test
225 * contrib/jenkins: Enable parallel make in make distcheck
226 * ipaccess: Use LOGPITS macro in __handle_ts1_write
227 * ipaccess: Fix log error printed on wrong conditional branch
228 * ipaccess: Fix wrong assertion in ipaccess_drop() when used by BTS code
229 * tests: trau_sync: Explicitly drop category from log
230 * gitignore: Ignore autofoo files *~
231
232 [ Oliver Smith ]
233 * configure.ac: set -std=gnu11
234
235 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 16:21:49 +0100
236
Harald Welte2a8a34c2020-08-13 12:09:39 +0200237libosmo-abis (1.0.0) unstable; urgency=medium
238
239 [ Neels Hofmeyr ]
240 * add/clean big-endian packed structs (struct_endianess.py)
241
242 [ Harald Welte ]
243 * dahdi: Don't use perror() directly, use osmocom logging instead
244 * introduce and use logging macros with context on E1 line / timeslot
245 * e1d: Use HAVE_E1D in C source, not ENABLE_E1D
246 * e1d: add missing forward-declaration of e1inp_e1d_init()
247 * e1d: Don't use perror() directly, use osmocom logging instead
248 * e1d: Remove EXCEPTFD handling
249 * e1d: Remove bogus vty_show function.
250 * e1d: Use line->port_nr to specify e1d interface/line
251 * e1d: Use LOGPIL/LOGPITS logging macros to give context
252 * e1d: Don't connect to e1d at program start time
253 * e1d: Implement varions non-LAPD timeslot modes
254 * Add rtp_test to show the double-bind bug of OS#4444
255 * ortp: disable SO_REUSEADDR + SO_REUSEPORT
256 * subchan_demux: Use 'ubit_t' for unpacked bit buffer; use const
257 * trau_frame: use 'ubit_t' for unpacked bits
258 * subchan_demux: Use ubit_t where appropriate
259 * trau_frame.h: Fix definition of TRAU_FT_OM_UP
260 * Fix subchan_demux_test compiler warning on some gcc versions
261 * trau_frame: Fix AMR frame decoding
262 * lapd: Always print context information when logging
263 * fix compilation with --enable-e1d
264 * lapd: Replace magic numbers with #defines
265 * input/lapd.c: Enlarge message buffers for DL-SAP primitives
266 * input/dahdi.c: Don't simply read beyond end of msgb
267 * subchan_demux: Fix out-of-bounds write
268 * e1d: Add new osmo_e1dp_client_ts_open() argument
269 * e1d: Fix compilation after I4a088f91f23aaad05c5ab84a4783c1915d85aca6
270 * contrib/jenkins.sh: Test builds with --enable-e1d
271 * dahdi: Use osmo_revbytebits_buf() instead of local flip table
272 * input/e1d: Fix support for TRAU slots
273 * input/e1d: Add missing "RAW" timeslot support
274 * e1_input_vty: Fix VTY help strings
275
276 [ Sylvain Munaut ]
277 * e1d: Initial osmo-e1d support
278 * e1_input: Allow to change the pcap fd and/or unset it
279 * e1_input: Add VTY command to enable PCAP debug output
280
281 [ Oliver Smith ]
282 * ipaccess.c: line_already_initialized: int -> bool
283 * osmo_ortp: add osmo_rtp_socket_set_dscp()
284 * contrib: import RPM spec
285 * contrib: integrate RPM spec
286 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
287 * src/input/ipaccess.c: set TCP_NODELAY
288
289 [ Eric Wild ]
290 * add ipa ping/pong keepalive for OML/RSL links between bts and bsc
291
292 [ Eric ]
293 * configure.ac: fix libtool issue with clang and sanitizer
294
295 [ Pau Espin Pedrol ]
296 * e1_input: refcount inc line during e1_sign_link_create, not during line update
297 * ipaccess.c: Drop repeated ipaccess_keepalive_fsm_cleanup in write error path
298 * ipaccess: Fix log formatting of RESP_ID IPA attributes
299 * cosmetic: e1_input.h: Fix trailing whitespace
300 * e1_input: Use osmo_use_count in e1inp_line
301 * ipaccess: Drop e1inp_line reference in ipacess_drop()
302 * ipacces: Fix e1inp_line reference put in ipaccess_close
303 * ipaccess: Set bfd->data to NULL before releasing its reference
304 * ipaccess_recvmsg: Clean up release steps upon error condition
305 * ipaccess_recvmsg: Assert the new bfd from new line differs from the old one
306 * ipaccess_recvmsg: Untangle code updating line
307 * cosmetic: lapd: Fix trailing whitespace
308 * lapd: Use lapd_dl_init2 instead of deprecated lapd_dl_init
309 * tests: Use API e1inp_line_put2 instead of deprecated e1inp_line_put
310 * ipaccess: Fix use-after-free in ipaccess_drop()
311
312 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:09:39 +0200
313
Pau Espin Pedrolc313d442020-01-02 20:53:32 +0100314libosmo-abis (0.8.0) unstable; urgency=medium
315
316 [ Alexander Couzens ]
317 * ipa: ipa_server_link_close() add checks of link state
318
319 [ Pau Espin Pedrol ]
320 * ipa: Allow setting local addr and port for struct ipa_client_conn
321
322 [ Harald Welte ]
323 * dahdi: Use ioctl(DAHDI_SPECIFY) instead of legacy /dev/dahdi/%u
324 * Enable DAHDI support by default; require --disable-dahdi otherwise
325
326 [ Vadim Yanitskiy ]
327 * input/ipaccess.c: propagate errors from ipa_parse_unitid()
328 * input/ipaccess.c: fix debug message on receipt of IPAC_MSGT_ID_GET
329 * e1_input.c: make reference counting get() / put() more verbose
330 * input/ipa_keepalive.c: make sure IPA keepalive FSM is registered
331
332 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:53:32 +0100
333
Harald Welte30249a12019-07-21 21:32:08 +0200334libosmo-abis (0.7.0) unstable; urgency=medium
335
336 [ Max ]
337 * Set local IP in ipa_server_link properly
338 * Log peer's port in accept callback
339
340 [ Harald Welte ]
341 * ipa: Make ipa_server_conn_destroy() re-entrant
342 * Add IPA keep-alive FSM implementation
343 * ipa_keepalive_fsm: Fix OSMO_IPA_KA_E_STOP allstate event
344 * ipa_keepalive_fsm: Suppress error messages for INIT -> INIT transition
345 * ipaccess.c: Avoid calling close(-1) on error path
346
347 [ Oliver Smith ]
348 * tests: use -no-install libtool flag to avoid ./lt-* scripts
349 * contrib/jenkins.sh: run "make maintainer-clean"
350
351 [ Sylvain Munaut ]
352 * rtp: Add 'autoconnect' feature to the osmo_rtp_socket
353
354 [ Eric Wild ]
355 * ipaccess: allow tcp keepalive for ipa clients
356 * add TCP_USER_TIMEOUT to keepalive
357 * extend the ipa keepalive fsm
358
359 [ Debian Mobcom Maintainers ]
360 * spelling
361
362 -- Harald Welte <laforge@gnumonks.org> Sun, 21 Jul 2019 21:32:08 +0200
363
Harald Welte176a1fb2019-01-19 22:20:47 +0100364libosmo-abis (0.6.0) unstable; urgency=medium
365
366 [ Neels Hofmeyr ]
367 * fix strncpy bugs in ipaccess.c, ipa_proxy.c
368 * ipa: don't crash on missing IPA ID GET message
369
370 [ Harald Welte ]
371 * Migrate from ipa_ccm_idtag_parse to ipa_ccm_id_resp_parse()
372 * debian/rules: Don't overwrite .tarball-version
373
374 [ Pau Espin Pedrol ]
375 * ipaccess: Use osmo_fd_setup to set up callbacks
376 * ipaccess_rcvmsg: Fix bug introduced in previous commit
377 * ipa: Simplify code in ipa_client_read
378 * ipa: Simplify code in ipa_server_conn_read
379 * ipa: Allow signalling fd destroyed in ipa_client_read
380 * ipa: Allow signalling fd destroyed in ipa_server_conn_read
381 * ipaccess: Return -EBADF when closing socket in ipaccess_bts_read_cb
382 * ipaccess: Allow passing return code in e1inp_line_ops->sign_link()
383 * debian: Fix libosmoabis soname package version
384 * debian: Conflict libosmoabis6 with libosmoabis5
385 * ipacces: Log correct trx_nr during IPA GET
386 * ipaccess: Simplify handling of ipaccess e1line ts
387 * e1_input.h: Set correct type for input_signal_data->link_type
388 * osmo_ortp: Log domain and fix strings without endl char
389
390 [ Stefan Sperling ]
391 * Properly deal with sockaddr_un socket path length limitations.
392 * ensure unix socket paths are NUL-terminated for bind/connect
393
394 -- Harald Welte <laforge@gnumonks.org> Sat, 19 Jan 2019 22:20:46 +0100
395
Pau Espin Pedrol026ff452018-07-27 18:15:19 +0200396libosmo-abis (0.5.1) unstable; urgency=medium
397
398 [ Pau Espin Pedrol ]
399 * ipaccess: ipaccess_rcvmsg: Drop unneeded memcpy
400 * ipaccess: Avoid using released line and bfd in ipaccess_fd_cb
401 * e1_input.c: Replace '.' in counter names with ':'
402
403 [ Stefan Sperling ]
404 * fix double-free/use-after-free of pointers in struct e1inp_line
405
406 [ Philipp Maier ]
407 * ortp: make sure the ortp scheduler is started
408 * ortp: reset rtp session on SSRC changes
409 * ortp: detect ssrc changes immediately
410 * ortp: enable scheduled mode on rtp socket creation
411 * Revert "ortp: make sure the ortp scheduler is started"
412 * Revert "ortp: enable scheduled mode on rtp socket creation"
413
414 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 18:15:18 +0200
415
Pau Espin Pedrol7b89f122018-05-03 16:12:04 +0200416libosmo-abis (0.5.0) unstable; urgency=medium
417
418 [ Max ]
419 * Use value string check from osmo-ci
420 * cosmetic: update ipaccess_bts_handle_ccm()
421 * IPA: log remote address
422
423 [ Neels Hofmeyr ]
424 * cosmetic: ipa.c: use msgb_dequeue(), drop local var
425 * jenkins: use osmo-clean-workspace.sh before and after build
426 * vty: skip installing cmds now always installed by default
427 * add --enable-sanitize config option
428 * configure: add --enable-werror
429 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
430
431 [ Alexander Couzens ]
432 * debian/rules: show testsuite.log when tests are failing
433 * unixsocket: fix a potential string overflow
434
435 [ Harald Welte ]
436 * debian/copyright: fix upstream-name
437 * Add SPDX-License-Identifier to all source files
438 * Add a new osmo_rtp_set_source_desc() function to set the RTCP SDES items
439 * debian/control: Fix Vcs-Browser
440
441 [ Pau Espin Pedrol ]
442 * contrib: jenkins.sh: Disable doxygen in libosmocore build
443 * e1_input.h: Remove dead declaration of unexistent API ipaccess_setup
444 * configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
445 * use osmo_init_logging2
446 * git-version-gen: Check first for new tag format
447
448 [ Stefan Sperling ]
449 * preserve 'when' flags of new osmo_fd in ipaccess_rcvmsg()
450
451 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:12:04 +0200
452
Max7f17b8c2017-08-25 16:09:48 +0200453libosmo-abis (0.4.0) unstable; urgency=medium
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200454
455 * Move forward towards a new release.
Max7f17b8c2017-08-25 16:09:48 +0200456 * libosmo-abis API change major: add parameter to struct
457 input_signal_data
458 * libosmo-trau API change major: add parameters to rx_cb()
459 callack in osmo_ortp.h
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200460
Max7f17b8c2017-08-25 16:09:48 +0200461 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 25 Aug 2017 16:09:46 +0200
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200462
463libosmo-abis (0.3.2) unstable; urgency=medium
Holger Hans Peter Freyther3cef39b2015-11-03 09:40:00 +0100464
465 * Bump so version to re-link libosmovty
466
467 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:42:01 +0100
468
469libosmo-abis (0.3.1) unstable; urgency=medium
Holger Hans Peter Freyther2f0dd0c2015-01-18 19:27:07 +0100470
471 * New upstream release of libosmo-abis
472
473 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:26:40 +0100
474
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200475libosmo-abis (0.3.0) unstable; urgency=medium
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200476
477 * New upstream release of libosmo-abis
478
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200479 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:39 +0200
480
481libosmo-abis (0.2.0) unstable; urgency=medium
482
483 * New upstream release of libosmo-abis
484
485 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:19 +0200
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200486
487libosmo-abis (0.1.6) unstable; urgency=medium
Holger Hans Peter Freytherf6415ea2014-01-20 10:33:52 +0100488
489 * New upstream release of libosmo-abis
490
491 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:33:36 +0100
492
Holger Hans Peter Freyther91de2d02013-12-12 11:47:39 +0100493libosmo-abis (0.1.5+git1) unstable; urgency=low
494
495 * Rebuild 0.1.5 with the right libosmocore depedency
496
497 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 12 Dec 2013 11:47:01 +0100
498
Holger Hans Peter Freyther2dfcd9e2012-11-06 13:34:34 +0100499libosmo-abis (0.1.4) unstable; urgency=low
500
501 * New upstream release
502
503 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 06 Nov 2012 13:33:45 +0100
504
Eric Butlerd11a5c12012-08-14 20:56:26 -0700505libosmo-abis (0.1.3+git3-1) precise; urgency=low
506
507 * Fix version issue.
508
509 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
510
Eric Butler91ffa2b2012-08-14 18:07:48 -0700511libosmo-abis (0.1.3+git3) precise; urgency=low
512
513 Created new Ubuntu package.
514
515 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 13:00:18 -0700