blob: b839ed9a0bc1ce2a1690f2968a6dc6861e59a588 [file] [log] [blame]
Harald Welte2a8a34c2020-08-13 12:09:39 +02001libosmo-abis (1.0.0) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * add/clean big-endian packed structs (struct_endianess.py)
5
6 [ Harald Welte ]
7 * dahdi: Don't use perror() directly, use osmocom logging instead
8 * introduce and use logging macros with context on E1 line / timeslot
9 * e1d: Use HAVE_E1D in C source, not ENABLE_E1D
10 * e1d: add missing forward-declaration of e1inp_e1d_init()
11 * e1d: Don't use perror() directly, use osmocom logging instead
12 * e1d: Remove EXCEPTFD handling
13 * e1d: Remove bogus vty_show function.
14 * e1d: Use line->port_nr to specify e1d interface/line
15 * e1d: Use LOGPIL/LOGPITS logging macros to give context
16 * e1d: Don't connect to e1d at program start time
17 * e1d: Implement varions non-LAPD timeslot modes
18 * Add rtp_test to show the double-bind bug of OS#4444
19 * ortp: disable SO_REUSEADDR + SO_REUSEPORT
20 * subchan_demux: Use 'ubit_t' for unpacked bit buffer; use const
21 * trau_frame: use 'ubit_t' for unpacked bits
22 * subchan_demux: Use ubit_t where appropriate
23 * trau_frame.h: Fix definition of TRAU_FT_OM_UP
24 * Fix subchan_demux_test compiler warning on some gcc versions
25 * trau_frame: Fix AMR frame decoding
26 * lapd: Always print context information when logging
27 * fix compilation with --enable-e1d
28 * lapd: Replace magic numbers with #defines
29 * input/lapd.c: Enlarge message buffers for DL-SAP primitives
30 * input/dahdi.c: Don't simply read beyond end of msgb
31 * subchan_demux: Fix out-of-bounds write
32 * e1d: Add new osmo_e1dp_client_ts_open() argument
33 * e1d: Fix compilation after I4a088f91f23aaad05c5ab84a4783c1915d85aca6
34 * contrib/jenkins.sh: Test builds with --enable-e1d
35 * dahdi: Use osmo_revbytebits_buf() instead of local flip table
36 * input/e1d: Fix support for TRAU slots
37 * input/e1d: Add missing "RAW" timeslot support
38 * e1_input_vty: Fix VTY help strings
39
40 [ Sylvain Munaut ]
41 * e1d: Initial osmo-e1d support
42 * e1_input: Allow to change the pcap fd and/or unset it
43 * e1_input: Add VTY command to enable PCAP debug output
44
45 [ Oliver Smith ]
46 * ipaccess.c: line_already_initialized: int -> bool
47 * osmo_ortp: add osmo_rtp_socket_set_dscp()
48 * contrib: import RPM spec
49 * contrib: integrate RPM spec
50 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
51 * src/input/ipaccess.c: set TCP_NODELAY
52
53 [ Eric Wild ]
54 * add ipa ping/pong keepalive for OML/RSL links between bts and bsc
55
56 [ Eric ]
57 * configure.ac: fix libtool issue with clang and sanitizer
58
59 [ Pau Espin Pedrol ]
60 * e1_input: refcount inc line during e1_sign_link_create, not during line update
61 * ipaccess.c: Drop repeated ipaccess_keepalive_fsm_cleanup in write error path
62 * ipaccess: Fix log formatting of RESP_ID IPA attributes
63 * cosmetic: e1_input.h: Fix trailing whitespace
64 * e1_input: Use osmo_use_count in e1inp_line
65 * ipaccess: Drop e1inp_line reference in ipacess_drop()
66 * ipacces: Fix e1inp_line reference put in ipaccess_close
67 * ipaccess: Set bfd->data to NULL before releasing its reference
68 * ipaccess_recvmsg: Clean up release steps upon error condition
69 * ipaccess_recvmsg: Assert the new bfd from new line differs from the old one
70 * ipaccess_recvmsg: Untangle code updating line
71 * cosmetic: lapd: Fix trailing whitespace
72 * lapd: Use lapd_dl_init2 instead of deprecated lapd_dl_init
73 * tests: Use API e1inp_line_put2 instead of deprecated e1inp_line_put
74 * ipaccess: Fix use-after-free in ipaccess_drop()
75
76 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:09:39 +0200
77
Pau Espin Pedrolc313d442020-01-02 20:53:32 +010078libosmo-abis (0.8.0) unstable; urgency=medium
79
80 [ Alexander Couzens ]
81 * ipa: ipa_server_link_close() add checks of link state
82
83 [ Pau Espin Pedrol ]
84 * ipa: Allow setting local addr and port for struct ipa_client_conn
85
86 [ Harald Welte ]
87 * dahdi: Use ioctl(DAHDI_SPECIFY) instead of legacy /dev/dahdi/%u
88 * Enable DAHDI support by default; require --disable-dahdi otherwise
89
90 [ Vadim Yanitskiy ]
91 * input/ipaccess.c: propagate errors from ipa_parse_unitid()
92 * input/ipaccess.c: fix debug message on receipt of IPAC_MSGT_ID_GET
93 * e1_input.c: make reference counting get() / put() more verbose
94 * input/ipa_keepalive.c: make sure IPA keepalive FSM is registered
95
96 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:53:32 +0100
97
Harald Welte30249a12019-07-21 21:32:08 +020098libosmo-abis (0.7.0) unstable; urgency=medium
99
100 [ Max ]
101 * Set local IP in ipa_server_link properly
102 * Log peer's port in accept callback
103
104 [ Harald Welte ]
105 * ipa: Make ipa_server_conn_destroy() re-entrant
106 * Add IPA keep-alive FSM implementation
107 * ipa_keepalive_fsm: Fix OSMO_IPA_KA_E_STOP allstate event
108 * ipa_keepalive_fsm: Suppress error messages for INIT -> INIT transition
109 * ipaccess.c: Avoid calling close(-1) on error path
110
111 [ Oliver Smith ]
112 * tests: use -no-install libtool flag to avoid ./lt-* scripts
113 * contrib/jenkins.sh: run "make maintainer-clean"
114
115 [ Sylvain Munaut ]
116 * rtp: Add 'autoconnect' feature to the osmo_rtp_socket
117
118 [ Eric Wild ]
119 * ipaccess: allow tcp keepalive for ipa clients
120 * add TCP_USER_TIMEOUT to keepalive
121 * extend the ipa keepalive fsm
122
123 [ Debian Mobcom Maintainers ]
124 * spelling
125
126 -- Harald Welte <laforge@gnumonks.org> Sun, 21 Jul 2019 21:32:08 +0200
127
Harald Welte176a1fb2019-01-19 22:20:47 +0100128libosmo-abis (0.6.0) unstable; urgency=medium
129
130 [ Neels Hofmeyr ]
131 * fix strncpy bugs in ipaccess.c, ipa_proxy.c
132 * ipa: don't crash on missing IPA ID GET message
133
134 [ Harald Welte ]
135 * Migrate from ipa_ccm_idtag_parse to ipa_ccm_id_resp_parse()
136 * debian/rules: Don't overwrite .tarball-version
137
138 [ Pau Espin Pedrol ]
139 * ipaccess: Use osmo_fd_setup to set up callbacks
140 * ipaccess_rcvmsg: Fix bug introduced in previous commit
141 * ipa: Simplify code in ipa_client_read
142 * ipa: Simplify code in ipa_server_conn_read
143 * ipa: Allow signalling fd destroyed in ipa_client_read
144 * ipa: Allow signalling fd destroyed in ipa_server_conn_read
145 * ipaccess: Return -EBADF when closing socket in ipaccess_bts_read_cb
146 * ipaccess: Allow passing return code in e1inp_line_ops->sign_link()
147 * debian: Fix libosmoabis soname package version
148 * debian: Conflict libosmoabis6 with libosmoabis5
149 * ipacces: Log correct trx_nr during IPA GET
150 * ipaccess: Simplify handling of ipaccess e1line ts
151 * e1_input.h: Set correct type for input_signal_data->link_type
152 * osmo_ortp: Log domain and fix strings without endl char
153
154 [ Stefan Sperling ]
155 * Properly deal with sockaddr_un socket path length limitations.
156 * ensure unix socket paths are NUL-terminated for bind/connect
157
158 -- Harald Welte <laforge@gnumonks.org> Sat, 19 Jan 2019 22:20:46 +0100
159
Pau Espin Pedrol026ff452018-07-27 18:15:19 +0200160libosmo-abis (0.5.1) unstable; urgency=medium
161
162 [ Pau Espin Pedrol ]
163 * ipaccess: ipaccess_rcvmsg: Drop unneeded memcpy
164 * ipaccess: Avoid using released line and bfd in ipaccess_fd_cb
165 * e1_input.c: Replace '.' in counter names with ':'
166
167 [ Stefan Sperling ]
168 * fix double-free/use-after-free of pointers in struct e1inp_line
169
170 [ Philipp Maier ]
171 * ortp: make sure the ortp scheduler is started
172 * ortp: reset rtp session on SSRC changes
173 * ortp: detect ssrc changes immediately
174 * ortp: enable scheduled mode on rtp socket creation
175 * Revert "ortp: make sure the ortp scheduler is started"
176 * Revert "ortp: enable scheduled mode on rtp socket creation"
177
178 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 18:15:18 +0200
179
Pau Espin Pedrol7b89f122018-05-03 16:12:04 +0200180libosmo-abis (0.5.0) unstable; urgency=medium
181
182 [ Max ]
183 * Use value string check from osmo-ci
184 * cosmetic: update ipaccess_bts_handle_ccm()
185 * IPA: log remote address
186
187 [ Neels Hofmeyr ]
188 * cosmetic: ipa.c: use msgb_dequeue(), drop local var
189 * jenkins: use osmo-clean-workspace.sh before and after build
190 * vty: skip installing cmds now always installed by default
191 * add --enable-sanitize config option
192 * configure: add --enable-werror
193 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
194
195 [ Alexander Couzens ]
196 * debian/rules: show testsuite.log when tests are failing
197 * unixsocket: fix a potential string overflow
198
199 [ Harald Welte ]
200 * debian/copyright: fix upstream-name
201 * Add SPDX-License-Identifier to all source files
202 * Add a new osmo_rtp_set_source_desc() function to set the RTCP SDES items
203 * debian/control: Fix Vcs-Browser
204
205 [ Pau Espin Pedrol ]
206 * contrib: jenkins.sh: Disable doxygen in libosmocore build
207 * e1_input.h: Remove dead declaration of unexistent API ipaccess_setup
208 * configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
209 * use osmo_init_logging2
210 * git-version-gen: Check first for new tag format
211
212 [ Stefan Sperling ]
213 * preserve 'when' flags of new osmo_fd in ipaccess_rcvmsg()
214
215 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:12:04 +0200
216
Max7f17b8c2017-08-25 16:09:48 +0200217libosmo-abis (0.4.0) unstable; urgency=medium
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200218
219 * Move forward towards a new release.
Max7f17b8c2017-08-25 16:09:48 +0200220 * libosmo-abis API change major: add parameter to struct
221 input_signal_data
222 * libosmo-trau API change major: add parameters to rx_cb()
223 callack in osmo_ortp.h
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200224
Max7f17b8c2017-08-25 16:09:48 +0200225 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 25 Aug 2017 16:09:46 +0200
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200226
227libosmo-abis (0.3.2) unstable; urgency=medium
Holger Hans Peter Freyther3cef39b2015-11-03 09:40:00 +0100228
229 * Bump so version to re-link libosmovty
230
231 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:42:01 +0100
232
233libosmo-abis (0.3.1) unstable; urgency=medium
Holger Hans Peter Freyther2f0dd0c2015-01-18 19:27:07 +0100234
235 * New upstream release of libosmo-abis
236
237 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:26:40 +0100
238
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200239libosmo-abis (0.3.0) unstable; urgency=medium
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200240
241 * New upstream release of libosmo-abis
242
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200243 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:39 +0200
244
245libosmo-abis (0.2.0) unstable; urgency=medium
246
247 * New upstream release of libosmo-abis
248
249 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:19 +0200
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200250
251libosmo-abis (0.1.6) unstable; urgency=medium
Holger Hans Peter Freytherf6415ea2014-01-20 10:33:52 +0100252
253 * New upstream release of libosmo-abis
254
255 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:33:36 +0100
256
Holger Hans Peter Freyther91de2d02013-12-12 11:47:39 +0100257libosmo-abis (0.1.5+git1) unstable; urgency=low
258
259 * Rebuild 0.1.5 with the right libosmocore depedency
260
261 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 12 Dec 2013 11:47:01 +0100
262
Holger Hans Peter Freyther2dfcd9e2012-11-06 13:34:34 +0100263libosmo-abis (0.1.4) unstable; urgency=low
264
265 * New upstream release
266
267 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 06 Nov 2012 13:33:45 +0100
268
Eric Butlerd11a5c12012-08-14 20:56:26 -0700269libosmo-abis (0.1.3+git3-1) precise; urgency=low
270
271 * Fix version issue.
272
273 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
274
Eric Butler91ffa2b2012-08-14 18:07:48 -0700275libosmo-abis (0.1.3+git3) precise; urgency=low
276
277 Created new Ubuntu package.
278
279 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 13:00:18 -0700