blob: d3f1534c88ce60433016b9e05195db45400bf1c8 [file] [log] [blame]
Eric Butler91ffa2b2012-08-14 18:07:48 -07001#!/usr/bin/make -f
2
Eric Butlerd11a5c12012-08-14 20:56:26 -07003DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +01007#export DH_VERBOSE=1
Holger Hans Peter Freytherd65ccd52013-12-12 12:30:29 +01008export DEB_BUILD_HARDENING=1
Eric Butler91ffa2b2012-08-14 18:07:48 -07009
10%:
Holger Hans Peter Freyther050d60a2015-03-14 20:01:48 +010011 dh $@ --with autoreconf --fail-missing
Eric Butlerd11a5c12012-08-14 20:56:26 -070012
Holger Hans Peter Freythercf5b08b2013-02-13 20:12:36 +010013override_dh_strip:
14 dh_strip --dbg-package=libosmo-abis-dbg
15
Eric Butlerd11a5c12012-08-14 20:56:26 -070016override_dh_autoreconf:
17 echo $(VERSION) > .tarball-version
18 dh_autoreconf