blob: 476c3bfe8b78cee8d8ea5dcf79e904e089d0211e [file] [log] [blame]
Eric Butler91ffa2b2012-08-14 18:07:48 -07001#!/usr/bin/make -f
2
Eric Butlerd11a5c12012-08-14 20:56:26 -07003DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Eric Butler91ffa2b2012-08-14 18:07:48 -07007export DH_VERBOSE=1
8
9%:
10 dh --with autoreconf $@ --fail-missing
Eric Butlerd11a5c12012-08-14 20:56:26 -070011
Holger Hans Peter Freythercf5b08b2013-02-13 20:12:36 +010012override_dh_strip:
13 dh_strip --dbg-package=libosmo-abis-dbg
14
Eric Butlerd11a5c12012-08-14 20:56:26 -070015override_dh_autoreconf:
16 echo $(VERSION) > .tarball-version
17 dh_autoreconf