blob: e889ba6fbe622ac5d18739a6f36eda6f9b7bf680 [file] [log] [blame]
Pau Espin Pedrola6eda5a2021-11-16 14:18:45 +01001libosmo-abis (1.2.0) unstable; urgency=medium
2
3 [ Keith ]
4 * Configure E1 pcap file per line
5 * Log TRAU FSM at INFO not NOTICE
6 * Fix up vty 'show' commands for E1 line/timeslots
7
8 [ Harald Welte ]
9 * ipa: Introduce support for user-specific DSCP and priority
10 * e1_input: Allow (vty) configuration of IP DSCP and socket priority
11 * trau: Introduce osmo_rtp_socket_set_priority()
12
13 [ Philipp Maier ]
14 * ipaccess: do not block ipaccess_line_update on failure
15
16 [ Pau Espin Pedrol ]
17 * Use new stat item/ctr getter APIs
18 * osmo_ortp: Fix seqno reset to 0 upon ssrc_changed
19 * e1_input: Fix line not removed from e1inp_line_list when freed
20 * e1_input: Document e1inp_line_create()
21 * ipaccess: Allow reconfiguring the ipa line during line_update()
22 * ipaccess: e1inp_ipa_bts_rsl_connect: Fix memleak recreating ipa_client_conn
23 * e1inp_input: Fix e1inp_line_clone removing original line from global list when freed
24
25 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 16 Nov 2021 14:18:45 +0100
26
Harald Welte4aea11b2021-02-24 09:32:29 +010027libosmo-abis (1.1.1) unstable; urgency=medium
28
29 * attempt to fix RPM spec file after recent soversion bump
30
31 -- Harald Welte <laforge@osmocom.org> Wed, 24 Feb 2021 09:32:29 +0100
32
Pau Espin Pedrolde169192021-02-23 16:21:49 +010033libosmo-abis (1.1.0) unstable; urgency=medium
34
35 [ Harald Welte ]
36 * trau_frame: New API
37 * trau_frame: Introduce support for Downlink Time Alignment
38 * osmo_trau_frame_encode(): Check for sufficiently sized output buffer
39 * Add new TRAU frame sync code
40 * TRAU frame RTP conversion
41 * Add 'trau2rtp' demo program illustrating the use of new TRAU code
42 * Add missing build dependency to libosmocodec-dev
43 * trau_frame: Fix computation of odd parity while encoding HR frames
44 * trau_sync: Check return value of osmo_fsm_register()
45 * trau_frame: Add missing break statement in osmo_trau_frame_encode()
46 * Fix RPM spec file (.so.6 -> .so.9)
47 * debian: Build libosmo-abis with osmo-e1d support
48 * Revert "debian: Build libosmo-abis with osmo-e1d support"
49 * Use OSMO_FD_* instead of deprecated BSC_FD_*
50 * Use osmo_fd_setup() wherever applicable
51 * e1_input: Support I.460 timeslot type
52 * osmo_ortp: Don't print ERROR message for every missing RTP frame
53 * migrate to osmo_fd_{read,write}_{enable,disable}()
54
55 [ Philipp Maier ]
56 * trau_sync: prevent false positive synchronization on startup
57 * trau_sync: make sync pattern configurable
58 * vty: add attributes to VTY commands indicating when they apply
59
60 [ Vadim Yanitskiy ]
61 * debian/control: change maintainer to the Osmocom team / mailing list
62 * vty: use install_lib_element() and install_lib_element_ve()
63 * cosmetic: fix spelling in logging messages: existAnt -> existEnt
64 * ipaccess: fix verbosive logging in __handle_ts1_write()
65
66 [ Pau Espin Pedrol ]
67 * tests: Disable stderr log color in trau_sync_test
68 * contrib/jenkins: Enable parallel make in make distcheck
69 * ipaccess: Use LOGPITS macro in __handle_ts1_write
70 * ipaccess: Fix log error printed on wrong conditional branch
71 * ipaccess: Fix wrong assertion in ipaccess_drop() when used by BTS code
72 * tests: trau_sync: Explicitly drop category from log
73 * gitignore: Ignore autofoo files *~
74
75 [ Oliver Smith ]
76 * configure.ac: set -std=gnu11
77
78 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 23 Feb 2021 16:21:49 +0100
79
Harald Welte2a8a34c2020-08-13 12:09:39 +020080libosmo-abis (1.0.0) unstable; urgency=medium
81
82 [ Neels Hofmeyr ]
83 * add/clean big-endian packed structs (struct_endianess.py)
84
85 [ Harald Welte ]
86 * dahdi: Don't use perror() directly, use osmocom logging instead
87 * introduce and use logging macros with context on E1 line / timeslot
88 * e1d: Use HAVE_E1D in C source, not ENABLE_E1D
89 * e1d: add missing forward-declaration of e1inp_e1d_init()
90 * e1d: Don't use perror() directly, use osmocom logging instead
91 * e1d: Remove EXCEPTFD handling
92 * e1d: Remove bogus vty_show function.
93 * e1d: Use line->port_nr to specify e1d interface/line
94 * e1d: Use LOGPIL/LOGPITS logging macros to give context
95 * e1d: Don't connect to e1d at program start time
96 * e1d: Implement varions non-LAPD timeslot modes
97 * Add rtp_test to show the double-bind bug of OS#4444
98 * ortp: disable SO_REUSEADDR + SO_REUSEPORT
99 * subchan_demux: Use 'ubit_t' for unpacked bit buffer; use const
100 * trau_frame: use 'ubit_t' for unpacked bits
101 * subchan_demux: Use ubit_t where appropriate
102 * trau_frame.h: Fix definition of TRAU_FT_OM_UP
103 * Fix subchan_demux_test compiler warning on some gcc versions
104 * trau_frame: Fix AMR frame decoding
105 * lapd: Always print context information when logging
106 * fix compilation with --enable-e1d
107 * lapd: Replace magic numbers with #defines
108 * input/lapd.c: Enlarge message buffers for DL-SAP primitives
109 * input/dahdi.c: Don't simply read beyond end of msgb
110 * subchan_demux: Fix out-of-bounds write
111 * e1d: Add new osmo_e1dp_client_ts_open() argument
112 * e1d: Fix compilation after I4a088f91f23aaad05c5ab84a4783c1915d85aca6
113 * contrib/jenkins.sh: Test builds with --enable-e1d
114 * dahdi: Use osmo_revbytebits_buf() instead of local flip table
115 * input/e1d: Fix support for TRAU slots
116 * input/e1d: Add missing "RAW" timeslot support
117 * e1_input_vty: Fix VTY help strings
118
119 [ Sylvain Munaut ]
120 * e1d: Initial osmo-e1d support
121 * e1_input: Allow to change the pcap fd and/or unset it
122 * e1_input: Add VTY command to enable PCAP debug output
123
124 [ Oliver Smith ]
125 * ipaccess.c: line_already_initialized: int -> bool
126 * osmo_ortp: add osmo_rtp_socket_set_dscp()
127 * contrib: import RPM spec
128 * contrib: integrate RPM spec
129 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
130 * src/input/ipaccess.c: set TCP_NODELAY
131
132 [ Eric Wild ]
133 * add ipa ping/pong keepalive for OML/RSL links between bts and bsc
134
135 [ Eric ]
136 * configure.ac: fix libtool issue with clang and sanitizer
137
138 [ Pau Espin Pedrol ]
139 * e1_input: refcount inc line during e1_sign_link_create, not during line update
140 * ipaccess.c: Drop repeated ipaccess_keepalive_fsm_cleanup in write error path
141 * ipaccess: Fix log formatting of RESP_ID IPA attributes
142 * cosmetic: e1_input.h: Fix trailing whitespace
143 * e1_input: Use osmo_use_count in e1inp_line
144 * ipaccess: Drop e1inp_line reference in ipacess_drop()
145 * ipacces: Fix e1inp_line reference put in ipaccess_close
146 * ipaccess: Set bfd->data to NULL before releasing its reference
147 * ipaccess_recvmsg: Clean up release steps upon error condition
148 * ipaccess_recvmsg: Assert the new bfd from new line differs from the old one
149 * ipaccess_recvmsg: Untangle code updating line
150 * cosmetic: lapd: Fix trailing whitespace
151 * lapd: Use lapd_dl_init2 instead of deprecated lapd_dl_init
152 * tests: Use API e1inp_line_put2 instead of deprecated e1inp_line_put
153 * ipaccess: Fix use-after-free in ipaccess_drop()
154
155 -- Harald Welte <laforge@osmocom.org> Thu, 13 Aug 2020 12:09:39 +0200
156
Pau Espin Pedrolc313d442020-01-02 20:53:32 +0100157libosmo-abis (0.8.0) unstable; urgency=medium
158
159 [ Alexander Couzens ]
160 * ipa: ipa_server_link_close() add checks of link state
161
162 [ Pau Espin Pedrol ]
163 * ipa: Allow setting local addr and port for struct ipa_client_conn
164
165 [ Harald Welte ]
166 * dahdi: Use ioctl(DAHDI_SPECIFY) instead of legacy /dev/dahdi/%u
167 * Enable DAHDI support by default; require --disable-dahdi otherwise
168
169 [ Vadim Yanitskiy ]
170 * input/ipaccess.c: propagate errors from ipa_parse_unitid()
171 * input/ipaccess.c: fix debug message on receipt of IPAC_MSGT_ID_GET
172 * e1_input.c: make reference counting get() / put() more verbose
173 * input/ipa_keepalive.c: make sure IPA keepalive FSM is registered
174
175 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:53:32 +0100
176
Harald Welte30249a12019-07-21 21:32:08 +0200177libosmo-abis (0.7.0) unstable; urgency=medium
178
179 [ Max ]
180 * Set local IP in ipa_server_link properly
181 * Log peer's port in accept callback
182
183 [ Harald Welte ]
184 * ipa: Make ipa_server_conn_destroy() re-entrant
185 * Add IPA keep-alive FSM implementation
186 * ipa_keepalive_fsm: Fix OSMO_IPA_KA_E_STOP allstate event
187 * ipa_keepalive_fsm: Suppress error messages for INIT -> INIT transition
188 * ipaccess.c: Avoid calling close(-1) on error path
189
190 [ Oliver Smith ]
191 * tests: use -no-install libtool flag to avoid ./lt-* scripts
192 * contrib/jenkins.sh: run "make maintainer-clean"
193
194 [ Sylvain Munaut ]
195 * rtp: Add 'autoconnect' feature to the osmo_rtp_socket
196
197 [ Eric Wild ]
198 * ipaccess: allow tcp keepalive for ipa clients
199 * add TCP_USER_TIMEOUT to keepalive
200 * extend the ipa keepalive fsm
201
202 [ Debian Mobcom Maintainers ]
203 * spelling
204
205 -- Harald Welte <laforge@gnumonks.org> Sun, 21 Jul 2019 21:32:08 +0200
206
Harald Welte176a1fb2019-01-19 22:20:47 +0100207libosmo-abis (0.6.0) unstable; urgency=medium
208
209 [ Neels Hofmeyr ]
210 * fix strncpy bugs in ipaccess.c, ipa_proxy.c
211 * ipa: don't crash on missing IPA ID GET message
212
213 [ Harald Welte ]
214 * Migrate from ipa_ccm_idtag_parse to ipa_ccm_id_resp_parse()
215 * debian/rules: Don't overwrite .tarball-version
216
217 [ Pau Espin Pedrol ]
218 * ipaccess: Use osmo_fd_setup to set up callbacks
219 * ipaccess_rcvmsg: Fix bug introduced in previous commit
220 * ipa: Simplify code in ipa_client_read
221 * ipa: Simplify code in ipa_server_conn_read
222 * ipa: Allow signalling fd destroyed in ipa_client_read
223 * ipa: Allow signalling fd destroyed in ipa_server_conn_read
224 * ipaccess: Return -EBADF when closing socket in ipaccess_bts_read_cb
225 * ipaccess: Allow passing return code in e1inp_line_ops->sign_link()
226 * debian: Fix libosmoabis soname package version
227 * debian: Conflict libosmoabis6 with libosmoabis5
228 * ipacces: Log correct trx_nr during IPA GET
229 * ipaccess: Simplify handling of ipaccess e1line ts
230 * e1_input.h: Set correct type for input_signal_data->link_type
231 * osmo_ortp: Log domain and fix strings without endl char
232
233 [ Stefan Sperling ]
234 * Properly deal with sockaddr_un socket path length limitations.
235 * ensure unix socket paths are NUL-terminated for bind/connect
236
237 -- Harald Welte <laforge@gnumonks.org> Sat, 19 Jan 2019 22:20:46 +0100
238
Pau Espin Pedrol026ff452018-07-27 18:15:19 +0200239libosmo-abis (0.5.1) unstable; urgency=medium
240
241 [ Pau Espin Pedrol ]
242 * ipaccess: ipaccess_rcvmsg: Drop unneeded memcpy
243 * ipaccess: Avoid using released line and bfd in ipaccess_fd_cb
244 * e1_input.c: Replace '.' in counter names with ':'
245
246 [ Stefan Sperling ]
247 * fix double-free/use-after-free of pointers in struct e1inp_line
248
249 [ Philipp Maier ]
250 * ortp: make sure the ortp scheduler is started
251 * ortp: reset rtp session on SSRC changes
252 * ortp: detect ssrc changes immediately
253 * ortp: enable scheduled mode on rtp socket creation
254 * Revert "ortp: make sure the ortp scheduler is started"
255 * Revert "ortp: enable scheduled mode on rtp socket creation"
256
257 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 18:15:18 +0200
258
Pau Espin Pedrol7b89f122018-05-03 16:12:04 +0200259libosmo-abis (0.5.0) unstable; urgency=medium
260
261 [ Max ]
262 * Use value string check from osmo-ci
263 * cosmetic: update ipaccess_bts_handle_ccm()
264 * IPA: log remote address
265
266 [ Neels Hofmeyr ]
267 * cosmetic: ipa.c: use msgb_dequeue(), drop local var
268 * jenkins: use osmo-clean-workspace.sh before and after build
269 * vty: skip installing cmds now always installed by default
270 * add --enable-sanitize config option
271 * configure: add --enable-werror
272 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
273
274 [ Alexander Couzens ]
275 * debian/rules: show testsuite.log when tests are failing
276 * unixsocket: fix a potential string overflow
277
278 [ Harald Welte ]
279 * debian/copyright: fix upstream-name
280 * Add SPDX-License-Identifier to all source files
281 * Add a new osmo_rtp_set_source_desc() function to set the RTCP SDES items
282 * debian/control: Fix Vcs-Browser
283
284 [ Pau Espin Pedrol ]
285 * contrib: jenkins.sh: Disable doxygen in libosmocore build
286 * e1_input.h: Remove dead declaration of unexistent API ipaccess_setup
287 * configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
288 * use osmo_init_logging2
289 * git-version-gen: Check first for new tag format
290
291 [ Stefan Sperling ]
292 * preserve 'when' flags of new osmo_fd in ipaccess_rcvmsg()
293
294 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:12:04 +0200
295
Max7f17b8c2017-08-25 16:09:48 +0200296libosmo-abis (0.4.0) unstable; urgency=medium
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200297
298 * Move forward towards a new release.
Max7f17b8c2017-08-25 16:09:48 +0200299 * libosmo-abis API change major: add parameter to struct
300 input_signal_data
301 * libosmo-trau API change major: add parameters to rx_cb()
302 callack in osmo_ortp.h
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200303
Max7f17b8c2017-08-25 16:09:48 +0200304 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 25 Aug 2017 16:09:46 +0200
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200305
306libosmo-abis (0.3.2) unstable; urgency=medium
Holger Hans Peter Freyther3cef39b2015-11-03 09:40:00 +0100307
308 * Bump so version to re-link libosmovty
309
310 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:42:01 +0100
311
312libosmo-abis (0.3.1) unstable; urgency=medium
Holger Hans Peter Freyther2f0dd0c2015-01-18 19:27:07 +0100313
314 * New upstream release of libosmo-abis
315
316 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:26:40 +0100
317
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200318libosmo-abis (0.3.0) unstable; urgency=medium
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200319
320 * New upstream release of libosmo-abis
321
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200322 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:39 +0200
323
324libosmo-abis (0.2.0) unstable; urgency=medium
325
326 * New upstream release of libosmo-abis
327
328 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:19 +0200
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200329
330libosmo-abis (0.1.6) unstable; urgency=medium
Holger Hans Peter Freytherf6415ea2014-01-20 10:33:52 +0100331
332 * New upstream release of libosmo-abis
333
334 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:33:36 +0100
335
Holger Hans Peter Freyther91de2d02013-12-12 11:47:39 +0100336libosmo-abis (0.1.5+git1) unstable; urgency=low
337
338 * Rebuild 0.1.5 with the right libosmocore depedency
339
340 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 12 Dec 2013 11:47:01 +0100
341
Holger Hans Peter Freyther2dfcd9e2012-11-06 13:34:34 +0100342libosmo-abis (0.1.4) unstable; urgency=low
343
344 * New upstream release
345
346 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 06 Nov 2012 13:33:45 +0100
347
Eric Butlerd11a5c12012-08-14 20:56:26 -0700348libosmo-abis (0.1.3+git3-1) precise; urgency=low
349
350 * Fix version issue.
351
352 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
353
Eric Butler91ffa2b2012-08-14 18:07:48 -0700354libosmo-abis (0.1.3+git3) precise; urgency=low
355
356 Created new Ubuntu package.
357
358 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 13:00:18 -0700