blob: 2c615db67c061b5fb83b0972a663c1aa608344b5 [file] [log] [blame]
Harald Welte95fac3a2018-08-26 10:07:21 +02001#!/usr/bin/make -f
2
Oliver Smith71cfc2b2019-11-28 11:21:12 +01003# Uncomment this to turn on verbose mode.
4#export DH_VERBOSE=1
5
6DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
7DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
8VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
9
10export DEB_BUILD_MAINT_OPTIONS = hardening=+all
11
12export DEB_LDFLAGS_MAINT_STRIP = -Wl,-Bsymbolic-functions
13
14
Harald Welte95fac3a2018-08-26 10:07:21 +020015%:
16 dh $@
Oliver Smith71cfc2b2019-11-28 11:21:12 +010017
18override_dh_autoreconf:
19 cd host && dh_autoreconf