blob: e6cac87b5802e5f04f35f857f2668f2ae2322377 [file] [log] [blame]
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +01001#!/usr/bin/make -f
2
Max833e97e2017-01-24 15:14:32 +01003export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +01004
5%:
6 dh $@ --with autoreconf
7
8override_dh_shlibdeps:
9 dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
10
Harald Welte96f0f2c2018-04-28 14:18:23 +020011override_dh_auto_configure:
Oliver Smithf1ce0e72024-03-18 11:34:57 +010012 dh_auto_configure -- \
13 --enable-manuals \
14 --with-systemdsystemunitdir=/lib/systemd/system \
15 --with-ipc \
16 --with-lms \
17 --with-uhd \
18 --with-usrp1 \
19 $(NULL)
Harald Welte96f0f2c2018-04-28 14:18:23 +020020
Holger Hans Peter Freytherd17b1892016-03-18 20:13:23 +010021override_dh_strip:
22 dh_strip --dbg-package=osmo-trx-dbg
Oliver Smith76a50132019-05-22 14:10:01 +020023
24# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
25override_dh_compress:
26 dh_compress -X.pdf