blob: 84874bc99d4d859d9a022f4691ef6d96b476380f [file] [log] [blame]
Oliver Smith81022c82020-05-14 11:51:40 +02001#
2# spec file for package osmo-remsim
3#
4# Copyright (c) 2018, Martin Hauke <mardnh@gmx.de>
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18%define sover 1
19Name: osmo-remsim
20Version: 0.2.2.86
21Release: 0
22Summary: Osmocom remote SIM software suite
23License: GPL-2.0-or-later
24Group: Productivity/Telephony/Servers
25URL: https://projects.osmocom.org/projects/osmo-remsim
26Source: %{name}-%{version}.tar.xz
27BuildRequires: autoconf
28BuildRequires: automake
29BuildRequires: libcsv-devel
30BuildRequires: libtool
31BuildRequires: pkgconfig
32BuildRequires: systemd-rpm-macros
33BuildRequires: pkgconfig(libasn1c) >= 0.9.30
34BuildRequires: pkgconfig(libosmoabis)
35BuildRequires: pkgconfig(libosmocore) >= 0.11.0
36BuildRequires: pkgconfig(libosmogsm) >= 0.11.0
37BuildRequires: pkgconfig(libosmosim)
38BuildRequires: pkgconfig(libpcsclite)
39BuildRequires: pkgconfig(libulfius)
40BuildRequires: pkgconfig(libusb-1.0)
41BuildRequires: pkgconfig(libosmousb)
42BuildRequires: pkgconfig(libosmo-simtrace2)
43%{?systemd_ordering}
44
45%description
46osmo-remsim is a suite of software programs enabling physical/geographic
47separation of a cellular phone (or modem) on the one hand side and the
48SIM/USIM/ISIM card on the other side.
49
50Using osmo-remsim, you can operate an entire fleet of modems/phones, as
51well as banks of SIM cards and dynamically establish or remove the
52connections between modems/phones and cards.
53
54So in technical terms, it behaves like a proxy for the ISO 7816 smart
55card interface between the MS/UE and the UICC/SIM/USIM/ISIM.
56
57While originally designed to be used in context of cellular networks,
58there is nothing cellular specific in the system. It can therefore also
59be used with other systems that use contact based smart cards according
60to ISO 7816. Currently only the T=0 protocol with standard
61(non-extended) APDUs is supported. Both T=1 and extended APDU support
62can easily be added as a pure software update, should it be required at
63some future point.
64
65%package -n libosmo-rspro%{sover}
66Summary: Osmocom Remote SIM - Shared Library
67License: GPL-2.0-or-later
68Group: System/Libraries
69
70%description -n libosmo-rspro%{sover}
71libosmo-rsrpo is an utility library for encoding/decoding the ASN.1 BER
72based RSPRO (Remote SIM Protocol) protocol used between the osmo-remsim
73programs.
74
75%package -n libosmo-rspro-devel
76Summary: Osmocom Remote SIM - Shared Library Development Haders
77License: GPL-2.0-or-later
78Group: Development/Libraries/C and C++
79Requires: libosmo-rspro%{sover} = %{version}
80
81%description -n libosmo-rspro-devel
82libosmo-rsrpo is an utility library for encoding/decoding the ASN.1 BER
83based RSPRO (Remote SIM Protocol) protocol used between the osmo-remsim
84programs.
85
86This subpackage contains libraries and header files for developing
87applications that want to make use of libosmo-rspro.
88
89%package -n osmo-remsim-server
90Summary: Osmocom Remote SIM - Central Server
91License: GPL-2.0-or-later
92Group: Productivity/Telephony/Servers
93
94%description -n osmo-remsim-server
95The remsim-server is the central element of a osmo-remsim deployment,
96it maintains a list of clients + bankds connected to it, as well as the
97dynamic SIM card mappings between them.
98
99%package -n osmo-remsim-bankd
100Summary: Osmocom Remote SIM - Bank Daemon
101License: GPL-2.0-or-later
102Group: Productivity/Telephony/Servers
103
104%description -n osmo-remsim-bankd
105The remsim-bankd is managing a bank of SIM card readers and their
106respective cards. It establishes a control connection to remsim-server
107and receives inbound connections from remsim-clients.
108
109%package -n osmo-remsim-client-st2
110Summary: Osmocom Remote SIM - Client for SIMtrace2
111License: GPL-2.0-or-later
112Group: Productivity/Telephony/Servers
113
114%description -n osmo-remsim-client-st2
115Description: Osmocom Remote SIM - Client for SIMtrace2 cardem firmware
116The remsim-client is managing a given phone/modem. It attaches to the
117'cardem' firmware of a SIMtrcace2 (or compatible, such as sysmoQMOD)
118hardware and forwards the SIM card communication to a remsim-bankd,
119under the control of remsim-server.
120
121%package -n osmo-remsim-client-shell
122Summary: Osmocom Remote SIM - Interactive Client
123License: GPL-2.0-or-later
124Group: Productivity/Telephony/Servers
125
126%description -n osmo-remsim-client-shell
127The remsim-client-shell is for manually interacting with a remote SIM
128card via remsim-bankd + remsim-server. It's mostly a test/debug tool.
129
130%package -n libifd-osmo-remsim-client0
131Summary: Osmocom Remote SIM Client - PC/SC driver
132License: GPL-2.0-or-later
133Group: Productivity/Telephony/Servers
134Requires: pcsc-lite
135
136%description -n libifd-osmo-remsim-client0
137This is an incarnation of osmo-remsim-client which can plug as ifd_handler
138driver into pcscd. This means you can use remote smart cards managed
139by osmo-remsim-server via normal PC/SC applications.
140
141%prep
142%setup -q
143
144%build
145echo "%{version}" >.tarball-version
146autoreconf -fi
147%configure \
148 --disable-static \
149 --with-systemdsystemunitdir=%{_unitdir}
150make V=1 %{?_smp_mflags}
151
152%install
153%make_install
154find %{buildroot} -type f -name "*.la" -delete -print
155
156%check
157make %{?_smp_mflags} check || find . -name testsuite.log -exec cat {} +
158
159%post -n libosmo-rspro%{sover} -p /sbin/ldconfig
160%postun -n libosmo-rspro%{sover} -p /sbin/ldconfig
161
162%pre -n osmo-remsim-bankd %service_add_pre osmo-remsim-bankd.service
163%post -n osmo-remsim-bankd %service_add_post osmo-remsim-bankd.service
164%preun -n osmo-remsim-bankd %service_del_preun osmo-remsim-bankd.service
165%postun -n osmo-remsim-bankd %service_del_postun osmo-remsim-bankd.service
166
167%pre -n osmo-remsim-client-st2 %service_add_pre osmo-remsim-client@.service
168%post -n osmo-remsim-client-st2 %service_add_post osmo-remsim-client@.service
169%preun -n osmo-remsim-client-st2 %service_del_preun osmo-remsim-client@.service
170%postun -n osmo-remsim-client-st2 %service_del_postun osmo-remsim-client@.service
171
172%pre -n osmo-remsim-server %service_add_pre osmo-remsim-server.service
173%post -n osmo-remsim-server %service_add_post osmo-remsim-server.service
174%preun -n osmo-remsim-server %service_del_preun osmo-remsim-server.service
175%postun -n osmo-remsim-server %service_del_postun osmo-remsim-server.service
176
177%files -n libosmo-rspro%{sover}
178%license COPYING
179%doc README.md
180%{_libdir}/libosmo-rspro.so.%{sover}*
181
182%files -n libosmo-rspro-devel
183%{_includedir}/osmocom
184%dir %{_includedir}/osmocom/rspro
185%{_includedir}/osmocom/rspro/rspro_client.h
186%{_libdir}/libosmo-rspro.so
187%{_libdir}/pkgconfig/libosmo-rspro.pc
188
189%files -n osmo-remsim-server
190%{_bindir}/osmo-remsim-server
191%{_unitdir}/osmo-remsim-server.service
192
193%files -n osmo-remsim-bankd
194%{_bindir}/osmo-remsim-bankd
195%{_unitdir}/osmo-remsim-bankd.service
196%config %{_sysconfdir}/default/osmo-remsim-bankd
197
198%files -n osmo-remsim-client-shell
199%{_bindir}/osmo-remsim-client-shell
200
201%files -n osmo-remsim-client-st2
202%{_bindir}/osmo-remsim-client-st2
203%{_unitdir}/osmo-remsim-client*
204%config %{_sysconfdir}/default/osmo-remsim-client*
205
206%files -n libifd-osmo-remsim-client0
207%dir %{_libdir}/readers/
208%dir %{_libdir}/readers/libifd-osmo-remsim-client.bundle
209%dir %{_libdir}/readers/libifd-osmo-remsim-client.bundle/Contents
210%{_libdir}/readers/libifd-osmo-remsim-client.bundle/Contents/PkgInfo
211%dir %{_libdir}/readers/libifd-osmo-remsim-client.bundle/Contents/Linux
212%{_libdir}/readers/libifd-osmo-remsim-client.bundle/Contents/Linux/libifd_remsim_client.so*
213%config %{_sysconfdir}/reader.conf.d/osmo-remsim-client-reader_conf
214
215%changelog