blob: ac9c6a8d607dd59258ab4abbb5dea367d80f80b5 [file] [log] [blame]
Harald Welte99278b12019-01-21 19:03:52 +01001osmo-pcu (0.6.0) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * debian/rules: Don't overwrite .tarball-version
5 * gprs_rlcmac_received_lost(): Fix regression / uninitialized now_tv
6 * initial checkin of manuals to public repo
7 * Add link to Asciidoc source code of manual
8 * Initial place-holder for the new Gb/IP interface documentation
9 * Gb message sequence chart: flip sides (SGSN should be right)
10 * Gb message sequence chart: Add notion of PCU unix domain socket
11 * Gb: Various spelling fixes
12 * gb: Some language improvements, formatting changes
13 * consistently use '3GPP TS' not sometimes 3GPP TS and sometimes TS.
14 * gb/NS: Clarify the language regarding the UDP port numbers / socket
15 * vty-ref: Update URI of docbook 5.0 schema
16
17 [ Pau Espin Pedrol ]
18 * Cleanup of systemd service files
19 * configure.ac: Set CXXFLAGS during --enable-sanitize
20 * Install systemd services with autotools
21 * Move examples/ to doc/examples/
22 * Install osmo-pcu.cfg to docdir/examples
23 * Allow easily disabling GFDL references
24
25 [ Stefan Sperling ]
26 * check for overlong unix socket paths
27
28 [ Max ]
29 * deb: add missing copyright file
30 * OsmoPCU: fix Gb documentation front page
31 * OsmoPCU: expand NS documentation
32 * OsmoPCU: expand BSSGP documentation
33 * OsmoPCU: add MSC chart
34
35 [ Neels Hofmeyr ]
36 * Importing history from osmo-gsm-manuals.git
37 * make clean: also remove generated image files
38 * add 'make check' target
39 * fix 'make clean': shell glob, ignore failure
40 * refactor Makefile build rules, don't use the FORCE
41
42 [ Jonathan Brielmaier ]
43 * fix various typos across all manuals
44
45 [ Philipp ]
46 * configuration: fixing typos
47
48 [ Alexander Couzens ]
49 * OsmoPCU: add rate counter documentation
50
51 [ Daniel Willmann ]
52 * Change OpenBSC mentions to OsmoBSC where applicable
53
54 [ Oliver Smith ]
55 * build manuals moved here from osmo-gsm-manuals.git
56 * Fix DISTCHECK_CONFIGURE_FLAGS override
57 * contrib/jenkins.sh: build and publish manuals
58 * contrib: fix makedistcheck with disabled systemd
59
60 -- Harald Welte <laforge@gnumonks.org> Mon, 21 Jan 2019 19:03:52 +0100
61
Pau Espin Pedrol448750e2018-07-27 21:56:39 +020062osmo-pcu (0.5.1) unstable; urgency=medium
63
64 [ Harald Welte ]
65 * Don't register SIGHUP handler without actually handling SIGHUP
66
67 [ Pau Espin Pedrol ]
68 * tbf: Fix memset(0) on object with no trivial copy-assignment
69 * rlc: Fix memset(0) on object with no trivial copy-assignment
70 * jenkins.sh: use flag --enable-werror for sysmo and none
71 * tbf: Use incrementing id for rate_ctr_group_alloc
72 * tbf: Replace '.' in counter names with ':'
73
74 [ Stefan Sperling ]
75 * fix a one-byte stack buffer overrun in osmo-pcu
76 * read monotonic clock with clock_gettime() instead of gettimeofday()
77 * fix time-delta calculations for measurement reports
78 * change log level of "DL packet loss" log messages
79 * check bssgp_tlv_parse() return code in gprs_bssgp_pcu_rcvmsg()
80
81 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 21:56:38 +0200
82
Pau Espin Pedrolf1a334b2018-05-03 16:20:01 +020083osmo-pcu (0.5.0) unstable; urgency=medium
84
85 [ Neels Hofmeyr ]
86 * jenkins: use osmo-clean-workspace.sh before and after build
87 * vty: skip installing cmds now always installed by default
88 * implement support for 3-digit MNC with leading zeros
89 * configure: add --enable-werror
90 * mslot_class: find_free_tfi(): use uint32_t to shift 1 << 31
91 * mslot_class: two more: use uint32_t to shift 1 << 31
92 * Revert "Use Timing Advance Index in UL assignments"
93 * Revert "Rewrite Packet Uplink Assignment"
94 * Revert "Rewrite Packet Downlink Assignment"
95 * configure: fix --enable-sysmocom-dsp and --with-sysmobts flags
96 * configure: properly quote CFLAGS in lc15 check
97 * Revert "Rewrite EGPRS Packet Uplink Assignment"
98 * use osmo_init_logging2() with proper talloc ctx
99
100 [ Minh-Quang Nguyen ]
101 * PCU: Fix TA adjustment
102 * PCU: display TA information in TBF stats
103
104 [ Max ]
105 * Remove unused parameter
106 * Move multislot table to separate file
107 * Replace '.' in counter names with ':'
108 * Fix compiler warning
109 * TBF: log timer override
110 * TBF: fix compiler warning in test
111 * TBF: expand timer logging
112 * vty: print class and TBFs for each MS
113 * DL window: constify resend_needed() function
114 * TBF: move EGPRS enablement into (U|D)L-TBF
115 * TBF-DL: fix misleading idle time check
116 * TBF: remove unused variable
117 * Remove unused includes and forward declarations
118 * Fix tests after rate_ctr change
119 * Introduce LOGTBF* for consistent logging
120 * TBF: implement independent T31xx timers
121 * TBF: add N3101 counter
122 * Fix warnings
123 * Add function to get max supported MS class
124 * Add --enable-sanitize configure option
125 * Enable sanitize for CI test
126 * Add tests for pcu_lsb()
127 * Add optional profiling support
128 * TBF: unify timer handling
129 * TBF: log timer invocation source
130 * TBF: bail out for unknown timers
131 * Fix llc_queue_size() type
132 * TBF-DL: mark rcvd_dl_ack() parameters as boolean
133 * window: move encoding into functions
134 * cosmetic: clarify coding scheme and puncturing
135 * Make TBF state private
136 * TBF: cleanup state flag handling
137 * Clarify RACH-related interfaces
138 * TBF-UL: add simpler test helper
139 * Avoid code duplication in TBF test
140 * TBF: move window parameters to UL/DL level
141 * TBF-DL: move priority computation into function
142 * TBF: unify EGPRS window calculation
143 * Don't access TBF internals in vty functions
144 * Fix jenkins.sh to match jenkins job axis filter
145 * Allocate global context for TypesTest
146 * Fix sanitizer build
147 * Rewrite EGPRS Packet Uplink Assignment
148 * Rewrite Packet Downlink Assignment
149 * Rewrite Packet Uplink Assignment
150 * Use Timing Advance Index in UL assignments
151 * Allow specifying sysmocom headers explicitly
152 * TBF: log source of state transitions
153 * jenkins.sh: Disable building doxygen for deps
154 * Set V_N and V_B to known initial state
155 * TBF: add dedicated log categories
156 * TBF: make UL/DL state internal
157 * TBF: make UL ack state internal
158 * TBF: make poll state internal
159 * TBF: adjust test log levels
160 * Add tests for find_multi_slots()
161 * AllocTest: adjust test_alloc_b()
162 * AllocTest: expand test output
163 * AllocTest: remove assumption on max MS class
164 * Add multislot classes from latest spec
165 * cosmetic: fix whitespace issue with include files
166 * TBF: decrease L1 logging verbosity in test
167 * TBF: override send function via linker option
168 * Simplify TS alloc: adjust allocator signatures
169 * Simplify TS alloc: fix allocation calls
170 * Simplify TS alloc: avoid TS reassignment
171 * Simplify TS alloc: use defines for constants
172 * Simplify TS alloc: adjust function signatures
173 * TS alloc: print suggested TRX on allocation errors
174 * Simplify TS alloc: internalize TRX check
175 * TBF: decrease logging verbosity for traffic
176 * TBF: add helpers for assignment type handling
177 * TBF: show assignment kind in vty
178 * vty: drop unused function
179 * RACH: improve single block detection
180 * TBF: move common test code into functions
181 * emu: use libosmocore definitions
182 * Use explicit type for pcu_lsb()
183 * Move paging generation into PDCH
184 * Move include guard to the top
185 * Update header includes
186 * Simplify TS alloc: split off RX mask computation
187 * Simplify TS alloc: separate capacity computation
188 * Simplify TS alloc: split allocation
189 * Simplify TS alloc: split USF/UL allocation
190 * Move PDCH-related functions into separate files
191 * Simplify TS alloc: don't use PDCH for free TFI
192 * Simplify TS alloc: constify max dl slot func
193 * TBF: make network counters internal
194 * Simplify TS alloc: move slot assignment
195 * Simplify TS alloc: move slot check into functions
196
197 [ Pau Espin Pedrol ]
198 * Print error cause of pcu socket connect failure
199 * gprs_bssgp_pcu.cpp: Comment unused function parse_ra_cap
200
201 [ Stefan Sperling ]
202 * Make osmo-pcu wait for BTS to become available at start-up time.
203 * improve documentation of Encoding::write_paging_request()
204
205 [ Alexander Couzens ]
206 * pcuif_proto.h: fix whitespaces and indention
207 * pcuif_proto: add version 8 features
208
209 [ Philipp Maier ]
210 * cosmetic: remove runaway semicolon
211 * pcu_l1_if: add frame number to log output
212 * tbf: add frame number to log output
213
214 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:20:00 +0200
215
Harald Welted34ec1b2017-10-29 12:03:05 +0100216osmo-pcu (0.4.0) unstable; urgency=medium
217
218 [ Holger Hans Peter Freyther ]
219 * Initial release.
220
221 [ Max ]
222 * Use value string check from osmo-ci
223 * cosmetic: tighten direct-phy related code
224 * Support receiving SI13 from BTS
225 * Move gsmtap and accounting into separate function
226 * cosmetic: convert explicit warnings to fixme/todo
227 * Assert valid CS
228 * TBF-DL: extend index check for RLC block copy
229 * TS alloc: properly count UL slots
230 * cosmetic: reformat multislot classes table
231
232 [ Philipp Maier ]
233 * gb: allow only packets from a specific SGSN
234
235 [ Harald Welte ]
236 * tests: Don't use private version of log_info but global gprs_log_info
237 * Call osmo_init_logging() before static BTS constructor
238 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
239 * Debian: Cosmetic changes to control file; add better Description
240 * Debian: print test results in case of failure + clean-up autotest
241 * Debian: migrate from DEB_BUILD_HARDENING to DEB_BUILD_MAINT_OPTIONS
242 * Debian: upgrade to debhelper 9 / Standards 3.9.8
243
244 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 12:03:05 +0100
245
Maxd78adfb2017-08-24 13:53:25 +0200246osmo-pcu (0.3.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +0200247
248 * Initial release.
249
250 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 01 Apr 2016 18:59:00 +0200