blob: 13e88c3686e676e083c3dcebe7989837d2934019 [file] [log] [blame]
Pau Espin Pedrol19b15a52019-08-07 21:09:53 +02001osmo-pcu (0.7.0) unstable; urgency=medium
2
3 [ Rafael Diniz ]
4 * Added support for daemonize to osmo-pcu.
5 * Fix help message formatting of osmo-pcu.
6
7 [ Max ]
8 * Don't install pcuif_proto.h header
9 * Move C include to proper place
10 * Add define for dummy burst string
11 * Add encoding tests for Immediate Assignment
12 * Clarify write_immediate_assignment() signature
13 * Restructure IA Rest Octets encoders
14 * Rewrite Packet Downlink Assignment
15 * Rewrite EGPRS Packet Uplink IA Rest Octets for MBA
16 * Rewrite EGPRS Packet Uplink IA Rest Octets for SBA
17 * MCS: internalize 'family' parameter
18 * EDGE tests: reduce code duplication
19 * MCS: remove dead code
20 * EDGE tests: remove no-op check
21 * Use msgb_eq_data_print() in tests
22 * Tighten lqual table limits check
23 * Enable LGLOBAL logging for TBF tests
24 * Log (M)CS UL update errors
25 * MCS: move Coding Scheme enum outside of class definition
26 * Make get_retx_mcs() into regular function
27 * MCS: remove unused function
28 * Debian: bump copyright year
29 * Use unique NSEI/BVCI/NSVCI in TBF tests
30 * MS store: move test helper to unit test
31 * Explicitly clean up BTS singleton
32 * MCS: move HeaderType enum outside of class definition
33 * MCS: use value_string for conversion
34 * TBF-DL: log MCS as string
35 * Fix TA index encoder
36 * MCS: move Mode enum outside of class definition
37 * MCS: add mcs_is_*() helpers
38 * MCS: add Channel Coding Command encoder
39 * Fix Channel Coding Command for MCS
40 * Rewrite Packet Uplink IA Rest Octets for MBA
41 * Rewrite Packet Uplink IA Rest Octets for SBA
42 * Use Timing Advance Index in UL assignments
43 * TBF: update MCS counters
44 * TBF-DL: cosmetic update for helper routines
45 * Update IA Rest Octets encoding
46 * TS alloc: expand tests log
47 * vty: add commands to show TBF of a certain kind
48 * Update MCS selection for retransmission
49 * cosmetic: use const pointer for bts_data
50 * Add test for MS mode and (M)CS settings
51 * Use libosmocore for IMSI parsing
52
53 [ Harald Welte ]
54 * Mark gprs_ns_reconnect() as static (not used outside of C file)
55 * Optionally Use the NS Sub-Network-Service (SNS) on Gb
56 * pcu_l1_if: Fix erroneous endian-swapping of the CellID
57 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
58 * gprs_debug: Use named initializers and explicit array indicies
59 * bssgp: Fix dead code: PDUT_STATUS can never reach this part
60
61 [ JF Dionne ]
62 * encoding: Fixes TMSI vs MI bit selection in repeated page info
63
64 [ Oliver Smith ]
65 * tests: use -no-install libtool flag to avoid ./lt-* scripts
66 * debian: create -doc subpackage with pdf manuals
67 * contrib/jenkins.sh: run "make maintainer-clean"
68
69 [ Daniel Willmann ]
70 * Include pdch.h in bts.h even if we're not compiling C++
71 * oc2g: Remove custom alarms
72 * oc2g: Change log type (Litecell15->Oc2g)
73 * jenkins.sh: Add oc2g build support
74 * manuals: Add script to regenerate vty/counter documentation
75 * manuals: Update VTY documentation
76
77 [ Jean-Francois Dionne ]
78 * Initial commit for OC-2G support.
79
80 [ Minh-Quang Nguyen ]
81 * OC-2G: Fix missing header
82 * OC-2G: Fix TA adjustment
83 * OC-2G: Always use positive TA information provided in PH-RA-IND
84
85 [ Alexander Couzens ]
86 * gprs_bssgp_pcu: make gprs_bssgp_ns_cb public
87 * gprs_bssgp_pcu: explicit allocate & initialize bssgp_nsi instance
88 * encoding: correct encoding of CRBB in ACK/NACK when not byte aligned
89 * encoding: use `/* */` for comments instead of `#if 0 #endif`
90 * egprs_rlc_compression: fix white spaces
91 * tests/BitcompTest: fix wording in log message
92 * rlc: replace int with uint16_t
93 * Encoding: drop struct gprs_rlcmac_bts* from all functions
94 * decompress_crbb: add length argument for search_runlen
95 * Encoding: write_packet_ack_nack_desc_egprs: don't use a reference for rest_bits
96 * bts.cpp: ensure left-shift operation does not exceed uint32_t
97 * Encoding: use uint16_t when interacting with the window object
98 * Encoding: ACK/NACK: always encode with length field present
99
100 [ Keith ]
101 * Cosmetic: Osmcoom -> Osmocom
102
103 [ Vadim Yanitskiy ]
104 * src/pcu_l1_if.cpp: fix: properly pass measurements from PCUIF
105 * gprs_bssgp_pcu_rx_dl_ud(): fix: BSSGP_IE_IMSI is optional
106 * gprs_bssgp_pcu.cpp: check return code of gsm48_mi_to_string()
107 * gprs_bssgp_pcu_rx_dl_ud(): use OSMO_IMSI_BUF_SIZE
108
109 [ Thorsten Alteholz ]
110 * fix spelling errors detected by lintian
111
112 [ Eric Wild ]
113 * ubsan: fix shift
114
115 [ Pau Espin Pedrol ]
116 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
117 * Require newer libosmocore to avoid compile failures
118
119 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:09:53 +0200
120
Harald Welte99278b12019-01-21 19:03:52 +0100121osmo-pcu (0.6.0) unstable; urgency=medium
122
123 [ Harald Welte ]
124 * debian/rules: Don't overwrite .tarball-version
125 * gprs_rlcmac_received_lost(): Fix regression / uninitialized now_tv
126 * initial checkin of manuals to public repo
127 * Add link to Asciidoc source code of manual
128 * Initial place-holder for the new Gb/IP interface documentation
129 * Gb message sequence chart: flip sides (SGSN should be right)
130 * Gb message sequence chart: Add notion of PCU unix domain socket
131 * Gb: Various spelling fixes
132 * gb: Some language improvements, formatting changes
133 * consistently use '3GPP TS' not sometimes 3GPP TS and sometimes TS.
134 * gb/NS: Clarify the language regarding the UDP port numbers / socket
135 * vty-ref: Update URI of docbook 5.0 schema
136
137 [ Pau Espin Pedrol ]
138 * Cleanup of systemd service files
139 * configure.ac: Set CXXFLAGS during --enable-sanitize
140 * Install systemd services with autotools
141 * Move examples/ to doc/examples/
142 * Install osmo-pcu.cfg to docdir/examples
143 * Allow easily disabling GFDL references
144
145 [ Stefan Sperling ]
146 * check for overlong unix socket paths
147
148 [ Max ]
149 * deb: add missing copyright file
150 * OsmoPCU: fix Gb documentation front page
151 * OsmoPCU: expand NS documentation
152 * OsmoPCU: expand BSSGP documentation
153 * OsmoPCU: add MSC chart
154
155 [ Neels Hofmeyr ]
156 * Importing history from osmo-gsm-manuals.git
157 * make clean: also remove generated image files
158 * add 'make check' target
159 * fix 'make clean': shell glob, ignore failure
160 * refactor Makefile build rules, don't use the FORCE
161
162 [ Jonathan Brielmaier ]
163 * fix various typos across all manuals
164
165 [ Philipp ]
166 * configuration: fixing typos
167
168 [ Alexander Couzens ]
169 * OsmoPCU: add rate counter documentation
170
171 [ Daniel Willmann ]
172 * Change OpenBSC mentions to OsmoBSC where applicable
173
174 [ Oliver Smith ]
175 * build manuals moved here from osmo-gsm-manuals.git
176 * Fix DISTCHECK_CONFIGURE_FLAGS override
177 * contrib/jenkins.sh: build and publish manuals
178 * contrib: fix makedistcheck with disabled systemd
179
180 -- Harald Welte <laforge@gnumonks.org> Mon, 21 Jan 2019 19:03:52 +0100
181
Pau Espin Pedrol448750e2018-07-27 21:56:39 +0200182osmo-pcu (0.5.1) unstable; urgency=medium
183
184 [ Harald Welte ]
185 * Don't register SIGHUP handler without actually handling SIGHUP
186
187 [ Pau Espin Pedrol ]
188 * tbf: Fix memset(0) on object with no trivial copy-assignment
189 * rlc: Fix memset(0) on object with no trivial copy-assignment
190 * jenkins.sh: use flag --enable-werror for sysmo and none
191 * tbf: Use incrementing id for rate_ctr_group_alloc
192 * tbf: Replace '.' in counter names with ':'
193
194 [ Stefan Sperling ]
195 * fix a one-byte stack buffer overrun in osmo-pcu
196 * read monotonic clock with clock_gettime() instead of gettimeofday()
197 * fix time-delta calculations for measurement reports
198 * change log level of "DL packet loss" log messages
199 * check bssgp_tlv_parse() return code in gprs_bssgp_pcu_rcvmsg()
200
201 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 21:56:38 +0200
202
Pau Espin Pedrolf1a334b2018-05-03 16:20:01 +0200203osmo-pcu (0.5.0) unstable; urgency=medium
204
205 [ Neels Hofmeyr ]
206 * jenkins: use osmo-clean-workspace.sh before and after build
207 * vty: skip installing cmds now always installed by default
208 * implement support for 3-digit MNC with leading zeros
209 * configure: add --enable-werror
210 * mslot_class: find_free_tfi(): use uint32_t to shift 1 << 31
211 * mslot_class: two more: use uint32_t to shift 1 << 31
212 * Revert "Use Timing Advance Index in UL assignments"
213 * Revert "Rewrite Packet Uplink Assignment"
214 * Revert "Rewrite Packet Downlink Assignment"
215 * configure: fix --enable-sysmocom-dsp and --with-sysmobts flags
216 * configure: properly quote CFLAGS in lc15 check
217 * Revert "Rewrite EGPRS Packet Uplink Assignment"
218 * use osmo_init_logging2() with proper talloc ctx
219
220 [ Minh-Quang Nguyen ]
221 * PCU: Fix TA adjustment
222 * PCU: display TA information in TBF stats
223
224 [ Max ]
225 * Remove unused parameter
226 * Move multislot table to separate file
227 * Replace '.' in counter names with ':'
228 * Fix compiler warning
229 * TBF: log timer override
230 * TBF: fix compiler warning in test
231 * TBF: expand timer logging
232 * vty: print class and TBFs for each MS
233 * DL window: constify resend_needed() function
234 * TBF: move EGPRS enablement into (U|D)L-TBF
235 * TBF-DL: fix misleading idle time check
236 * TBF: remove unused variable
237 * Remove unused includes and forward declarations
238 * Fix tests after rate_ctr change
239 * Introduce LOGTBF* for consistent logging
240 * TBF: implement independent T31xx timers
241 * TBF: add N3101 counter
242 * Fix warnings
243 * Add function to get max supported MS class
244 * Add --enable-sanitize configure option
245 * Enable sanitize for CI test
246 * Add tests for pcu_lsb()
247 * Add optional profiling support
248 * TBF: unify timer handling
249 * TBF: log timer invocation source
250 * TBF: bail out for unknown timers
251 * Fix llc_queue_size() type
252 * TBF-DL: mark rcvd_dl_ack() parameters as boolean
253 * window: move encoding into functions
254 * cosmetic: clarify coding scheme and puncturing
255 * Make TBF state private
256 * TBF: cleanup state flag handling
257 * Clarify RACH-related interfaces
258 * TBF-UL: add simpler test helper
259 * Avoid code duplication in TBF test
260 * TBF: move window parameters to UL/DL level
261 * TBF-DL: move priority computation into function
262 * TBF: unify EGPRS window calculation
263 * Don't access TBF internals in vty functions
264 * Fix jenkins.sh to match jenkins job axis filter
265 * Allocate global context for TypesTest
266 * Fix sanitizer build
267 * Rewrite EGPRS Packet Uplink Assignment
268 * Rewrite Packet Downlink Assignment
269 * Rewrite Packet Uplink Assignment
270 * Use Timing Advance Index in UL assignments
271 * Allow specifying sysmocom headers explicitly
272 * TBF: log source of state transitions
273 * jenkins.sh: Disable building doxygen for deps
274 * Set V_N and V_B to known initial state
275 * TBF: add dedicated log categories
276 * TBF: make UL/DL state internal
277 * TBF: make UL ack state internal
278 * TBF: make poll state internal
279 * TBF: adjust test log levels
280 * Add tests for find_multi_slots()
281 * AllocTest: adjust test_alloc_b()
282 * AllocTest: expand test output
283 * AllocTest: remove assumption on max MS class
284 * Add multislot classes from latest spec
285 * cosmetic: fix whitespace issue with include files
286 * TBF: decrease L1 logging verbosity in test
287 * TBF: override send function via linker option
288 * Simplify TS alloc: adjust allocator signatures
289 * Simplify TS alloc: fix allocation calls
290 * Simplify TS alloc: avoid TS reassignment
291 * Simplify TS alloc: use defines for constants
292 * Simplify TS alloc: adjust function signatures
293 * TS alloc: print suggested TRX on allocation errors
294 * Simplify TS alloc: internalize TRX check
295 * TBF: decrease logging verbosity for traffic
296 * TBF: add helpers for assignment type handling
297 * TBF: show assignment kind in vty
298 * vty: drop unused function
299 * RACH: improve single block detection
300 * TBF: move common test code into functions
301 * emu: use libosmocore definitions
302 * Use explicit type for pcu_lsb()
303 * Move paging generation into PDCH
304 * Move include guard to the top
305 * Update header includes
306 * Simplify TS alloc: split off RX mask computation
307 * Simplify TS alloc: separate capacity computation
308 * Simplify TS alloc: split allocation
309 * Simplify TS alloc: split USF/UL allocation
310 * Move PDCH-related functions into separate files
311 * Simplify TS alloc: don't use PDCH for free TFI
312 * Simplify TS alloc: constify max dl slot func
313 * TBF: make network counters internal
314 * Simplify TS alloc: move slot assignment
315 * Simplify TS alloc: move slot check into functions
316
317 [ Pau Espin Pedrol ]
318 * Print error cause of pcu socket connect failure
319 * gprs_bssgp_pcu.cpp: Comment unused function parse_ra_cap
320
321 [ Stefan Sperling ]
322 * Make osmo-pcu wait for BTS to become available at start-up time.
323 * improve documentation of Encoding::write_paging_request()
324
325 [ Alexander Couzens ]
326 * pcuif_proto.h: fix whitespaces and indention
327 * pcuif_proto: add version 8 features
328
329 [ Philipp Maier ]
330 * cosmetic: remove runaway semicolon
331 * pcu_l1_if: add frame number to log output
332 * tbf: add frame number to log output
333
334 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:20:00 +0200
335
Harald Welted34ec1b2017-10-29 12:03:05 +0100336osmo-pcu (0.4.0) unstable; urgency=medium
337
338 [ Holger Hans Peter Freyther ]
339 * Initial release.
340
341 [ Max ]
342 * Use value string check from osmo-ci
343 * cosmetic: tighten direct-phy related code
344 * Support receiving SI13 from BTS
345 * Move gsmtap and accounting into separate function
346 * cosmetic: convert explicit warnings to fixme/todo
347 * Assert valid CS
348 * TBF-DL: extend index check for RLC block copy
349 * TS alloc: properly count UL slots
350 * cosmetic: reformat multislot classes table
351
352 [ Philipp Maier ]
353 * gb: allow only packets from a specific SGSN
354
355 [ Harald Welte ]
356 * tests: Don't use private version of log_info but global gprs_log_info
357 * Call osmo_init_logging() before static BTS constructor
358 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
359 * Debian: Cosmetic changes to control file; add better Description
360 * Debian: print test results in case of failure + clean-up autotest
361 * Debian: migrate from DEB_BUILD_HARDENING to DEB_BUILD_MAINT_OPTIONS
362 * Debian: upgrade to debhelper 9 / Standards 3.9.8
363
364 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 12:03:05 +0100
365
Maxd78adfb2017-08-24 13:53:25 +0200366osmo-pcu (0.3.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +0200367
368 * Initial release.
369
370 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 01 Apr 2016 18:59:00 +0200