blob: 0232b32fd38f69e656ac234d408c808005e4c9e7 [file] [log] [blame]
Oliver Smithd0156fd2020-05-14 11:50:38 +02001#
2# spec file for package osmo-pcu
3#
4# Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18
19Name: osmo-pcu
20Version: 0.8.0.126
21Release: 0
22Summary: Osmocom GPRS Packet Control Unit (PCU)
23License: GPL-2.0-only
24Group: Productivity/Telephony/Servers
25URL: https://osmocom.org/projects/osmopcu/wiki/OsmoPCU
26Source: %{name}-%{version}.tar.xz
27BuildRequires: autoconf
28BuildRequires: automake
29BuildRequires: gcc-c++
30BuildRequires: libtool
31BuildRequires: pkgconfig >= 0.20
32BuildRequires: systemd-rpm-macros
33BuildRequires: pkgconfig(libosmocore) >= 1.1.0
34BuildRequires: pkgconfig(libosmogb) >= 1.1.0
35BuildRequires: pkgconfig(libosmogsm) >= 1.1.0
36BuildRequires: pkgconfig(libosmovty) >= 1.1.0
37%{?systemd_requires}
38
39%description
40Osmocom PCU code (RLC/MAC/PCU) for OpenBTS and OsmoBTS.
41
42%prep
43%setup -q
44
45%build
46echo "%{version}" >.tarball-version
47autoreconf -fi
48%configure \
49 --enable-shared \
50 --disable-static \
51 --docdir=%{_docdir}/%{name} \
52 --with-systemdsystemunitdir=%{_unitdir}
53make %{?_smp_mflags}
54
55%install
56%make_install
57
58%preun
59%service_del_preun %{name}.service
60
61%postun
62%service_del_postun %{name}.service
63
64%pre
65%service_add_pre %{name}.service
66
67%post
68%service_add_post %{name}.service
69
70%check
71make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
72
73%files
74%license COPYING
75%doc README.md
76%doc %{_docdir}/%{name}/examples
77%{_bindir}/osmo-pcu
78%dir %{_sysconfdir}/osmocom
79%config(noreplace) %{_sysconfdir}/osmocom/osmo-pcu.cfg
80%{_unitdir}/%{name}.service
81
82%changelog