blob: 7623f7482cab1eb541b5130be8f050a1095c67d4 [file] [log] [blame]
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +02001#!/usr/bin/make -f
2
3DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
7#export DH_VERBOSE=1
8export DEB_BUILD_HARDENING=1
9
10
11%:
12 dh $@ --with=systemd --with autoreconf --fail-missing
13
14override_dh_strip:
15 dh_strip --dbg-package=osmo-pcu-dbg
16
17override_dh_autoreconf:
18 echo $(VERSION) > .tarball-version
19 dh_autoreconf