blob: e5df5c77a882c49246bebd7e006184f6fc501e36 [file] [log] [blame]
Pau Espin Pedrol448750e2018-07-27 21:56:39 +02001osmo-pcu (0.5.1) unstable; urgency=medium
2
3 [ Harald Welte ]
4 * Don't register SIGHUP handler without actually handling SIGHUP
5
6 [ Pau Espin Pedrol ]
7 * tbf: Fix memset(0) on object with no trivial copy-assignment
8 * rlc: Fix memset(0) on object with no trivial copy-assignment
9 * jenkins.sh: use flag --enable-werror for sysmo and none
10 * tbf: Use incrementing id for rate_ctr_group_alloc
11 * tbf: Replace '.' in counter names with ':'
12
13 [ Stefan Sperling ]
14 * fix a one-byte stack buffer overrun in osmo-pcu
15 * read monotonic clock with clock_gettime() instead of gettimeofday()
16 * fix time-delta calculations for measurement reports
17 * change log level of "DL packet loss" log messages
18 * check bssgp_tlv_parse() return code in gprs_bssgp_pcu_rcvmsg()
19
20 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 21:56:38 +0200
21
Pau Espin Pedrolf1a334b2018-05-03 16:20:01 +020022osmo-pcu (0.5.0) unstable; urgency=medium
23
24 [ Neels Hofmeyr ]
25 * jenkins: use osmo-clean-workspace.sh before and after build
26 * vty: skip installing cmds now always installed by default
27 * implement support for 3-digit MNC with leading zeros
28 * configure: add --enable-werror
29 * mslot_class: find_free_tfi(): use uint32_t to shift 1 << 31
30 * mslot_class: two more: use uint32_t to shift 1 << 31
31 * Revert "Use Timing Advance Index in UL assignments"
32 * Revert "Rewrite Packet Uplink Assignment"
33 * Revert "Rewrite Packet Downlink Assignment"
34 * configure: fix --enable-sysmocom-dsp and --with-sysmobts flags
35 * configure: properly quote CFLAGS in lc15 check
36 * Revert "Rewrite EGPRS Packet Uplink Assignment"
37 * use osmo_init_logging2() with proper talloc ctx
38
39 [ Minh-Quang Nguyen ]
40 * PCU: Fix TA adjustment
41 * PCU: display TA information in TBF stats
42
43 [ Max ]
44 * Remove unused parameter
45 * Move multislot table to separate file
46 * Replace '.' in counter names with ':'
47 * Fix compiler warning
48 * TBF: log timer override
49 * TBF: fix compiler warning in test
50 * TBF: expand timer logging
51 * vty: print class and TBFs for each MS
52 * DL window: constify resend_needed() function
53 * TBF: move EGPRS enablement into (U|D)L-TBF
54 * TBF-DL: fix misleading idle time check
55 * TBF: remove unused variable
56 * Remove unused includes and forward declarations
57 * Fix tests after rate_ctr change
58 * Introduce LOGTBF* for consistent logging
59 * TBF: implement independent T31xx timers
60 * TBF: add N3101 counter
61 * Fix warnings
62 * Add function to get max supported MS class
63 * Add --enable-sanitize configure option
64 * Enable sanitize for CI test
65 * Add tests for pcu_lsb()
66 * Add optional profiling support
67 * TBF: unify timer handling
68 * TBF: log timer invocation source
69 * TBF: bail out for unknown timers
70 * Fix llc_queue_size() type
71 * TBF-DL: mark rcvd_dl_ack() parameters as boolean
72 * window: move encoding into functions
73 * cosmetic: clarify coding scheme and puncturing
74 * Make TBF state private
75 * TBF: cleanup state flag handling
76 * Clarify RACH-related interfaces
77 * TBF-UL: add simpler test helper
78 * Avoid code duplication in TBF test
79 * TBF: move window parameters to UL/DL level
80 * TBF-DL: move priority computation into function
81 * TBF: unify EGPRS window calculation
82 * Don't access TBF internals in vty functions
83 * Fix jenkins.sh to match jenkins job axis filter
84 * Allocate global context for TypesTest
85 * Fix sanitizer build
86 * Rewrite EGPRS Packet Uplink Assignment
87 * Rewrite Packet Downlink Assignment
88 * Rewrite Packet Uplink Assignment
89 * Use Timing Advance Index in UL assignments
90 * Allow specifying sysmocom headers explicitly
91 * TBF: log source of state transitions
92 * jenkins.sh: Disable building doxygen for deps
93 * Set V_N and V_B to known initial state
94 * TBF: add dedicated log categories
95 * TBF: make UL/DL state internal
96 * TBF: make UL ack state internal
97 * TBF: make poll state internal
98 * TBF: adjust test log levels
99 * Add tests for find_multi_slots()
100 * AllocTest: adjust test_alloc_b()
101 * AllocTest: expand test output
102 * AllocTest: remove assumption on max MS class
103 * Add multislot classes from latest spec
104 * cosmetic: fix whitespace issue with include files
105 * TBF: decrease L1 logging verbosity in test
106 * TBF: override send function via linker option
107 * Simplify TS alloc: adjust allocator signatures
108 * Simplify TS alloc: fix allocation calls
109 * Simplify TS alloc: avoid TS reassignment
110 * Simplify TS alloc: use defines for constants
111 * Simplify TS alloc: adjust function signatures
112 * TS alloc: print suggested TRX on allocation errors
113 * Simplify TS alloc: internalize TRX check
114 * TBF: decrease logging verbosity for traffic
115 * TBF: add helpers for assignment type handling
116 * TBF: show assignment kind in vty
117 * vty: drop unused function
118 * RACH: improve single block detection
119 * TBF: move common test code into functions
120 * emu: use libosmocore definitions
121 * Use explicit type for pcu_lsb()
122 * Move paging generation into PDCH
123 * Move include guard to the top
124 * Update header includes
125 * Simplify TS alloc: split off RX mask computation
126 * Simplify TS alloc: separate capacity computation
127 * Simplify TS alloc: split allocation
128 * Simplify TS alloc: split USF/UL allocation
129 * Move PDCH-related functions into separate files
130 * Simplify TS alloc: don't use PDCH for free TFI
131 * Simplify TS alloc: constify max dl slot func
132 * TBF: make network counters internal
133 * Simplify TS alloc: move slot assignment
134 * Simplify TS alloc: move slot check into functions
135
136 [ Pau Espin Pedrol ]
137 * Print error cause of pcu socket connect failure
138 * gprs_bssgp_pcu.cpp: Comment unused function parse_ra_cap
139
140 [ Stefan Sperling ]
141 * Make osmo-pcu wait for BTS to become available at start-up time.
142 * improve documentation of Encoding::write_paging_request()
143
144 [ Alexander Couzens ]
145 * pcuif_proto.h: fix whitespaces and indention
146 * pcuif_proto: add version 8 features
147
148 [ Philipp Maier ]
149 * cosmetic: remove runaway semicolon
150 * pcu_l1_if: add frame number to log output
151 * tbf: add frame number to log output
152
153 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:20:00 +0200
154
Harald Welted34ec1b2017-10-29 12:03:05 +0100155osmo-pcu (0.4.0) unstable; urgency=medium
156
157 [ Holger Hans Peter Freyther ]
158 * Initial release.
159
160 [ Max ]
161 * Use value string check from osmo-ci
162 * cosmetic: tighten direct-phy related code
163 * Support receiving SI13 from BTS
164 * Move gsmtap and accounting into separate function
165 * cosmetic: convert explicit warnings to fixme/todo
166 * Assert valid CS
167 * TBF-DL: extend index check for RLC block copy
168 * TS alloc: properly count UL slots
169 * cosmetic: reformat multislot classes table
170
171 [ Philipp Maier ]
172 * gb: allow only packets from a specific SGSN
173
174 [ Harald Welte ]
175 * tests: Don't use private version of log_info but global gprs_log_info
176 * Call osmo_init_logging() before static BTS constructor
177 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
178 * Debian: Cosmetic changes to control file; add better Description
179 * Debian: print test results in case of failure + clean-up autotest
180 * Debian: migrate from DEB_BUILD_HARDENING to DEB_BUILD_MAINT_OPTIONS
181 * Debian: upgrade to debhelper 9 / Standards 3.9.8
182
183 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 12:03:05 +0100
184
Maxd78adfb2017-08-24 13:53:25 +0200185osmo-pcu (0.3.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +0200186
187 * Initial release.
188
189 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 01 Apr 2016 18:59:00 +0200