blob: ae85b6159c4d4b8b6ab675cef1534ac300f12574 [file] [log] [blame]
Pau Espin Pedrolb507e422020-01-03 19:40:02 +01001osmo-pcu (0.8.0) unstable; urgency=medium
2
3 [ Alexander Couzens ]
4 * tests: test encoding of egprs ul ack/nacks
5 * tbf_dl: add comments to the scheduler
6 * encoding: fix space, tabs
7
8 [ Vadim Yanitskiy ]
9 * osmobts_sock.cpp: pcu_sock_cb(): use libosmocore's socket API
10 * osmobts_sock.cpp: pcu_sock_read(): use stack buffer, not heap
11 * osmobts_sock.cpp: pcu_sock_read(): further simplify the code
12 * osmobts_sock.cpp: do not print the same debug message twice
13 * VTY: refactor pcu_vty_show_ms_all(): use show_ms()
14 * VTY: fix command 'show tbf all': properly filter TBFs
15 * BSSGP: do not reject SUSPEND ACK / NACK messages
16 * BSSGP: properly print BVCI for signalling messages (BVCI=0)
17 * tests/tbf: suspend warnings about the link quality measurements
18 * GprsMs::update_cs_ul(): clarify the meaning of old_link_qual
19 * gprs_bssgp_destroy(): fix memleak and NULL-pointer dereference
20 * PTCCH: implement basic message codec and API
21 * PTCCH: properly handle RTS.req for PCU_IF_SAPI_PTCCH
22 * pcuif_proto.h: extend RACH.ind with TRX / TS numbers
23 * PTCCH: properly handle RACH.ind for PCU_IF_SAPI_PTCCH
24 * VTY: add warning about changing PCU socket path at run-time
25 * VTY: cosmetic: use osmo_talloc_replace_string()
26
27 [ Pau Espin Pedrol ]
28 * cosmetic: tbf: Rename T and N arrays
29 * Use proper API osmo_timer_setup() to set up timer struct
30 * Introduce osmo_tdef infra and timer VTY commands
31 * bts.cpp: Fix osmo_tdef initialization on older g++ compilers
32 * Use osmo_tdef for BSSGP T1 and T2
33 * Use osmo_tdef to implement T3190
34 * tests: TbfTest: Unify stderr and stdout to ease debugging
35 * Use osmo_tdef to implement ms-idle-time
36 * Use osmo_tdef to implement dl-tbf-idle-time
37 * pdch.cpp: Refactor bitvec param passing in rcv_control_block
38 * pdch.cpp: Use pcu_l1_meas previously filled by lower layers
39 * cosmetic: fix whitespace
40 * Move out tbf subclasses from tbf.h to their own headers
41 * Move tbf_{dl,ul} child constructors to respective .cpp files
42 * tbf_dl: Setup m_llc_timer in constructor using osmocom API
43 * tbf_dl.cpp: Remove dup call to tbf_update_ms_class() in state GPRS_RLCMAC_WAIT_RELEASE
44 * vty: Fix osmo_tdef timers not listed in write config
45 * Log RACH Requests using GSMTAP
46 * Log AGCH and PCH blocks using GSMTAP
47 * pcu_l1_if.cpp: Fix GSMTAP Imm Assign PCH wrong encoding
48 * pcu_l1_if.cpp: Drop unneeded byte in Imm Ass PCH buffer
49 * pcu_l1_if.cpp: Imm Assign PCH: clarify size of different items
50 * pcu_l1_if.cpp: Replace value 23 with libosmocore's GSM_MACBLOCK_LEN
51 * Fix assertion hit upon CCCH Paging Request
52 * doc: vty: Update osmo-pcu_vty_reference.xml
53 * Clarify (M)CS related VTY attributes
54 * Remove dash from name used in VTY cmd prompt
55 * tbf_dl.cpp: Fix typo in log line
56 * pcu_l1_if: Check pag_req id_lv len fits buffer
57 * prs_bssgp_pcu.cpp: Mark priv funcs as static and remove trailing whitespace
58 * Fix trailing whitespace
59 * fix typo in log message
60 * Log BVCI PTP value upon msg recv
61 * Split identity_lv param into mi+mi_len
62
63 [ Oliver Smith ]
64 * doc: update generated VTY reference
65 * tbf_dl: make preemptive retransmission optional
66 * Forward ETWS Primary Notification to MS
67 * tests/app_info: fix compiling with older g++
68 * configure.ac: set C and C++ dialects
69
70 [ Harald Welte ]
71 * manual: Fix copy+paste error
72 * manual: Fix documentation missing "-D" command line option
73 * manual: Add missing documentation for '-i' command line option
74
75 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:40:02 +0100
76
Pau Espin Pedrol19b15a52019-08-07 21:09:53 +020077osmo-pcu (0.7.0) unstable; urgency=medium
78
79 [ Rafael Diniz ]
80 * Added support for daemonize to osmo-pcu.
81 * Fix help message formatting of osmo-pcu.
82
83 [ Max ]
84 * Don't install pcuif_proto.h header
85 * Move C include to proper place
86 * Add define for dummy burst string
87 * Add encoding tests for Immediate Assignment
88 * Clarify write_immediate_assignment() signature
89 * Restructure IA Rest Octets encoders
90 * Rewrite Packet Downlink Assignment
91 * Rewrite EGPRS Packet Uplink IA Rest Octets for MBA
92 * Rewrite EGPRS Packet Uplink IA Rest Octets for SBA
93 * MCS: internalize 'family' parameter
94 * EDGE tests: reduce code duplication
95 * MCS: remove dead code
96 * EDGE tests: remove no-op check
97 * Use msgb_eq_data_print() in tests
98 * Tighten lqual table limits check
99 * Enable LGLOBAL logging for TBF tests
100 * Log (M)CS UL update errors
101 * MCS: move Coding Scheme enum outside of class definition
102 * Make get_retx_mcs() into regular function
103 * MCS: remove unused function
104 * Debian: bump copyright year
105 * Use unique NSEI/BVCI/NSVCI in TBF tests
106 * MS store: move test helper to unit test
107 * Explicitly clean up BTS singleton
108 * MCS: move HeaderType enum outside of class definition
109 * MCS: use value_string for conversion
110 * TBF-DL: log MCS as string
111 * Fix TA index encoder
112 * MCS: move Mode enum outside of class definition
113 * MCS: add mcs_is_*() helpers
114 * MCS: add Channel Coding Command encoder
115 * Fix Channel Coding Command for MCS
116 * Rewrite Packet Uplink IA Rest Octets for MBA
117 * Rewrite Packet Uplink IA Rest Octets for SBA
118 * Use Timing Advance Index in UL assignments
119 * TBF: update MCS counters
120 * TBF-DL: cosmetic update for helper routines
121 * Update IA Rest Octets encoding
122 * TS alloc: expand tests log
123 * vty: add commands to show TBF of a certain kind
124 * Update MCS selection for retransmission
125 * cosmetic: use const pointer for bts_data
126 * Add test for MS mode and (M)CS settings
127 * Use libosmocore for IMSI parsing
128
129 [ Harald Welte ]
130 * Mark gprs_ns_reconnect() as static (not used outside of C file)
131 * Optionally Use the NS Sub-Network-Service (SNS) on Gb
132 * pcu_l1_if: Fix erroneous endian-swapping of the CellID
133 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
134 * gprs_debug: Use named initializers and explicit array indicies
135 * bssgp: Fix dead code: PDUT_STATUS can never reach this part
136
137 [ JF Dionne ]
138 * encoding: Fixes TMSI vs MI bit selection in repeated page info
139
140 [ Oliver Smith ]
141 * tests: use -no-install libtool flag to avoid ./lt-* scripts
142 * debian: create -doc subpackage with pdf manuals
143 * contrib/jenkins.sh: run "make maintainer-clean"
144
145 [ Daniel Willmann ]
146 * Include pdch.h in bts.h even if we're not compiling C++
147 * oc2g: Remove custom alarms
148 * oc2g: Change log type (Litecell15->Oc2g)
149 * jenkins.sh: Add oc2g build support
150 * manuals: Add script to regenerate vty/counter documentation
151 * manuals: Update VTY documentation
152
153 [ Jean-Francois Dionne ]
154 * Initial commit for OC-2G support.
155
156 [ Minh-Quang Nguyen ]
157 * OC-2G: Fix missing header
158 * OC-2G: Fix TA adjustment
159 * OC-2G: Always use positive TA information provided in PH-RA-IND
160
161 [ Alexander Couzens ]
162 * gprs_bssgp_pcu: make gprs_bssgp_ns_cb public
163 * gprs_bssgp_pcu: explicit allocate & initialize bssgp_nsi instance
164 * encoding: correct encoding of CRBB in ACK/NACK when not byte aligned
165 * encoding: use `/* */` for comments instead of `#if 0 #endif`
166 * egprs_rlc_compression: fix white spaces
167 * tests/BitcompTest: fix wording in log message
168 * rlc: replace int with uint16_t
169 * Encoding: drop struct gprs_rlcmac_bts* from all functions
170 * decompress_crbb: add length argument for search_runlen
171 * Encoding: write_packet_ack_nack_desc_egprs: don't use a reference for rest_bits
172 * bts.cpp: ensure left-shift operation does not exceed uint32_t
173 * Encoding: use uint16_t when interacting with the window object
174 * Encoding: ACK/NACK: always encode with length field present
175
176 [ Keith ]
177 * Cosmetic: Osmcoom -> Osmocom
178
179 [ Vadim Yanitskiy ]
180 * src/pcu_l1_if.cpp: fix: properly pass measurements from PCUIF
181 * gprs_bssgp_pcu_rx_dl_ud(): fix: BSSGP_IE_IMSI is optional
182 * gprs_bssgp_pcu.cpp: check return code of gsm48_mi_to_string()
183 * gprs_bssgp_pcu_rx_dl_ud(): use OSMO_IMSI_BUF_SIZE
184
185 [ Thorsten Alteholz ]
186 * fix spelling errors detected by lintian
187
188 [ Eric Wild ]
189 * ubsan: fix shift
190
191 [ Pau Espin Pedrol ]
192 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
193 * Require newer libosmocore to avoid compile failures
194
195 -- Pau Espin Pedrol <pespin@sysmocom.de> Wed, 07 Aug 2019 21:09:53 +0200
196
Harald Welte99278b12019-01-21 19:03:52 +0100197osmo-pcu (0.6.0) unstable; urgency=medium
198
199 [ Harald Welte ]
200 * debian/rules: Don't overwrite .tarball-version
201 * gprs_rlcmac_received_lost(): Fix regression / uninitialized now_tv
202 * initial checkin of manuals to public repo
203 * Add link to Asciidoc source code of manual
204 * Initial place-holder for the new Gb/IP interface documentation
205 * Gb message sequence chart: flip sides (SGSN should be right)
206 * Gb message sequence chart: Add notion of PCU unix domain socket
207 * Gb: Various spelling fixes
208 * gb: Some language improvements, formatting changes
209 * consistently use '3GPP TS' not sometimes 3GPP TS and sometimes TS.
210 * gb/NS: Clarify the language regarding the UDP port numbers / socket
211 * vty-ref: Update URI of docbook 5.0 schema
212
213 [ Pau Espin Pedrol ]
214 * Cleanup of systemd service files
215 * configure.ac: Set CXXFLAGS during --enable-sanitize
216 * Install systemd services with autotools
217 * Move examples/ to doc/examples/
218 * Install osmo-pcu.cfg to docdir/examples
219 * Allow easily disabling GFDL references
220
221 [ Stefan Sperling ]
222 * check for overlong unix socket paths
223
224 [ Max ]
225 * deb: add missing copyright file
226 * OsmoPCU: fix Gb documentation front page
227 * OsmoPCU: expand NS documentation
228 * OsmoPCU: expand BSSGP documentation
229 * OsmoPCU: add MSC chart
230
231 [ Neels Hofmeyr ]
232 * Importing history from osmo-gsm-manuals.git
233 * make clean: also remove generated image files
234 * add 'make check' target
235 * fix 'make clean': shell glob, ignore failure
236 * refactor Makefile build rules, don't use the FORCE
237
238 [ Jonathan Brielmaier ]
239 * fix various typos across all manuals
240
241 [ Philipp ]
242 * configuration: fixing typos
243
244 [ Alexander Couzens ]
245 * OsmoPCU: add rate counter documentation
246
247 [ Daniel Willmann ]
248 * Change OpenBSC mentions to OsmoBSC where applicable
249
250 [ Oliver Smith ]
251 * build manuals moved here from osmo-gsm-manuals.git
252 * Fix DISTCHECK_CONFIGURE_FLAGS override
253 * contrib/jenkins.sh: build and publish manuals
254 * contrib: fix makedistcheck with disabled systemd
255
256 -- Harald Welte <laforge@gnumonks.org> Mon, 21 Jan 2019 19:03:52 +0100
257
Pau Espin Pedrol448750e2018-07-27 21:56:39 +0200258osmo-pcu (0.5.1) unstable; urgency=medium
259
260 [ Harald Welte ]
261 * Don't register SIGHUP handler without actually handling SIGHUP
262
263 [ Pau Espin Pedrol ]
264 * tbf: Fix memset(0) on object with no trivial copy-assignment
265 * rlc: Fix memset(0) on object with no trivial copy-assignment
266 * jenkins.sh: use flag --enable-werror for sysmo and none
267 * tbf: Use incrementing id for rate_ctr_group_alloc
268 * tbf: Replace '.' in counter names with ':'
269
270 [ Stefan Sperling ]
271 * fix a one-byte stack buffer overrun in osmo-pcu
272 * read monotonic clock with clock_gettime() instead of gettimeofday()
273 * fix time-delta calculations for measurement reports
274 * change log level of "DL packet loss" log messages
275 * check bssgp_tlv_parse() return code in gprs_bssgp_pcu_rcvmsg()
276
277 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 21:56:38 +0200
278
Pau Espin Pedrolf1a334b2018-05-03 16:20:01 +0200279osmo-pcu (0.5.0) unstable; urgency=medium
280
281 [ Neels Hofmeyr ]
282 * jenkins: use osmo-clean-workspace.sh before and after build
283 * vty: skip installing cmds now always installed by default
284 * implement support for 3-digit MNC with leading zeros
285 * configure: add --enable-werror
286 * mslot_class: find_free_tfi(): use uint32_t to shift 1 << 31
287 * mslot_class: two more: use uint32_t to shift 1 << 31
288 * Revert "Use Timing Advance Index in UL assignments"
289 * Revert "Rewrite Packet Uplink Assignment"
290 * Revert "Rewrite Packet Downlink Assignment"
291 * configure: fix --enable-sysmocom-dsp and --with-sysmobts flags
292 * configure: properly quote CFLAGS in lc15 check
293 * Revert "Rewrite EGPRS Packet Uplink Assignment"
294 * use osmo_init_logging2() with proper talloc ctx
295
296 [ Minh-Quang Nguyen ]
297 * PCU: Fix TA adjustment
298 * PCU: display TA information in TBF stats
299
300 [ Max ]
301 * Remove unused parameter
302 * Move multislot table to separate file
303 * Replace '.' in counter names with ':'
304 * Fix compiler warning
305 * TBF: log timer override
306 * TBF: fix compiler warning in test
307 * TBF: expand timer logging
308 * vty: print class and TBFs for each MS
309 * DL window: constify resend_needed() function
310 * TBF: move EGPRS enablement into (U|D)L-TBF
311 * TBF-DL: fix misleading idle time check
312 * TBF: remove unused variable
313 * Remove unused includes and forward declarations
314 * Fix tests after rate_ctr change
315 * Introduce LOGTBF* for consistent logging
316 * TBF: implement independent T31xx timers
317 * TBF: add N3101 counter
318 * Fix warnings
319 * Add function to get max supported MS class
320 * Add --enable-sanitize configure option
321 * Enable sanitize for CI test
322 * Add tests for pcu_lsb()
323 * Add optional profiling support
324 * TBF: unify timer handling
325 * TBF: log timer invocation source
326 * TBF: bail out for unknown timers
327 * Fix llc_queue_size() type
328 * TBF-DL: mark rcvd_dl_ack() parameters as boolean
329 * window: move encoding into functions
330 * cosmetic: clarify coding scheme and puncturing
331 * Make TBF state private
332 * TBF: cleanup state flag handling
333 * Clarify RACH-related interfaces
334 * TBF-UL: add simpler test helper
335 * Avoid code duplication in TBF test
336 * TBF: move window parameters to UL/DL level
337 * TBF-DL: move priority computation into function
338 * TBF: unify EGPRS window calculation
339 * Don't access TBF internals in vty functions
340 * Fix jenkins.sh to match jenkins job axis filter
341 * Allocate global context for TypesTest
342 * Fix sanitizer build
343 * Rewrite EGPRS Packet Uplink Assignment
344 * Rewrite Packet Downlink Assignment
345 * Rewrite Packet Uplink Assignment
346 * Use Timing Advance Index in UL assignments
347 * Allow specifying sysmocom headers explicitly
348 * TBF: log source of state transitions
349 * jenkins.sh: Disable building doxygen for deps
350 * Set V_N and V_B to known initial state
351 * TBF: add dedicated log categories
352 * TBF: make UL/DL state internal
353 * TBF: make UL ack state internal
354 * TBF: make poll state internal
355 * TBF: adjust test log levels
356 * Add tests for find_multi_slots()
357 * AllocTest: adjust test_alloc_b()
358 * AllocTest: expand test output
359 * AllocTest: remove assumption on max MS class
360 * Add multislot classes from latest spec
361 * cosmetic: fix whitespace issue with include files
362 * TBF: decrease L1 logging verbosity in test
363 * TBF: override send function via linker option
364 * Simplify TS alloc: adjust allocator signatures
365 * Simplify TS alloc: fix allocation calls
366 * Simplify TS alloc: avoid TS reassignment
367 * Simplify TS alloc: use defines for constants
368 * Simplify TS alloc: adjust function signatures
369 * TS alloc: print suggested TRX on allocation errors
370 * Simplify TS alloc: internalize TRX check
371 * TBF: decrease logging verbosity for traffic
372 * TBF: add helpers for assignment type handling
373 * TBF: show assignment kind in vty
374 * vty: drop unused function
375 * RACH: improve single block detection
376 * TBF: move common test code into functions
377 * emu: use libosmocore definitions
378 * Use explicit type for pcu_lsb()
379 * Move paging generation into PDCH
380 * Move include guard to the top
381 * Update header includes
382 * Simplify TS alloc: split off RX mask computation
383 * Simplify TS alloc: separate capacity computation
384 * Simplify TS alloc: split allocation
385 * Simplify TS alloc: split USF/UL allocation
386 * Move PDCH-related functions into separate files
387 * Simplify TS alloc: don't use PDCH for free TFI
388 * Simplify TS alloc: constify max dl slot func
389 * TBF: make network counters internal
390 * Simplify TS alloc: move slot assignment
391 * Simplify TS alloc: move slot check into functions
392
393 [ Pau Espin Pedrol ]
394 * Print error cause of pcu socket connect failure
395 * gprs_bssgp_pcu.cpp: Comment unused function parse_ra_cap
396
397 [ Stefan Sperling ]
398 * Make osmo-pcu wait for BTS to become available at start-up time.
399 * improve documentation of Encoding::write_paging_request()
400
401 [ Alexander Couzens ]
402 * pcuif_proto.h: fix whitespaces and indention
403 * pcuif_proto: add version 8 features
404
405 [ Philipp Maier ]
406 * cosmetic: remove runaway semicolon
407 * pcu_l1_if: add frame number to log output
408 * tbf: add frame number to log output
409
410 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:20:00 +0200
411
Harald Welted34ec1b2017-10-29 12:03:05 +0100412osmo-pcu (0.4.0) unstable; urgency=medium
413
414 [ Holger Hans Peter Freyther ]
415 * Initial release.
416
417 [ Max ]
418 * Use value string check from osmo-ci
419 * cosmetic: tighten direct-phy related code
420 * Support receiving SI13 from BTS
421 * Move gsmtap and accounting into separate function
422 * cosmetic: convert explicit warnings to fixme/todo
423 * Assert valid CS
424 * TBF-DL: extend index check for RLC block copy
425 * TS alloc: properly count UL slots
426 * cosmetic: reformat multislot classes table
427
428 [ Philipp Maier ]
429 * gb: allow only packets from a specific SGSN
430
431 [ Harald Welte ]
432 * tests: Don't use private version of log_info but global gprs_log_info
433 * Call osmo_init_logging() before static BTS constructor
434 * Forward GPRS SUSPEND REQ from BTS to SGSN using BSSGP
435 * Debian: Cosmetic changes to control file; add better Description
436 * Debian: print test results in case of failure + clean-up autotest
437 * Debian: migrate from DEB_BUILD_HARDENING to DEB_BUILD_MAINT_OPTIONS
438 * Debian: upgrade to debhelper 9 / Standards 3.9.8
439
440 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 12:03:05 +0100
441
Maxd78adfb2017-08-24 13:53:25 +0200442osmo-pcu (0.3.0) UNRELEASED; urgency=medium
Holger Hans Peter Freyther97e48a32016-04-01 19:21:16 +0200443
444 * Initial release.
445
446 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 01 Apr 2016 18:59:00 +0200