blob: 9cbafbedea91607b98a13943bd9cad3c5ad2ed7d [file] [log] [blame]
Oliver Smith9d5fadc2020-05-14 11:49:52 +02001#
2# spec file for package osmo-pcap
3#
4# Copyright (c) 2015, Martin Hauke <mardnh@gmx.de>
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18Name: osmo-pcap
19Version: 0.1.2.0
20Release: 0
21Summary: Osmocom's PCAP client and server
22License: AGPL-3.0-or-later AND GPL-2.0-or-later
23Group: Productivity/Telephony/Servers
24URL: https://osmocom.org/projects/osmo-pcap
25Source: %{name}-%{version}.tar.xz
26BuildRequires: autoconf
27BuildRequires: automake >= 1.6
28BuildRequires: libpcap-devel
29BuildRequires: libtool
30BuildRequires: pkgconfig
31BuildRequires: pkgconfig(gnutls)
32BuildRequires: pkgconfig(libosmocore) >= 0.11.0
33BuildRequires: pkgconfig(libosmogb)
34BuildRequires: pkgconfig(libosmogsm) >= 0.11.0
35BuildRequires: pkgconfig(libosmovty) >= 0.11.0
36BuildRequires: pkgconfig(libzmq) >= 3.2.2
37
38%description
39Osmocom tools to help with pcap tracing.
40Run osmo_pcap_client locally and send traces to a different system.
41
42%prep
43%setup -q
44
45%build
46echo "%{version}" >.tarball-version
47autoreconf -fi
48%configure \
49 --docdir=%{_docdir}/%{name} \
50 --with-systemdsystemunitdir=%{_unitdir}
51make %{?_smp_mflags}
52
53%install
54%make_install
55
56%preun
57%service_del_preun osmo-pcap-client.service osmo-pcap-server.service
58
59%postun
60%service_del_postun osmo-pcap-client.service osmo-pcap-server.service
61
62%pre
63%service_add_pre osmo-pcap-client.service osmo-pcap-server.service
64
65%post
66%service_add_post osmo-pcap-client.service osmo-pcap-server.service
67
68%check
69make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
70
71%files
72%license COPYING
73%doc AUTHORS
74%doc %{_docdir}/%{name}/examples
75%dir %{_sysconfdir}/osmocom
76%config(noreplace) %{_sysconfdir}/osmocom/osmo-pcap-client.cfg
77%config(noreplace) %{_sysconfdir}/osmocom/osmo-pcap-server.cfg
78%{_bindir}/osmo-pcap-client
79%{_bindir}/osmo-pcap-server
80%{_unitdir}/osmo-pcap-client.service
81%{_unitdir}/osmo-pcap-server.service
82%dir %{_datadir}/%{name}
83%{_datadir}/%{name}/osmo_pcap_clean_old
84
85%changelog