blob: 6297fcbefd299933f12737b81c8afe4cb75b2db7 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# This has to be exported to make some magic below work.
export DH_OPTIONS
# Maybe we require some moreadvanced testing in the future
PCAP_CFLAGS="-I/usr/include"
PCAP_LIBS="-lpcap"
%:
dh --with autoreconf $@
override_dh_auto_configure:
dh_auto_configure -- \
--with-pcap-config=/bin/false \
PCAP_CFLAGS=$(PCAP_CFLAGS) \
PCAP_LIBS=$(PCAP_LIBS)