blob: 686288814ed0ed3efd468820a5534d12c7e8d232 [file] [log] [blame]
#!/usr/bin/make -f
DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
#export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# Maybe we require some moreadvanced testing in the future
PCAP_CFLAGS="-I/usr/include"
PCAP_LIBS="-lpcap"
%:
dh $@ --with autoreconf --fail-missing
override_dh_auto_configure:
dh_auto_configure -- \
--with-pcap-config=/bin/false \
PCAP_CFLAGS=$(PCAP_CFLAGS) \
PCAP_LIBS=$(PCAP_LIBS)
override_dh_auto_install:
dh_auto_install $@
install -d -m 0755 $(CURDIR)/debian/osmo-pcap-client/etc/osmo-pcap/
install -m 0644 $(CURDIR)/contrib/osmo-pcap-client.cfg $(CURDIR)/debian/osmo-pcap-client/etc/osmo-pcap
install -d -m 0755 $(CURDIR)/debian/osmo-pcap-server/etc/osmo-pcap/
install -m 0644 $(CURDIR)/contrib/osmo-pcap-server.cfg $(CURDIR)/debian/osmo-pcap-server/etc/osmo-pcap
install -d -m 0755 $(CURDIR)/debian/osmo-pcap-server/etc/cron.daily/
install -m 0755 $(CURDIR)/contrib/osmo_pcap_clean_old $(CURDIR)/debian/osmo-pcap-server/etc/cron.daily/
override_dh_strip:
dh_strip -posmo-pcap-client --dbg-package=osmo-pcap-client-dbg
dh_strip -posmo-pcap-server --dbg-package=osmo-pcap-server-dbg